红帽企业 Linux 3

用于 x86、Itanium™、和 AMD64 体系的安装指南

版权 © 2003 Red Hat, Inc.

ISBN: N/A
目录
介绍
1. 文档约定
2. 如何使用本书
2.1. 我们需要用户的反馈！
3. 辅助功能的解决办法
1章 . Itanium 系统特有信息
1.1. Itanium 系统安装总览
1.2. Itanium 系统 — EFI Shell
1.2.1. Itanium 系统 — EFI 设备名称
1.2.2. Itanium 系统 — EFI 系统分区
2章 . 安装前的准备工作
2.1. 其它指南手册的位置
2.2. 注册您的产品
2.3. 你的硬件兼容吗？
2.4. 你有足够的磁盘空间吗？
2.5. 你能用光盘安装吗？
2.5.1. 其它引导方法
2.5.2. 制作安装引导光盘
2.5.3. 制作安装引导盘
2.6. 筹备网络安装
2.6.1. 使用 ISO 映像进行 NFS 安装
2.7. 筹备硬盘驱动器安装
3章 . 系统需求表
4章 . 安装红帽企业 Linux
4.1. 图形化安装程序用户界面
4.1.1. 关于虚拟控制台的注记
4.2. 文本模式安装程序用户界面
4.2.1. 使用键盘来导航
4.3. 启动安装程序
4.3.1. 在 x86 和 AMD64 系统上引导安装程序
4.3.2. 在 Itanium 系统上引导安装程序
4.3.3. 其它引导选项
4.4. 选择一种安装方法
4.5. 从光盘中安装
4.5.1. 如果没有发现 IDE 光盘怎么办？
4.6. 从硬盘安装
4.7. 执行网络安装
4.8. 通过 NFS 安装
4.9. 通过 FTP 安装
4.10. 通过 HTTP 安装
4.11. 欢迎使用红帽企业 Linux
4.12. 语言选择
4.13. 键盘配置
4.14. 鼠标配置
4.15. 磁盘分区设置
4.16. 自动分区
4.17. 为你的系统分区
4.17.1. 硬盘驱动器的图形化表示
4.17.2. Disk Druid 的按钮
4.17.3. 分区字段
4.17.4. 推荐的分区方案
4.17.5. 添加分区
4.17.6. 编辑分区
4.17.7. 删除一个分区
4.18. x86 和 AMD64 系统的引导装载程序配置
4.18.1. 高级引导装载程序配置
4.18.2. 救援模式
4.18.3. 其它可选的引导装载程序
4.18.4. SMP 母板，GRUB，和 LILO
4.19. 网络配置
4.20. 防火墙配置
4.21. 语言支持的选择
4.22. 时区配置
4.23. 设置根口令
4.24. 软件包组的选择
4.25. 准备安装
4.26. 安装软件包
4.27. 视频卡配置
4.28. X 配置 — 显示器和定制
4.28.1. 配置你的显示器
4.28.2. 定制配置
4.29. 安装完成
4.30. Itanium 系统 — 引导机器和安装后的设置
4.30.1. 安装后引导装载程序选项
4.30.2. 自动引导红帽企业 Linux
A. 给你目前的系统升级
A.1. 升级意味着什么
A.2. 给你的系统升级
A.3. 升级引导装载程序配置
A.3.1. 创建一个新的引导装载程序配置
A.3.2. 高级引导装载程序配置
A.3.3. 救援模式
A.3.4. 其它可选的引导装载程序
A.3.5. SMP 母板，GRUB，和 LILO
A.4. 升级软件包
A.5. 升级完成
B. 删除红帽企业 Linux
C. 安装红帽企业 Linux 中的故障排除
C.1. 你无法引导红帽企业 Linux
C.1.1. x86 特定的说明 — 你无法从光盘中引导吗？
C.1.2. x86 特定的说明 — 你无法从引导盘中引导吗？
C.1.3. 无法使用 RAID 卡来引导
C.1.4. 系统显示了信号 11 错误
C.2. 安装起始部分的问题
C.2.1. 没有检测到你的鼠标
C.2.2. 引导入图形化安装遇到问题
C.3. 安装过程中的问题
C.3.1. “No devices found to install Red Hat Enterprise Linux”错误消息
C.3.2. 没有软驱却要保存回溯追踪消息
C.3.3. 分区表问题
C.3.4. 使用剩余空间
C.3.5. x86 系统用户会遇到的其它分区问题
C.3.6. Itanium 系统用户会遇到的其它分区问题
C.3.7. 看到 Python 错误
C.4. 安装后的问题
C.4.1. 在基于 x86 系统的 GRUB 图形化屏幕中遇到问题
C.4.2. 在基于 x86 系统的 LILO 图形化屏幕中遇到问题
C.4.3. 引导入图形环境
C.4.4. 引导入 X 窗口系统（GUI）的问题
C.4.5. 登录时的问题
C.4.6. 你的内存不能够被识别吗？
C.4.7. 你的打印机无法运行
C.4.8. 配置声卡遇到问题
C.4.9. 基于 Apache 的 httpd 服务或 Sendmail 在启动时被挂起
C.4.10. NVIDIA 芯片集的问题
D. 磁盘分区简介
D.1. 硬盘基本概念
D.1.1. 不是你写入什么，而是你怎么写入
D.1.2. 分区：将一个驱动器变成多个驱动器
D.1.3. 分区内的分区 — 扩展分区概述
D.1.4. 为红帽企业 Linux 腾挪空间
D.1.5. 分区命名方案
D.1.6. 磁盘分区以及其它操作系统
D.1.7. 磁盘分区和挂载点
D.1.8. 多少个分区？
D.1.9. 最后一个疑问：使用 GRUB 还是 LILO
E. 驱动程序介质
E.1. 为什么需要驱动程序盘
E.1.1. 驱动程序介质到底是什么
E.1.2. 如何获取驱动程序介质
E.1.3. 在安装过程中使用驱动程序映像
F. 其它引导选项
G. 关于 Itanium 和 Linux 的额外资料
索引
后记
前进
介绍


其它引导选项

红帽企业 Linux 3: 用于 x86、Itanium™、和 AMD64 体系的安装指南
后退 前进

附录 F. 其它引导选项

该附录讨论红帽企业 Linux 安装程序中提供的附加引导和内核引导选项。

要使用这里提到的任何一个引导选项，在安装 boot: 提示下键入你想启用的命令。

引导时的命令参数

askmethod

该命令请你选择从红帽企业 Linux 光盘中引导时你想使用的安装方法。

apic

这个 x86 引导命令绕过在 Intel 440GX 芯片集 BIOS 中可能会普遍遇到的错误，它只应该使用安装程序内核来执行。

apm=allow_ints

这个 x86 引导命令改变挂起服务的处理方式（对于某些便携电脑来说可能是必要的）。

apm=off

这个 x86 引导命令禁用 APM（高级电源管理）。它很有用处，因为某些 BIOS 的电源管理（APM）问题重重，很容易崩溃。

apm=power_off

这个 x86 引导命令会使红帽企业 Linux 默认关闭（断电）系统。它对于不默认关闭的 SMP 系统来说有用。

apm=realmode_power_off

某些 BIOS 在基于 x86 的系统试图关闭（断电）机器时崩溃。该命令把操作方法从 Windows NT 方式改为 Windows 95 方式。

dd

这个参数会导致安装程序提示你使用驱动程序盘。

dd=url

这个参数会导致安装程序提示你使用来自指定 HTTP、FTP、或 NFS 网络地址的驱动程序映像。

display=IP:0

该命令允许远程显示转发。其中，IP 应该用你想充当显示系统的 IP 地址替换。

在你想用来显示的系统上，你必须执行 xhost +remotehostname 命令，这里的 remotehostname 是你运行显示命令的主机名称。使用 xhost +remotehostname 命令限制了对远程显示终端的访问，而且不允许来自没有被确切授予远程访问权的人员和系统的访问。

driverdisk

该命令执行的功能和 dd 命令相同，它还会在红帽企业 Linux 安装中提示你使用驱动程序盘。

ide=nodma

该命令禁用所有 IDE 设备上的 DMA，在遇到 IDE 相关的问题时可能有用。

linux upgradeany

该命令会放松对你的 /etc/redhat-release 文件的某些检查。如果你的 /etc/redhat-release 文件已从默认内容被改变了。在试图升级红帽企业 Linux 3 时就可能会找不到你的红帽企业 Linux 安装。只有在你现存的红帽企业 Linux 安装没有被检测到时才使用该选项。

mediacheck

该命令给你提供测试安装源完好性的机会（如果使用的是基于 ISO 的方法）。该命令可用于光盘、DVD、硬盘 ISO、和 NFS ISO 安装方法。在试图安装前先校验 ISO 映像的完整性会帮助你避免在安装中经常遇到的问题。

mem=xxxM

该命令允许你超越内核在机器上检测到的内存数量。在某些较老的仅检测到16MB的系统上，以及某些较新的视频卡与主内存共享视频内存的机器上，你可能需要使用该命令。当执行这项命令时，xxx 应该用以MB为单位的内存数量替换。

nmi_watchdog=1

该命令启用内建的内核死锁检测器。它可以用来调试硬性内核锁定。通过执行定期的 NMI（不可屏蔽中断）中断，内核可以监控 CPU 是否被锁，并在需要时打印出调试消息。

noapic

这个 x86 引导命令告诉内核不要使用 APIC 芯片。它对于某些带有不良 APIC（如 Abit BP6）或错误重重的 BIOS 的母板有帮助。

noht

这个 x86 引导命令禁用超线程。

nofb

该命令禁用帧缓冲支持，允许安装程序在文本模式中运行。它可能是带有某些读屏硬件的辅助功能所必需的。

nomce

这个 x86 引导命令禁用在 CPU 上执行的自我诊断检查。内核默认启用 CPU 的自我诊断（称为机器检查意外，Machine Check Exception）。在一些早期的 Compaq Pentium 系统上，你可能需要这个选项，因为它们不能正确支持处理器错误检查。几个其它便携电脑，显著的是那些使用 Radeon IGP 芯片集的便携电脑，可能也需要这个选项。

nopass

该命令禁止把键盘和鼠标信息传递给安装程序的第二阶段。当执行网络安装时，它可以用来在安装的第二阶段测试鼠标和键盘配置屏幕。

nopcmcia

该命令忽略系统上的任何 PCMCIA 控制器。

noprobe

该命令禁用硬件检测，相反，它提示用户来提供硬件信息。

noshell

该命令禁止在安装时进入第二虚拟控制台上的 shell。

nousb

该命令禁止在安装中载入 USB 支持。如果安装程序在进程早期容易挂起，该命令就能够起到作用。

nousbstorage

该命令在安装程序的载入程序中禁止载入 usbstorage 模块。它对 SCSI 系统上的设备排序可能有帮助。

reboot=b

这个 x86 和 AMD64 命令改变内核试图重新引导机器的方式。如果系统关闭时内核被挂起，该命令会导致系统被成功地重新引导。

rescue

该命令将会运行救援模式。关于救援模式的详细信息，请参阅《红帽企业 Linux 系统管理指南》。

resolution=

告诉安装程序要运行哪种视频模式。它接受所有标准的分辨率，如 640x480、800x600、1024x768 等等。

serial

该命令启用串行控制台支持。

skipddc

这个 x86 引导命令跳过 ddc 显示器探测，这种探测在某些系统上会导致问题。

text

该命令禁用图形化安装程序，并强制安装程序在文本模式下运行。

updates

该命令会提示你插入包含更新（错误修正）的软盘。如果你执行的是网络安装，并且已把更新映像存放在服务器上的 RHupdates/ 目录下，则不需要使用该命令。

vnc

该命令允许你从 VNC 服务器中安装。

vncpassword=

该命令设置用来连接 VNC 服务器的口令。

后退 | 起点 | 前进
驱动程序介质 |  | 关于 Itanium 和 Linux 的额外资料


驱动程序介质

后退 前进

附录 E. 驱动程序介质

E.1. 为什么需要驱动程序盘

在红帽企业 Linux 安装程序被载入的时候，你可能会看到向你索取驱动程序介质的屏幕。驱动程序介质屏幕在下面几种情况中最常出现：

  • 如果你需要从网络设备中执行安装

  • 如果你需要从块设备中执行安装

  • 如果你需要从 PCMCIA 设备中执行安装

  • 如果你是通过在 boot: 提示后输入 linux dd 来运行安装程序（Itanium 用户应该输入 elilo linux dd）

  • 如果你在一个不具备任何 PCI 设备的计算机上运行安装程序

E.1.1. 驱动程序介质到底是什么

驱动程序介质能够为安装程序可能支持也可能不支持的硬件添加支持。它可以是由红帽制作的，也可以根据在互联网上发现的驱动程序自制，还可以是硬件制造商配给硬件的软盘或光盘。

如果你需要使用某一特别设备以便安装红帽企业 Linux，你就可能需要驱动程序介质。驱动程序可以用在网络安装（NFS）；使用 PCMCIA 或块设备的安装；以及使用非标准的或非常新型的光盘驱动器、SCSI 适配器、NIC、和其它罕见设备的安装。

注记 | 注记
 | 如果在你的系统上安装红帽企业 Linux 时不需要某个不被支持的设备，请继续安装进程。一旦安装完毕，你可以添加对这个新设备的支持。

E.1.2. 如何获取驱动程序介质

驱动程序映像可以从好几种渠道获得。它们可能会被包括在红帽企业 Linux，或者可从软件或硬件厂商的网站中获取。如果你怀疑你的系统可能会需要驱动程序，你应该在开始安装红帽企业 Linux 之前创建驱动程序软盘或光盘。

对于使用基于 x86 的系统的用户，红帽企业 Linux 的第一张光盘包括了驱动程序盘的映像（images/drvnet.img — 网卡驱动程序，以及 images/drvblock.img — 用于 SCSI 控制器的驱动程序）。这些映像包括许多常见和罕见的驱动程序。

窍门 | 窍门
 | 你还可能通过一个网络文件来使用驱动程序映像。与其使用 linux dd 引导命令，你可以使用 linux dd=url 命令，把这里的 url 替换成驱动程序映像所用的 HTTP、FTP、或 NFS 地址。

你还可以从以下红帽的网站中的「Bug Fixes」部分下查到有关特制的驱动程序盘的信息：

http://www.redhat.com/support/errata/

偶尔，在红帽企业 Linux 版本发行之后，会出现一些新的通用硬件，这些硬件无法使用在安装程序中已有的驱动程序或包括在红帽企业 Linux 第一张光盘中的驱动程序盘映像。在这种情况下，红帽网站可能会提供到这些驱动程序映像的链接。

E.1.2.1. 根据映像文件创建驱动程序盘

如果你有一份驱动程序的映像，你需要将它写入磁盘，这可以在 DOS 或红帽企业 Linux 环境中做到。在 Itanium 系统上，磁盘必须是 LS-120。

要在红帽企业 Linux 环境下根据驱动程序盘映像来制作驱动程序盘：

  1. 在第一个软盘（或 LS-120 磁盘）驱动器中插入一张空白的、格式化的软盘（Itanium 系统用户则插入 LS-120 磁盘）。

  2. 在含有驱动程序盘映像（如：drvnet.img）的同一目录下，以根用户身份键入 dd if=drvnet.img of=/dev/fd0 。

要在 DOS 环境下根据驱动程序盘映像来制作驱动程序盘：

  1. 在软盘（或 LS-120 磁盘）驱动器中插入一张空白的、格式化的软盘（Itanium 系统用户则插入 LS-120 磁盘）。

  2. 在含有驱动程序盘映像（如：drvnet.img）的同一目录下，在命令行中键入 d:\dosutils\rawrite drvnet.img a:，此处的 d: 是光盘设备的驱动器盘符。

E.1.3. 在安装过程中使用驱动程序映像

如果你需要使用驱动程序映像，例如在 PCMCIA 设备或 NFS 安装过程中，安装程序会在需要时提示你插入驱动程序（磁盘、光盘或文件名称）。

然而，在某些情况下，你必须明确指示红帽企业 Linux 安装程序在安装过程中载入并使用某个驱动程序盘。

要指定载入你创建的驱动程序磁盘，请首先从红帽企业 Linux 的第一张光盘（或安装引导盘）中引导安装进程。对于基于 x86 系统的用户，在 boot: 提示符下输入 linux dd。引导安装程序的细节请参阅第 4.3.1 节。对于 Itanium 系统，在 Shell> 提示符下输入 elilo linux dd。引导安装程序的细节请参阅第 4.3.2 节。

红帽企业 Linux 安装程序会请你插入驱动程序盘。一旦驱动程序盘被读取，它会把那些驱动程序应用到稍后的安装进程中在你的系统上发现的硬件上。

后退 | 起点 | 前进
磁盘分区简介 |  | 其它引导选项


关于 Itanium 和 Linux 的额外资料

后退 前进

附录 G. 关于 Itanium 和 Linux 的额外资料

其它和在 Itanium 系统上运行红帽企业 Linux 相关的参考资料在万维网上可以查到。几个可用的资源如下所列：

  • http://www.linuxia64.org/ — Itanium Linux 项目的官方网站主页

  • http://www.intel.com/products/server/processors/server/itanium/index.htm?iid=sr+itanium& — 关于 Itanium 处理器的 Intel 网站

  • http://developer.intel.com/technology/efi/index.htm?iid=sr+efi& — 关于可扩展固件界面（Extensible Firmware Interface，EFI）的 Intel 网站

  • http://www.itanium.com/eBusiness/products/itanium/ — 关于 Itanium 2 处理器的 Intel 网站

后退 | 起点 | 前进
其它引导选项 |  | 索引


磁盘分区简介

后退 前进

附录 D. 磁盘分区简介

注记 | 注记
 | 本附录对于非 x86 体系不一定适用。然而，在这里提及的一般原理可能有用。

磁盘分区长期以来一直是个人计算机领域中的一项基本必备知识。然而，由于越来越多的人开始购买带有预安装的操作系统的计算机，相对来说，只有极少人理解分区的原理。本章试图解释分区的原因以及用法，从而使你能够尽可能简便轻松地安装红帽企业 Linux。

如果你对磁盘分区已有足够的了解，你可以直接跳到第 D.1.4 节来阅读关于如何腾出磁盘空间来准备红帽企业 Linux 安装的信息。本节还将讨论 Linux 系统使用的分区命名方案，与其它操作系统共用磁盘，以及其它相关课题。

D.1. 硬盘基本概念

硬盘功能极为简单 — 它们被用来可靠地储存及检索数据。

在讨论磁盘分区之类的问题时，了解一些基础硬件知识至关重要。不幸的是，这又极容易使人陷入小节，忽略全局。因此，本附录使用了一种简化的磁盘驱动器图表来解释磁盘分区后的情形。图 D-1显示了一个崭新的、未曾使用的磁盘驱动器。

图 D-1. 未使用过的磁盘驱动器

没什么可看的，是不是？不过，若我们仅在一个最基本的层次上讨论磁盘驱动器，此图表已足够。假设我们要在这个磁盘驱动器上面储存一些数据，就目前而言，这还不行。我们首先要做一些准备工作…

D.1.1. 不是你写入什么，而是你怎么写入

有经验的计算机用户可能对此心中有数。我们需要格式化（format）这个驱动器。格式化又称“制作文件系统（file system）”，它是一个将信息写入驱动器，在未经格式化的驱动器内的空白空间中建立秩序的过程。

图 D-2. 有文件系统的磁盘驱动器

如图 D-2所暗示，文件系统所建立的秩序牵涉到一些利弊得失：

  • 驱动器上极小的一部分可用空间被用来储存与文件系统有关的数据，这可以被视作管理费用。

  • 文件系统将剩余空间分割成小块的，大小统一的段。在 Linux 中，这些段被称为块（block）。 [1]

由于文件系统带来创建目录和文件的可能性，以上牺牲可以被看作所需付出的一个很小的代价。

还有一点值得注意的是，统一通用的文件系统并不存在。如图 D-3所示，一个磁盘驱动器上可以有许多不同类型的文件系统。你可能也猜得到，不同类型的文件系统通常是不兼容的。这意味着，支持某种文件系统（或几种相关的文件系统类型）的操作系统可能不支持其它类型的文件系统。不过，最后那句话并非是一个不折不扣的定理。例如，红帽企业 Linux 支持的文件系统类型比较广泛（包括许多其它操作系统常用的文件系统），从而使不同文件系统之间的数据交换变得容易多了。

图 D-3. 含有不同文件系统的磁盘驱动器

当然，将文件系统写入磁盘仅仅是一个开端。这个过程的目标实际上是储存并且检索数据。写入一些文件后，让我们再来看一看磁盘。

图 D-4. 已写入数据的磁盘驱动器

如图 D-4所示，某些先前空白的块现在已被写入数据。然而，单看以上图示，我们无法判定在这个驱动器上究竟有多少个文件。可能少到只有一个文件，也可能有很多文件，因为所有的文件至少要使用一个块，有些需要几个块。还有一个要注意的要点是，所使用的块不必构成一处连续的区域；使用的和未使用的块可以交错散布。这就是通称的碎段（fragmentation）。碎段会对试图改变已存分区大小有一定的影响。

如同许多与计算机相关的科技，磁盘驱动器自问世后一直在不断地变化。特别是，它们越来越大。不是实际尺寸越来越大，而是它们储存信息的能力越来越大。这种新增的容量导致了磁盘驱动器使用方法的根本改变。

D.1.2. 分区：将一个驱动器变成多个驱动器

由于磁盘驱动器容量的不断增大，一些人开始质问将所有格式化的空间并为一大块是否明智。这一类想法的动机有哲学上的，也有技术上的。从哲学角度上讲，一个较大的磁盘驱动器所提供的额外空间若超过了一定的大小似乎只会造成更多的杂乱无章。从技术角度上讲，某些文件系统不是为支持大于一定容量的磁盘驱动器而设计的。或者，某些文件系统可能会支持拥有巨大容量的较大的驱动器，但是由文件系统跟踪文件所强加于上的管理费用也随之变得过高过大。

解决这个问题的办法是将磁盘划分为分区 （partition）。每一分区都可以像一个独立的磁盘一样被访问。这是通过添加分区表（partition table）来做到的。

注记 | 注记
 | 虽然本章图表中所显示的分区表和实际磁盘驱动器是分开的，这并不完全正确。事实上，分区表被保存在磁盘的最起首，在任何文件系统或用户数据之前。但是为了清楚起见，我们在图表中将之分开。

图 D-5. 带有分区表的磁盘驱动器

如图 D-5所示，分区表被分为四个部分。每个部分都装有定义单个分区所必需的信息，这意味着分区表定义的分区不能超过四个。

每个分区表项目都包含着该分区的几项重要的特征：

  • 在磁盘上分区开始和结束的地点（起止点）

  • 分区是否“活跃”

  • 分区的类型

让我们来仔细查看一下每一个特征。起止点实际上定义了分区的大小及在磁盘上的位置。“活跃”标志是被某些操作系统的引导装载程序所用。换一句话说，标为“活跃”的分区上的操作系统将会被引导。

分区类型可能有些不易分辨。 类型是标识分区将会被如何使用的数字。如果这句话听起来有些笼统，那是因为分区类型术语本身也有些笼统。某些操作系统用分区类型来代表一种指定的系统类型，或将分区标为与某个操作系统相关联的分区，或用来指明该分区包含着可引导的操作系统，或是以上三者的结合。

到了这一步，你可能会在猜想这些附加的复杂性通常是怎样被使用的。实例请见图 D-6。

图 D-6. 只有一个分区的磁盘驱动器

在许多情况下，整个磁盘上只有一个分区，基本上是重复分区以前所使用的方法。分区表内只有一个项目，它指向分区的起点。

我们把此分区标为“DOS”类。虽然它只是列在表 D-1之中的几种可能的分区之一，但也足以达到本附录的讨论目的。

表 D-1中包括了一些常用的（和罕见的）分区类型，以及它们的十六进制数值。

分区类型 | 值 | 分区类型 | 值
Empty | 00 | Novell Netware 386 | 65
DOS 12-bit FAT | 01 | PIC/IX | 75
XENIX root | 02 | Old MINIX | 80
XENIX usr | 03 | Linux/MINUX | 81
DOS 16-bit <=32M | 04 | Linux swap | 82
Extended | 05 | Linux Native | 83
DOS 16-bit >=32 | 06 | Linux extended | 85
OS/2 HPFS | 07 | Amoeba | 93
AIX | 08 | Amoeba BBT | 94
AIX bootable | 09 | BSD/386 | a5
OS/2 Boot Manager | 0a | OpenBSD | a6
Win95 FAT32 | 0b | NEXTSTEP | a7
Win95 FAT32 (LBA) | 0c | BSDI fs | b7
Win95 FAT16 (LBA) | 0e | BSDI swap | b8
Win95 Extended (LBA) | 0f | Syrinx | c7
Venix 80286 | 40 | CP/M | db
Novell | 51 | DOS access | e1
PPC PReP Boot | 41 | DOS R/O | e3
GNU HURD | 63 | DOS secondary | f2
Novell Netware 286 | 64 | BBT | ff

表 D-1. 分区类型

D.1.3. 分区内的分区 — 扩展分区概述

经过一段时间后，四个分区很明显将不够用。随着磁盘驱动器的不断增大，配置了四个相当大的分区后仍有剩余空间的可能性会越来越大。我们需要有一些创建更多分区的方法。

请进入扩展分区的世界。在表 D-1中你可能已注意到一种分区类型是“扩展”（Extended）。它就是位于扩展分区核心的分区类型。

当一个分区被建立，其类型被设为“扩展”时，扩展分区表也被创建。简而言之，扩展分区就像一个独立的磁盘驱动器 — 它有自己的分区表，该表指向一个或多个分区——它们现在被称为逻辑分区（logical partitions），与四个主分区（primary partitions） 相对，并完全包含在扩展分区之内。图 D-7显示了一个磁盘驱动器，其中有一个主分区和一个包含两个逻辑分区的扩展分区（以及一些未分区的空闲空间）。

图 D-7. 带有扩展分区的磁盘驱动器

如图表中所暗示，主分区与逻辑分区之间有一个区别 — 主分区只能有四个，但是可以存在的逻辑分区数量却无固定限制。不过，鉴于分区在 Linux 中可被进入的方式，你应该避免在一个磁盘驱动器上定义 12 个以上逻辑分区。

现在，我们已经大致讨论了分区概念，让我们来看一看如何将这些知识应用到安装红帽企业 Linux 上。

D.1.4. 为红帽企业 Linux 腾挪空间

当你试图为你的硬盘重新分区时，有三种可能的情况：

  • 有可用的未分区的空闲空间

  • 有可用的未使用过的分区

  • 被活跃使用的分区内有可用的空闲空间

让我们依次来看一看每一种情况。

注记 | 注记
 | 请记住，以下图解是为清晰起见而经简化的，它们并不反映当你实际安装红帽企业 Linux 时所会遇到的确切分区布局。

D.1.4.1. 使用未经分区的空闲空间

在这种情况下，已定义的分区没有扩展到整个硬盘，它没有包括那些不属于任何定义分区的未分配的空间。图 D-8显示了可能出现的情境。

图 D-8. 带有未分区的空闲空间的磁盘驱动器

在图 D-8中，1 代表带有未被拨发的空间的未定义分区，2 代表带有已被拨发的空间的已定义分区。

如果细想一下，你就会认识到一个未经使用的硬盘也属这种类型。唯一的区别是后者的全部空间都不属于任何定义的分区。

在以上任一情况下，你都可以从未经使用的空间中创建必要的分区。不幸的是，这种情况虽然简单，出现的可能性却不大（除非你为红帽企业 Linux 特意购买了一个新磁盘）。多数预安装的操作系统被配置为占据磁盘驱动器上所有可用空间（参阅第 D.1.4.3 节）。

接下来，我们将讨论一种更普遍的情况。

D.1.4.2. 使用一个未使用过的分区中的空间

在这种情况下，可能有一个或多个分区你已不再使用。可能你过去用过其它的操作系统，而你拨给它的分区似乎已不再被使用。图 D-9显示了这种情况。

图 D-9. 带有未使用分区的磁盘驱动器

在图 D-9中，1 代表未使用的分区，2 代表为 Linux 重新拨发未使用过的分区。

如果你发现自己处于这种情况，你可以使用那些拨给未使用分区的空间。首先，你应该删除该分区，然后在其上创建相应的 Linux 分区。你可以在安装过程中选择手工创建分区，然后在创建新分区前删除该分区。

D.1.4.3. 使用活跃分区中的空闲空间

这是最常见的情况。不幸的是，这也是最难处理的情况。主要问题是，即便你有足够的空闲空间，它们目前已被分配给一个正在使用中的分区。如果你购买了一个带有预装软件的计算机，很可能整个硬盘是一个单个的带有操作系统和数据的大分区。

除了给你的系统添加一个新硬盘驱动器外，你还有以下两种选择：

破坏性重新分区

简而言之，这种方法让你删除一个大分区而创建几个小一些的分区。你可能想象得到，贮存在原来分区上的所有数据将会被破坏。这意味着你有做完全备份的必要。为你自己的利益着想，请做两个备份，并校验（如果你的备份软件提供了的话）这些备份，在你删除分区之前试着从你的备份中读取数据。

小心 小心

如果该分区上装有某类操作系统，该操作系统也需要被重新安装。需要注意的是，那些带有预装操作系统售出的计算机可能没有包括重装该系统所需的光盘介质。请在破坏你的原有分区及原有操作系统之前觉查到这一点。

为现存的软件创建了一个较小的分区后，你可以重装这些软件，恢复你的数据，然后继续安装红帽企业 Linux。图 D-10显示了这个过程完成后的情景。

图 D-10. 被破坏性重新分区的磁盘驱动器

在图 D-10中，1 代表之前的情景，2 代表之后的情景。

小心 小心

如图 D-10所示，没有正确的备份，原有分区内的所有数据将会丢失！

非破坏性重新分区

这要求你运行一个似乎可以“为所不可为”的程序：它会把大分区变小，却不会丢失该分区上的原有文件。许多人都发现这个办法既可靠又简单可行。但是哪一个软件可以帮助你达到这一目的呢？在软件市场上有好几种磁盘管理软件。你应该做一番调查来找到最适合你的情况的一种。

非破坏性分区过程是非常直捷了当的，它包括以下几个步骤：

  • 压缩和备份现存数据

  • 重新划分现存分区的大小

  • 创建新分区

接下来，我们将详细说明每一步骤。

D.1.4.3.1. 压缩现存数据

如图 D-11所示，第一步要压缩你现存分区上的数据。原因是将这些数据重新安排后，你将会在该分区“终点”后获得最多的可用空闲空间。

图 D-11. 磁盘驱动器被压缩

在图 D-11中，1 代表之前的情景，2代表之后的情景。

这一步骤至关重要。不执行这一步骤，你的数据所在位置可能会阻止分区被重新划分为想要的大小。还请注意的是，由于某种原因，某些数据不能被移动。如果情况如此（这会严重地限制你的新分区的大小），你可能会被迫在你的磁盘上进行破坏性重新分区。

D.1.4.3.2. 重新划分现存分区的大小

图 D-12显示了重新划分分区大小的实际过程。这一过程的结果要依你所使用的软件而定。多数情况下，新空出的空闲空间被用来创建一个与原有分区同类的未格式化的分区。

图 D-12. 分区大小被重新划分的磁盘驱动器

在图 D-12中，1 代表之前的情景，2代表之后的情景。

理解你所使用的重新分区软件对新空出的空间的操作是很重要的，只有这样，你才能正确地采取相应措施。在我们示范的情况中，最佳措施是删除新建的 DOS 分区，然后创建恰当的 Linux 分区。

D.1.4.3.3. 创建新分区

如前一步骤所暗示，创建新分区可能必要，也可能没必要。然而，除非你的重新分区软件知道 Linux 的存在，你很可能需要删除在重新划分分区过程中创建的分区。图 D-13显示了完成后的情景。

图 D-13. 带有最终分区配置的磁盘驱动器

在图 D-13中，1 代表之前的情景，2代表之后的情景。

注记 | 注记
 | 下列信息是基于 intel 的计算机所特有的。

为了方便用户，我们提供了 parted 工具。它是一个可免费获得的重新划分分区大小的程序。

如果你决定使用 parted 来重新给你的硬盘驱动器分区，你必须熟悉磁盘贮存区，并备份了你的计算机上的数据。这一点至关重要。你应该给你的计算机上重要的数据做两个备份。这些备份应该保存在可移介质上（如磁盘、光盘或磁带），而且你应该在继续前确定它们可以被读取。

如果你决定要使用 parted，请留意在 parted 运行后，你会有两个分区：一个是你重新划分大小的分区，另一个是 parted 用新空出的空间创建的新分区。如果你的目的是使用新空出的空间来安装 红帽企业 Linux，你应该删除新分区。你既可以使用在目前操作系统下的分区工具来删除它，也可以在安装过程中设置分区时删除它。

D.1.5. 分区命名方案

Linux 使用字母和数字的组合来指代磁盘分区。这可能有些使人迷惑不解，特别是如果你以前使用“C 驱动器”这种方法来指代硬盘及它们的分区。在 DOS/Windows 的世界里，分区是用下列方法命名的：

  • 每个分区都被检查过以便判定它是否可被 DOS/Windows 读取。

  • 如果分区类型是兼容的，它会被指派给一个“驱动器字母”。驱动器字母从“C”开始，然后依据要标签的分区数量而按字母顺序推移。

  • 驱动器字母可以用来指代那个分区，也可以用来指带分区所含的文件系统。

红帽企业 Linux 使用一种更灵活的命名方案。它所传达的信息比其它操作系统采用的命名方案更多。该命名方案是基于文件的，文件名的格式类似 /dev/xxyN。

下面说明了解析分区命名方案的方法：

/dev/

这个字串是所有设备文件所在的目录名。因为分区位于硬盘上，而硬盘是设备，所以这些文件代表了在/dev/上所有可能的分区。

xx

分区名的前两个字母标明分区所在设备的类型。通常是 hd （IDE 磁盘）或 sd（SCSI 磁盘）。

y

这个字母标明分区所在的设备。例如，/dev/hda（第一个 IDE 磁盘）或 /dev/sdb（第二个 SCSI 磁盘）

N

最后的数字代表分区。前四个分区（主分区或扩展分区）是用数字从 1 排列到 4。逻辑分区从 5 开始。例如，/dev/hda3 是在第一个 IDE 硬盘上的第三个主分区或扩展分区；/dev/sdb6 是在第二个 SCSI 硬盘上的第二个逻辑分区。

注记 | 注记
 | 该命名方案中没有表明分区类型的地方；与 DOS/Windows 不同，所有分区都可在红帽企业 Linux 下被识别。当然，这并不是说红帽企业 Linux 能够访问每一类分区上的数据，但是在许多情况下，访问专用于另一操作系统的分区上的数据是可能的。

请切记以上信息；它会帮助你在设置红帽企业 Linux 所需分区时更容易地理解许多步骤。

D.1.6. 磁盘分区以及其它操作系统

如果你的红帽企业 Linux 分区将会与其它操作系统所用的分区共享一个硬盘，多数情况下，应该没什么问题。不过，某类 Liunx 和其它操作系统的组合需要特别加以注意。

D.1.7. 磁盘分区和挂载点

令许多 Linux 的新用户感到困惑的一个地方是各分区是如何被 Linux 操作系统使用及访问的。它在 DOS/Windows 中相对来说较为简单。每一分区有一个“驱动器字母”，你用恰当的驱动器字母来指代相应分区上的文件和目录。

这与 Linux 处理分区及磁盘贮存问题的方法截然不同。其主要的区别在于，Linux 中的每一个分区都是构成支持一组文件和目录所必需的贮存区的一部分。它是通过挂载（mounting）来实现的，挂载是将分区关联到某一目录的过程。挂载分区使起始于这个指定目录（通称为挂载点，mount point）的贮存区能够被使用。

例如，如果分区 /dev/hda5/ 被挂载在 /usr/ 上，这意味着所有在 /usr/ 之下的文件和目录在物理意义上位于 /dev/hda5/ 上。因此文件 /usr/share/doc/FAQ/txt/Linux-FAQ 被保存在 /dev/hda5/上，而文件 /etc/X11/gdm/Sessions/Gnome 却不是。

继续以上的例子，/usr/ 之下的一个或多个目录还有可能是其它分区的挂载点。例如，某个分区（假设为，/dev/hda7/）可以被挂载到 /usr/local/ 下，这意味着 /usr/local/man/whatis 将位于 /dev/hda7 上而不是 /dev/hda5 上。

D.1.8. 多少个分区？

到了红帽企业 Linux 安装筹备工作的这一步，你应该开始考虑一下你的新操作系统所要使用的分区数量及大小。“多少个分区”一直是 Linux 社区中的一个具有争议性的问题，在没有定论之前，可以说可用的分区布局与争论这一问题的人一样多。

鉴于上述情况，除非另有原因，我们推荐你至少应该创建以下几个分区：swap、/boot/（或用于 Itanium 系统的 /boot/efi/ 分区），/boot/efi/，和 /（根）。

详情请参阅第 4.17.4 节。

小心 | 小心
 | 请一定阅读第 D.1.9 节 — 那里所提供的信息也适用于 /boot/ 分区！

D.1.9. 最后一个疑问：使用 GRUB 还是 LILO

GRUB 和 LILO 是最常用的在基于 Intel 的系统上引导 红帽企业 Linux 的方法。作为操作系统装载程序，它们操作于任何操作系统 “之外”，仅使用计算机硬件中内建的基本 I/O 系统（或 BIOS）。本节向你描述 GRUB 和 LILO 与 PC BIOS 之间的交流，它只针对于 Intel 兼容的计算机。

D.1.9.1. 与 BIOS 相关的限制对 GRUB 和 LILO 的影响

在多数基于 x86 的计算机中，GRUB 和 LILO 要接受由 BIOS 所强加的限制。特别是，某些 BIOS 无法进入两个以上的硬盘，而且它们无法访问驱动器上柱面 1023 以上所贮存的数据。请注意，某些新近的 BIOS 没有这些限制，但是无论如何这还不是统一的规范。

窍门 窍门

在为你的硬盘驱动器分区时，请注意某些较老的系统 BIOS 无法进入硬盘上前1024柱面以外的区域。如果情况如此，在你的硬盘的前1024柱面上为 /boot Linux 保留足够空间以便引导 Linux。其它 Linux 分区可以在柱面1024之后。

在 parted 中，1024柱面相当于528MB。详情请参阅：

http://www.pcguide.com/ref/hdd/bios/sizeMB504-c.html

所有 GRUB 和 LILO 需要在引导期间使用的数据（包括 Linux 内核）都位于 /boot/ 目录中。如果你遵循了以上所建议的分区布局，或者选择了自动分区，/boot/ 目录将会是一个单独的小分区。否则，它可能会驻留在根分区（/）上。无论如何，如果你要使用 GRUB 或 LILO 来引导红帽企业 Linux 系统，/boot/ 所驻留的分区一定要遵守以下条例：

在前两个 IDE 驱动器上

如果你有两个 IDE（或 EIDE）驱动器，/boot/ 必须要位于其中之一。请注意，两个驱动器的限制也包括任何在你的主 IDE 控制器上的 IDE 光盘驱动器。因此，如果在你的主控制器上有一个 IDE 硬盘，和一个 IDE 光盘驱动器，/boot/ 必须仅能位于第一个硬盘，即便你在次 IDE 控制器上另有硬盘。

在第一个 IDE 或第一个 SCSI 驱动器上

如果你有一个 IDE（或 EIDE）驱动器以及一个或更多 SCSI 驱动器，/boot/ 必须位于 IDE 驱动器上或 ID 为 0 的 SCSI 驱动器上。其它任何 SCSI ID 都不行。

在前两个 SCSI 驱动器上

如果你只有 SCSI 硬盘，/boot/ 必须位于 ID 为 0 或 1 的驱动器上。其它任何 SCSI ID 都不行。

如前所述，某些新型的 BIOS 可能会允许 GRUB 和 LILO 与不符合这些条例的配置配合工作。同样的，某些 GRUB 和 LILO 的较隐诲的功能也可以用来启动 Linux 系统，即便其配置不符合我们的条例。然而，由于牵涉的变量太多，Red Hat 无法支持此类应用。

注记 | 注记
 | Disk Druid，以及工作站和服务器的安装，把这些 BIOS 相关的限制都已考虑在内。

注

[1]

与图解所示不同，块实际上是大小统一的。此外还请留意，一个普通的磁盘驱动器上含有数以千计的块。不过，在本次讨论中，我们可以忽略这些细微出入。

后退 | 起点 | 前进
安装后的问题 |  | 驱动程序介质


安装红帽企业 Linux 中的故障排除

后退 前进

附录 C. 安装红帽企业 Linux 中的故障排除

该附录讨论一些常见的安装问题以及它们的解决办法。

C.1. 你无法引导红帽企业 Linux

C.1.1. x86 特定的说明 — 你无法从光盘中引导吗？

注记 | 注记
 | 在某几种情况下，由于光盘上的引导映像的大小问题，系统 BIOS 不允许红帽企业 Linux 光盘引导。在这些情况下，应制作一个引导盘来引导安装程序。一旦引导成功，光盘就可以在安装中正常使用。

如果你无法从红帽企业 Linux 光盘引导，你有两种选择：

  1. 改变你的 BIOS 设置，因此从光盘中引导会在引导顺序中最先识别

  2. 使用你已制作的引导盘来引导

要改变你的 BIOS 设置，请参阅你的系统说明书来获得正确的能够允许你进入 BIOS 的键盘组合，或者在系统刚开始引导时在屏幕上阅读所需的键序列（假设该信息被显示）。

要制作引导盘，请遵循第 2.5.3 节中的说明。

要用引导盘引导红帽企业 Linux，把你制作的磁盘插入软盘驱动器，然后引导或重新引导你的计算机。请确定你的 BIOS 被设置为使用软盘或可移磁盘来引导。

C.1.2. x86 特定的说明 — 你无法从引导盘中引导吗？

如果你无法从引导盘中引导，你有两种选择：

  1. 改变 BIOS 设置，因此从引导盘中引导会在引导顺序中最先识别

  2. 使用更新的引导盘映像来引导

要改变你的 BIOS 设置，请参阅你的系统说明书来获得正确的能够允许你进入 BIOS 的键盘组合，或者在系统刚开始引导时在屏幕上阅读所需的键序列（假设该信息被显示）。

要找到更新的引导盘映像，查看一下下面的在线勘误：

http://www.redhat.com/support/errata/

并遵循第 2.5.3 节中的说明来为你的系统制作一张更新的引导盘。

C.1.3. 无法使用 RAID 卡来引导

如果你无法执行安装并且无法正确引导系统，你可能需要重新安装并且用不同的方式分区。

某些 BIOS 不支持从 RAID 卡引导。在安装的结束部分，一个基于文本的屏幕会显示引导装载程序提示（例如：GRUB:）以及一个闪动的光标。如果情况如此，你将会需要重新为你的系统分区。

不论你选择的是自动分区还是手工分区，你将会需要在 RAID 阵列之外，如一个分开的硬盘驱动器上，安装 /boot 分区。对于有问题的 RAID 卡，你必须有一个用于创建分区的内部硬盘驱动器。

你必须还要在 RAID 阵列外安装你优选的引导装载程序（GRUB 或 LILO） — 而不是在 MBR 中。引导装载程序应该安装在 创建/boot分区的同一驱动器上的 MBR 中。

当做完这些改变后，你应该可以结束安装并使用合适的方法引导系统。

C.1.4. 系统显示了信号 11 错误

信号 11 错误通称分段错误（segmentation fault），意思是程序进入了没有被分配给它的内存位置。

如果你在安装中接收到一个致命的信号 11 错误，其原因可能是你的系统总线内存中的硬件错误。内存中的硬件错误可能由可执行文件中的问题导致，或是由系统的硬件问题导致。和其它的操作系统一样，红帽企业 Linux 对你的系统硬件也有它自己的要求。某些硬件可能无法满足这些要求，即便它们在其它操作系统下运行正常。

检查一下你是否拥有来自 Red Hat 的最新安装和附加引导盘。检查一下在线勘误来确定是否有可用的更新版本。如果最新的映像仍不成功，这可能是由你的硬件问题导致的。这些错误通常是在你的内存或 CPU 缓存中。一种可能的解决方案是关闭 BIOS 中的 CPU 缓存。你还可以试着调换母板插槽中的内存来看一看这个问题是和插槽有关的还是和内存有关的。

你还可以试一试只使用 256MB 内存来运行安装程序。这可以通过使用 mem=256M 引导选项引导安装程序来达到。要试验这个选项，在安装程序的引导提示后键入：

mem=xxxM

这里的 xxx 应该用 MB 为单位的内存数量替换。

这个命令允许你超越内核在机器上检测到的内存数量。在一些老系统上，若安装程序只检测到 16MB（而实际上系统上有更多内存），或者在一些新系统上，视频卡和主内存共享视频内存情况下，你就需要使用该引导选项。

另一种选择是在安装光盘上执行介质检查。要测试 ISO 映像的校验和的完好性，在安装程序的引导提示下键入：

linux mediacheck

该命令可在 CD、DVD、硬盘 ISO、和 NFS ISO 安装方法中使用。

关于信号 11 错误的详情，请参阅：

http://www.bitwizard.nl/sig11/
后退 | 起点 | 前进
删除红帽企业 Linux |  | 安装起始部分的问题


给你目前的系统升级

后退 前进

附录 A. 给你目前的系统升级

这个附录帮助你进行一次典型的红帽企业 Linux 3 升级。

注记 注记

如果你当前在 x86 系统上使用红帽企业 Linux 2.1，你可以执行升级。

虽然用于 x86 处理器上的红帽企业 Linux 产品族支持升级，如果你备份数据后再在从前的红帽企业 Linux 安装上安装本版红帽企业 Linux，你可能会有一个更连贯的系统。所推荐的这种方法会帮助你确保系统的稳定性。

要执行升级，在引导提示下键入以下命令：

linux upgrade

A.1. 升级意味着什么

红帽企业 Linux 3 的安装进程包括从早期的红帽企业 Linux 版本（例如用于 x86 的红帽企业 Linux 版本 2.1）升级的能力。

升级你的系统会安装模块化的 2.4.x 内核以及你的系统中已安装软件包的更新版本。

升级进程通常保留现存的配置文件，它给这些文件分别添加了 .rpmsave 扩展名（例如，sendmail.cf.rpmsave）。升级进程还在 /root/upgrade.log 日志中记录了它的行动。随着软件的发展，配置文件的格式也会改变，因此你应该在集成这些改变之前仔细地比较原始配置文件和新文件。

注记 | 注记
 | 备份系统上的所有数据是明智之举。例如，如果你要升级或创建一个双引导系统，你应该备份这个硬盘驱动器上你想保存的数据。错误难免会发生，有些错误甚至会导致所有数据丢失。

某些升级的软件包可能需要安装其它软件包以便正常运行。如果你选择来定制要升级的软件包，你可能需要解决依赖关系的问题。否则，升级进程会自行解决依赖关系，但是，它可能会需要安装你的系统上没有的软件包。

依据你的系统分区情况而定，升级程序可能会提示你额外添加交换文件。如果升级程序没有检测到一个相当于你的内存两倍的交换文件，它会询问你是否要添加一个新的交换文件。如果你的系统没有足够的内存（小于 128 MB），推荐你添加这个交换文件。

后退 | 起点 | 前进
Itanium 系统 — 引导机器和安装后的设置 |  | 给你的系统升级


删除红帽企业 Linux

后退 前进

附录 B. 删除红帽企业 Linux

要从你的系统中卸装红帽企业 Linux，你将需要从你的主引导记录（MBR）中删除有关 GRUB 或 LILO 的信息。

注记 | 注记
 | 给系统上的数据进行备份是明智之举。错误有时会发生，它有可能导致你的数据的全部丢失。

在 DOS 和 Windows 系统中，你可以使用 Windows fdisk 工具来创建一个新的带有 undocumented 标志 /mbr 的 MBR。这将只会重写 MBR 以便引导主 DOS 分区。这个命令看起来类似：

fdisk /mbr

如果你需要从硬盘驱动器中删除 Linux，并且已经试图用默认的 DOS（Windows）fdisk 来这么做，你将会遇到“分区存在但又不存在”的问题。要删除非 DOS 分区的最好办法是使用一个理解 DOS 以外的分区的工具。

首先，插入红帽企业 Linux 的第一张光盘来引导系统。引导后，你会看到一个引导提示。在提示下键入：linux rescue。这会启动救援模式程序。

你会被提示输入你的键盘和语言需求。输入这些值，就如同你在安装红帽企业 Linux 中输入的一样。

下一步，会出现一个屏幕通知你该程序正在试图寻找要救援的红帽企业 Linux 安装。在该屏幕上选择「跳过」。

选择了「跳过」之后，你就会被给予一个命令提示，你可以用它来进入要删除的分区。

首先，键入命令 list-harddrives。这条命令会列出你的系统上所有被安装程序识别的硬盘驱动器，以及它们的大小（以MB为单位）。

警告 | 警告
 | 请只删除必要的红帽企业 Linux 分区。删除其它分区可能会导致数据丢失或受损的系统环境。

要删除分区，使用分区工具 parted。启动 parted，此处的 /dev/hda 是要删除的分区所在的设备：

parted /dev/hda

使用 print 命令来查看当前的分区表，从而判定要删除的分区的号码：

print

print 命令还可以显示分区的类型（如：linux-swap、ext2、ext3 等等）。了解分区类型会帮助你判定是否要删除该分区。

使用 rm 命令来删除分区。例如，要删除次要号码为 3 的分区：

rm 3

重要 | 重要
 | 你一按下 [Enter] 键，这些改变就会发生，因此在确定前请反复检查命令。

删除分区后，使用 print 命令来确认它已从分区表中被删除了。

一旦你已经删除了 Linux 分区，并且做完了所有必要的改变，键入 quit 来退出 parted。

退出 parted 后，在引导提示后键入 exit 来退出救援模式并重新引导你的系统，而不是继续安装。系统会自动重新引导。如果没有，你可以使用 [Control]-[Alt]-[Delete] 来重新引导系统。

后退 | 起点 | 前进
升级完成 |  | 安装红帽企业 Linux 中的故障排除


系统需求表

后退 前进

第 3章 . 系统需求表

最新的硬件支持列表可在 http://hardware.redhat.com/hcl/ 上找到。

该系统需求表会帮助你记录你的当前系统设置和需求。请在所提供的表格内输入关于你的系统的信息，它会成为帮助你顺利安装红帽企业 Linux 的便利参照。

硬盘驱动器：类型、标签、大小；如：IDE hda=40 GB
分区：分区和挂载点图；如： /dev/hda1=/home, /dev/hda2=/ (你知道它们的位置后再填充)
内存：你的系统上的内存数量；如：128 MB, 512 MB
CD-ROM：界面类型；如： SCSI, IDE (ATAPI)
SCSI 适配器：如果存在，其厂商和型号；如：BusLogic SCSI Adapter, Adaptec 2940UW
网卡：如果存在，其厂商和型号；如：Tulip, 3COM 3C590
鼠标：类型、协议、以及键数；如：通用 3 键 PS/2 鼠标, MouseMan 2 键串口鼠标
显示器：厂商、型号、和出厂规格；如： Optiquest Q53, ViewSonic G773
视频卡：厂商、型号、以及 VRAM 的大小；如：Creative Labs Graphics Blaster 3D, 8MB
声卡：厂商、芯片集、和型号；如：S3 SonicVibes, Sound Blaster 32/64 AWE
IP、DHCP、和 BOOTP 地址：四个用点分开的数字；如10.0.2.15
子网掩码：四个用点分开的数字；如：255.255.248.0
网关 IP 地址：四个用点分开的数字；如：10.0.2.245
一个或多个名称服务器的 IP 地址 (DNS)： 一组或多组用点分开的数字；如：10.0.2.1
域名：被定给你的组织的名称；如：example.com
主机名：你的计算机的名称；你的个人选择；如：cookie, southpark

表 3-1. 系统需求表

如果你不熟悉以上的联网需求或术语，请联系你的网络管理员。

后退 | 起点 | 前进
筹备硬盘驱动器安装 |  | 安装红帽企业 Linux


安装红帽企业 Linux

后退 前进

第 4章 . 安装红帽企业 Linux

本章解释了如何使用图形化、基于鼠标的安装程序从光盘中安装红帽企业 Linux。所讨论的课题如下：

  • 逐渐熟悉安装程序的用户界面

  • 启动安装程序

  • 选择安装方法

  • 安装中的配置步骤（语言、键盘、鼠标、分区等等）

  • 结束安装

4.1. 图形化安装程序用户界面

如果你从前使用过图形化用户界面（graphical user interface，GUI），你对这一进程会比较熟悉；你只需使用鼠标在屏幕间翻阅，“点击”按钮，或者输入文本字段。你还可以使用[Tab]和[Enter]键在安装中浏览各屏幕。

注记 注记

如果你使用的是 x86 或 AMD64 系统，并且不想使用图形化安装程序，你可以使用文本模式的安装程序。要开始文本模式安装程序，在 boot: 提示下键入下列命令：

linux text

关于文本模式安装步骤的简单描述，请参阅第 4.2 节。

强烈推荐你使用图形化安装程序来执行安装。图形化安装程序提供了红帽企业 Linux 安装程序的完整功能，包括在文本模式安装中没有的 LVM 配置。

必须使用文本模式安装程序的用户可以遵循图形化安装说明来获得所需信息。

注记 注记

如果你使用的是 Itanium 系统，并且不想使用图形化安装程序，你可以使用文本模式的安装程序。要开始文本模式安装程序，在 EFI Shell 提示下键入下列命令：

elilo linux text

4.1.1. 关于虚拟控制台的注记

红帽企业 Linux 安装程序不仅仅提供了安装进程的对话框。 除了提供从 shell 提示下输入命令的方法外，它还提供了几种不同类型的诊断消息。安装程序在五个虚拟控制台（virtual console）中显示这些消息，你可以用一个组合键在其间切换。

虚拟控制台是非图形化环境中的 shell 提示，从物理机器中而不是远程地进入。你可以同时进入多个虚拟控制台。

这些虚拟控制台在你安装红帽企业 Linux 中遇到问题时会对你很有帮助。在安装中或在系统控制台上显示的消息可以帮助你准确地找到问题的症结所在。关于虚拟控制台的列表，所用的切换击键组合，以及它们显示的内容，请参阅表 4-1。

一般来说，除非你试图诊断安装问题，你没有理由离开默认的控制台（图形化安装是第七号虚拟控制台）。

控制台 | 击键 | 内容
1 | [Ctrl]-[Alt]-[F1] | 安装对话框
2 | [Ctrl]-[Alt]-[F2] | shell 提示
3 | [Ctrl]-[Alt]-[F3] | 安装日志（安装程序的消息）
4 | [Ctrl]-[Alt]-[F4] | 与系统相关的消息
5 | [Ctrl]-[Alt]-[F5] | 其它消息
7 | [Ctrl]-[Alt]-[F7] | X 图形化显示

表 4-1. 控制台，击键，和内容

后退 | 起点 | 前进
系统需求表 |  | 文本模式安装程序用户界面


Itanium 系统特有信息

后退 前进

第 1章 . Itanium 系统特有信息

1.1. Itanium 系统安装总览

在 Itanium 系统上安装红帽企业 Linux 和在基于 x86 的系统上安装红帽企业 Linux 不同。一般来说，成功安装的步骤包括：

  1. 引导入 EFI（可扩展固件界面）Shell。

  2. 如果你无法从光盘引导，根据红帽企业 Linux 提供的引导映像创建一个 LS-120 磁盘。

  3. 使用 EFI Shell 和 ELILO 引导装载程序，载入并运行内核，然后引导红帽企业 Linux 安装程序。

后退 | 起点 | 前进
辅助功能的解决办法 |  | Itanium 系统 — EFI Shell


介绍

欢迎使用红帽企业 Linux 安装指南。本书所含信息对你安装红帽企业 Linux 3 会大有帮助。从安装准备之类的基本概念，到步骤分明的安装过程，本书将会成为你安装红帽企业 Linux 的极具价值的参考资料。

1. 文档约定

在你阅读这本手册的时候，你会注意到某些字词使用了不同的字体、大小和粗细。这种突出显示是有矩可循的；用同一风格来代表不同字词以表明它们属于同一类型。用这种方式来代表的各种字词类型包括：

command

Linux 命令（以及其它操作系统的命令，若使用的话）用这种方式代表。它向你表明你可以在命令行中键入单词或短语然后按 [Enter] 键来启用命令。有时，命令中会包括应用另一种方式显示的词（例如文件名）。在这种情况下，它们被视为命令的一部分，因而整个短语都会被显示为命令。例如：

使用 cat testfile 命令来查看当前工作目录中一个叫做 testfile 的文件。

file name

文件名、目录名、路径、以及 RPM 软件包名用这种方式代表。它表明在你的系统上存在着一个叫这个名称的文件或目录。例如：

你的主目录中的 .bashrc 文件包括你自用的 bash shell 定义和别名。

/etc/fstab 文件包括关于不同系统设备和文件系统的信息。

如果你想使用一个万维网服务器日志文件分析程序的话，安装 webalizer RPM。

application

这种方式向你表明该程序是一个终端用户的应用程序（与系统软件相对）。例如：

使用 Mozilla 来浏览万维网。

[key]

键盘上的按键用这种方式代表。例如：

要使用 [Tab] 键补全，键入一个字符然后按 [Tab] 键。你的终端上就会显示目录中起首为那个字符的文件列表。

[key]-[combination]

一个击键的组合用这种方式代表。例如：

[Ctrl]-[Alt]-[Backspace] 击键组合会退出你的图形会话，把你返回到图形登录屏幕或控制台。

「GUI 界面上的文本」

在 GUI 界面屏幕或窗口中的标题、词汇、或短语会用这种方式显示。它用来标明某个 GUI 屏幕或 GUI 屏幕上的某个元素（譬如与复选箱或字段相关的文本）。例如：

如果你想要在你的屏幕保护程序停止前要求口令的话，选择「需要口令」复选箱。

「GUI 屏幕或窗口上的最上级菜单」

用这种方式表示的词汇表明它位于一个下拉菜单的最上级。如果你在 GUI 屏幕上点击了这个词，应出现菜单的其它部分。例如：

在 GNOME 终端的「文件」下，你会看到「新建标签」选项，它允许你在同一窗口中打开多个 shell 提示。

如果你需要在 GUI 菜单上点击一系列命令的话，它们会如下面的例子中所示：

点击面板上的「主菜单」=> 「编程」 => 「Emacs」来启动 Emacs 文本编辑器。

「GUI 屏幕或窗口中的按钮」

这种方式表明它是 GUI 屏幕上可点击的按钮。例如：

点击「后退」按钮来返回到你刚才查看的网页。

computer output

用这种方式显示的文本表明它是 shell 提示中的文本，如错误消息或命令的答复。例如：

ls 命令显示目录的内容。例如：

Desktop                about.html       logs          paulwesterberg.png
Mail                   backupfiles      mail          reports

命令返回的输出（在上面的例子中，是目录的内容）用这种方式来显示。

prompt

提示是计算机在向你表明它在等待你的输入。它会用这种方式来显示。例如：

$

#

[stephen@maturin stephen]$

leopard login:

user input

用户键入的文本。无论是在命令行中还是在 GUI 屏幕上的文本箱内的输入都会用这种方式来显示。在下面的例子中，text 用这种方式显示：

要把你的系统引导入基于文本的安装程序，你需要在 boot: 提示下键入 text 命令。

replaceable

用在例子中的文本使用这种方式代表。该文本被用户提供的数据所代替。在下面的例子中，<version-number> 使用这种方式显示：

内核源码的目录是 /usr/src/<version-number>/，这里的 <version-number> 是安装在这个系统上的内核版本。

除此之外，我们还使用几种不同的方式来强调某些信息。按照信息对你的系统的重要程度，它们被标为注记、窍门、重要、小心、或警告。例如：

注记 | 注记
 | 切记，Linux 区分大小写。换一句话说，rose 不是 ROSE 或 rOsE。

窍门 | 窍门
 | 目录 /usr/share/doc/ 包括了关于你的系统上安装的软件包的附加信息。

重要 | 重要
 | 如果你修改了 DHCP 配置文件，这些改变在你重启 DHCP 守护进程之后才会生效。

小心 | 小心
 | 不要以根用户身份来执行日常任务 — 使用一个常规的用户帐号，除非你需要使用根帐号来进行系统管理任务。

警告 | 警告
 | 请只删除必要的红帽企业 Linux 分区。删除其它分区可能会导致数据丢失或受损的系统环境。
后退 | 起点 | 前进
红帽企业 Linux 3 |  | 如何使用本书


安装前的准备工作

后退 前进

第 2章 . 安装前的准备工作

注记 注记

虽然这本指南尽可能地反映了当前最新信息，你应该阅读“红帽企业 Linux 发行注记”来获得在我们的文档定版之前还来不及包括的信息。发行注记可以在红帽企业 Linux 的第一张光盘上找到，也可以从以下网址中阅读：

http://www.redhat.com/docs/

2.1. 其它指南手册的位置

如果你的产品中没有包括所有红帽企业 Linux 指南手册的印刷版本，你可以在网络上找到它们，也可以在包括在你的红帽企业 Linux 产品中的文档光盘中找到它们。

要在网络上寻找 HTML、PDF、和 RPM 格式的指南手册，请访问：

http://www.redhat.com/docs/
后退 | 起点 | 前进
Itanium 系统 — EFI Shell |  | 注册您的产品


后记

这些指南手册使用 DocBook SGML v4.1 格式编写。HTML 和 PDF 格式使用定制的 DSSSL 风格表单和定制的 jade 会绕脚本来编写。DocBook SGML 文件借助 Emacs 的 PSGML 模式编写。

Marianne Pecci <goddess@ipass.net> 创建了警诫图形（注记、窍门、重要、小心、和警告）。在获得 Marianne Pecci 和 Red Hat, Inc. 的书面许可后，它们可以被重新发行。

红帽产品文档组的成员如下：

Sandra A. Moore — 《红帽企业 Linux 用于 x86、Itanium™、和 AMD64 体系的安装指南》的主要撰写人和维护者；《红帽企业 Linux 用于 IBM® eServer™ iSeries™ 和 IBM® eServer™ pSeries™ 体系的安装指南》的主要撰写人和维护者；《红帽企业 Linux 逐步指南》的参与撰写人

Tammy Fox — 《红帽企业 Linux 系统管理指南》的主要撰写人和维护者；《红帽企业 Linux 用于 x86、Itanium™、和 AMD64 体系的安装指南》的参与撰写人；《红帽企业 Linux 安全指南》的参与撰写人；《红帽企业 Linux 逐步指南》的参与撰写人；DocBook 的定制风格表和脚本的编写人和维护者

Edward C. Bailey — 《红帽企业 Linux 系统管理介绍》的主要撰写人和维护者；“发行注记”的主要撰写人和维护者；《红帽企业 Linux 用于 x86、Itanium™、和 AMD64 体系的安装指南》的参与撰写人

Johnray Fuller — 《红帽企业 Linux 参考指南》的主要撰写人和维护者；《红帽企业 Linux 安全指南》的参与撰写人和维护者；《红帽企业 Linux 系统管理介绍》的参与撰写人

John Ha — 《红帽群集套件 群集配置和管理》的主要撰写人和维护者；“红帽术语”的主要撰写人和维护者；《红帽企业 Linux 用于 IBM® S/390® 和 IBM® eServer™ zSeries® 体系的安装指南》的主要撰写人和维护者；《红帽企业 Linux 安全指南》的参与撰写人和维护者；《红帽企业 Linux 系统管理介绍》的参与撰写人和维护者；《红帽企业 Linux 逐步指南》的参与撰写人和维护者

红帽产品文档翻译组的成员如下：

Jean-Paul Aubry — 法文翻译

David Barzilay — 巴西葡萄牙文翻译

Bernd Groh — 德文翻译

桥田喜代人 — 日文翻译

金芝恩 — 韩文翻译

Yelitza Louze — 西班牙文翻译

水本纪子 — 日文翻译

Nadine Richter — 德文翻译

Audrey Simons — 法文翻译

Francesco Valente — 意大利文翻译

王赛英 — 简体中文翻译

吴宏彬 — 繁体中文翻译

后退 | 起点
索引 |


索引

Symbols

/boot/ 分区
推荐的分区方案, 推荐的分区方案
/boot/efi/, 推荐的分区方案
/root/install.log
安装日志文件位置, 准备安装
/var/ 分区
推荐的分区方案, 推荐的分区方案
安装
DASD, 从硬盘安装
FTP, 筹备网络安装, 通过 FTP 安装
GUI
光盘, 安装红帽企业 Linux
HTTP, 筹备网络安装, 通过 HTTP 安装
Itanium 总览, Itanium 系统安装总览
NFS, 筹备网络安装, 通过 NFS 安装
服务器信息, 通过 NFS 安装
程序
不用软盘引导, 在基于 x86 的系统上不用软盘引导
开始, 启动安装程序
图形化用户界面, 图形化安装程序用户界面
文本模式用户界面, 文本模式安装程序用户界面
虚拟控制台, 关于虚拟控制台的注记
串行模式, 其它引导选项
UTF-8, 其它引导选项
磁盘空间, 你有足够的磁盘空间吗？
方法
FTP, 选择一种安装方法
HTTP, 选择一种安装方法
NFS 映像, 选择一种安装方法
光盘, 选择一种安装方法
选择, 选择一种安装方法
硬盘驱动器, 选择一种安装方法
分区, 为你的系统分区
光盘, 从光盘中安装
检查介质, 其它引导选项
键盘导航, 使用键盘来导航
开始, 从光盘中安装
你能否用光盘安装, 你能用光盘安装吗？
网络, 筹备网络安装
文本模式, 其它引导选项
问题
IDE 光盘相关的, 如果没有发现 IDE 光盘怎么办？
硬盘驱动器, 筹备硬盘驱动器安装, 从硬盘安装
中止, 从光盘中安装
注册您的产品, 注册您的产品
安装程序
Itanium
引导, 在 Itanium 系统上引导安装程序
x86 和 AMD64
引导, 在 x86 和 AMD64 系统上引导安装程序
安装后设置, Itanium 系统 &#8212; 引导机器和安装后的设置
安装日志文件
/root/install.log, 准备安装
安装软件包, 软件包组的选择
安装总览, Itanium 系统安装总览
编辑分区, 编辑分区
表格
参考, 系统需求表
系统需求, 系统需求表
步骤
磁盘空间, 你有足够的磁盘空间吗？
硬件兼容性, 你的硬件兼容吗？
用光盘安装, 你能用光盘安装吗？
磁盘
PCMCIA 支持，制作, 制作安装引导盘
介质, 驱动程序介质
网络引导，制作, 制作安装引导盘
引导，制作, 制作安装引导盘
用 MS-DOS 制作, 使用 rawrite 工具
在与 Linux 相仿的 OS 下制作, 使用 dd 命令
磁盘分区, 磁盘分区设置
磁盘空间, 你有足够的磁盘空间吗？
反馈
本书的联系信息, 我们需要用户的反馈！
防火墙配置, 防火墙配置
安全级别
启用防火墙, 防火墙配置
无防火墙, 防火墙配置
定制信任的服务, 防火墙配置
定制信任的设备, 防火墙配置
分区, 为你的系统分区
多少个分区, 多少个分区？
非破坏性, 使用活跃分区中的空闲空间
分区的数字排序, 分区命名方案
分区类型, 分区：将一个驱动器变成多个驱动器
给分区命名, 分区命名方案
挂载点和, 磁盘分区和挂载点
关系到……的 GRUB 问题, 最后一个疑问：使用 GRUB 还是 LILO
关系到……的 LILO 问题, 最后一个疑问：使用 GRUB 还是 LILO
基本概念, 磁盘分区简介
介绍, 分区：将一个驱动器变成多个驱动器
扩展, 分区内的分区 &#8212; 扩展分区概述
扩展分区, 分区内的分区 &#8212; 扩展分区概述
破坏性, 使用活跃分区中的空闲空间
其它操作系统, 磁盘分区以及其它操作系统
使用空闲空间, 使用未经分区的空闲空间
使用未使用过的分区, 使用一个未使用过的分区中的空间
使用正使用的分区, 使用活跃分区中的空闲空间
推荐的, 推荐的分区方案
为分区腾挪空间, 为红帽企业 Linux 腾挪空间
新建, 添加分区
文件系统类型, 文件系统类型
自动, 磁盘分区设置, 自动分区
辅助功能, 辅助功能的解决办法
引导选项
nofb, 其它引导选项
根（/）分区
推荐的分区方案, 推荐的分区方案
根口令, 设置根口令
故障排除, 安装红帽企业 Linux 中的故障排除
安装后, 安装后的问题
NVIDIA, NVIDIA 芯片集的问题
Sendmail 在启动时被挂起, 基于 Apache 的 httpd 服务或 Sendmail 在启动时被挂起
X（X 窗口系统）, 引导入 X 窗口系统（GUI）的问题
打印机, 你的打印机无法运行
登录, 登录时的问题
基于 Apache 的 httpd 服务在启动时被挂起, 基于 Apache 的 httpd 服务或 Sendmail 在启动时被挂起
内存不被识别, 你的内存不能够被识别吗？
声卡配置, 配置声卡遇到问题
图形化 GRUB 屏幕, 在基于 x86 系统的 GRUB 图形化屏幕中遇到问题
图形化 LILO 屏幕, 在基于 x86 系统的 LILO 图形化屏幕中遇到问题
引导入 GNOME 或 KDE, 引导入图形环境
引导入 X 窗口系统, 引导入图形环境
引导入图形环境, 引导入图形环境
光盘失败
光盘校验, 其它引导选项
开始安装, 安装起始部分的问题
GUI 安装法不可用, 引导入图形化安装遇到问题
没有检测到鼠标, 没有检测到你的鼠标
帧缓冲，禁用, 引导入图形化安装遇到问题
引导, 你无法引导红帽企业 Linux
RAID 卡, 无法使用 RAID 卡来引导
光盘, x86 特定的说明 &#8212; 你无法从光盘中引导吗？
信号 11 错误, 系统显示了信号 11 错误
引导盘, x86 特定的说明 &#8212; 你无法从引导盘中引导吗？
在安装过程中, 安装过程中的问题
Python 错误, 看到 Python 错误
“No devices found to install Red Hat Enterprise Linux”错误消息, “No devices found to install Red Hat Enterprise Linux”错误消息
分区表, 分区表问题
没有软驱却要保存回溯追踪消息, 没有软驱却要保存回溯追踪消息
使用剩余硬盘驱动器空间, 使用剩余空间
完成分区, x86 系统用户会遇到的其它分区问题, Itanium 系统用户会遇到的其它分区问题
挂载点
分区和, 磁盘分区和挂载点
光盘
ATAPI, 从光盘中安装
未识别，问题, 如果没有发现 IDE 光盘怎么办？
IDE, 从光盘中安装
未识别，问题, 如果没有发现 IDE 光盘怎么办？
SCSI, 从光盘中安装
从……安装, 从光盘中安装
可引导, 在基于 x86 的系统上不用软盘引导
引导光盘，制作, 制作安装引导光盘
回溯追踪消息
没有软驱却要保存回溯追踪消息, 没有软驱却要保存回溯追踪消息
键盘
配置, 键盘配置
使用……导航安装程序, 使用键盘来导航
键盘映射表
选择键盘类型, 键盘配置
交换分区
推荐的分区方案, 推荐的分区方案
交换文件
升级, 升级意味着什么
介绍, 介绍
救援模式, 救援模式, 救援模式
开始
安装, 启动安装程序, 从光盘中安装
可引导的光盘, 在基于 x86 的系统上不用软盘引导
控制台，虚拟, 关于虚拟控制台的注记
口令
设置根, 设置根口令
引导装载程序, x86 和 AMD64 系统的引导装载程序配置, 创建一个新的引导装载程序配置
扩展分区, 分区内的分区 &#8212; 扩展分区概述
内核
引导选项, 其它引导选项
内核选项, 内核选项
配置
GRUB, x86 和 AMD64 系统的引导装载程序配置
LILO, x86 和 AMD64 系统的引导装载程序配置
时间, 时区配置
时区, 时区配置
时钟, 时区配置
网络, 网络配置
硬件, 系统需求表
驱动程序介质, 驱动程序介质
根据映像创建磁盘, 根据映像文件创建驱动程序盘
使用驱动程序映像, 在安装过程中使用驱动程序映像
由红帽制作, 如何获取驱动程序介质
由他方制作, 如何获取驱动程序介质
驱动程序盘, 其它引导方法, 启动安装程序
取消安装, 从光盘中安装
如何使用本书, 如何使用本书
软件包
安装, 软件包组的选择
选择, 软件包组的选择
组群, 软件包组的选择
选择, 软件包组的选择
删除
GRUB, 删除红帽企业 Linux
LILO, 删除红帽企业 Linux
红帽企业 Linux, 删除红帽企业 Linux
删除分区, 删除一个分区
升级, 升级意味着什么
开始, 升级意味着什么
描述, 升级意味着什么
添加一个交换文件, 升级意味着什么
引导装载程序配置, 升级引导装载程序配置
引导装载程序配置，新建, 创建一个新的引导装载程序配置
时区
配置, 时区配置
时钟, 时区配置
视频卡设置, 视频卡配置
鼠标
没有检测到, 没有检测到你的鼠标
配置, 鼠标配置
选择, 鼠标配置
添加分区, 添加分区
文件系统类型, 文件系统类型
网络
安装
FTP, 通过 FTP 安装
HTTP, 通过 HTTP 安装
NFS, 通过 NFS 安装
配置, 网络配置
网络安装
筹备, 筹备网络安装
执行, 执行网络安装
文档
其它指南手册, 其它指南手册的位置
文件系统
格式，概述, 不是你写入什么，而是你怎么写入
文件系统类型, 文件系统类型
系统分区, Itanium 系统 &#8212; EFI Shell
系统需求表, 系统需求表
显示器设置, 配置你的显示器
卸装, 删除红帽企业 Linux
虚拟控制台, 关于虚拟控制台的注记
选择
软件包, 软件包组的选择
循环
见 循环
引导
安装程序
Itanium, 在 Itanium 系统上引导安装程序
x86 和 AMD64, 在 x86 和 AMD64 系统上引导安装程序
从 LS-120 磁盘, 从 LS-120 磁盘来引导安装程序
从光盘, 从光盘中引导安装程序
引导方法
PCMCIA 设备驱动程序盘, 其它引导方法
USB 磁盘驱动器, 其它引导方法
本地引导盘, 其它引导方法
块设备驱动程序盘, 其它引导方法
网络设备驱动程序盘, 其它引导方法
引导光盘, 其它引导方法
引导光盘, 其它引导方法
创建, 制作安装引导光盘
引导盘
从引导映像文件创建, 从 LS-120 磁盘来引导安装程序
引导选项, 其它引导选项
boot.iso, 其它引导选项
串行模式, 其它引导选项
UTF-8, 其它引导选项
附加, 其它引导选项
内核, 其它引导选项
检查介质, 其它引导选项
文本模式, 其它引导选项
引导装载程序, x86 和 AMD64 系统的引导装载程序配置
GRUB, x86 和 AMD64 系统的引导装载程序配置
LILO, x86 和 AMD64 系统的引导装载程序配置
MBR, 高级引导装载程序配置, 高级引导装载程序配置
口令, x86 和 AMD64 系统的引导装载程序配置, 创建一个新的引导装载程序配置
配置, x86 和 AMD64 系统的引导装载程序配置
其它选项, 其它可选的引导装载程序, 其它可选的引导装载程序
LOADLIN, 其它可选的引导装载程序, 其它可选的引导装载程序
SYSLINUX, 其它可选的引导装载程序, 其它可选的引导装载程序
商用产品, 其它可选的引导装载程序, 其它可选的引导装载程序
在引导分区上安装, 高级引导装载程序配置, 高级引导装载程序配置
引导装载程序口令, x86 和 AMD64 系统的引导装载程序配置, 创建一个新的引导装载程序配置
硬件
兼容性, 你的硬件兼容吗？
配置, 系统需求表
硬盘
分区, 磁盘分区简介
分区简介, 分区：将一个驱动器变成多个驱动器
分区类型, 分区：将一个驱动器变成多个驱动器
基本概念, 硬盘基本概念
扩展分区, 分区内的分区 &#8212; 扩展分区概述
文件系统格式, 不是你写入什么，而是你怎么写入
硬盘安装, 从硬盘安装
筹备, 筹备硬盘驱动器安装
用户界面，图形化
安装程序, 图形化安装程序用户界面
用户界面，文本模式
安装程序, 文本模式安装程序用户界面
与 Linux 相仿的 OS
用……制作安装磁盘, 使用 dd 命令
语言
对多种语言的支持, 语言支持的选择
选择, 语言选择
约定
文档, 文档约定
在线帮助
隐藏, 欢迎使用红帽企业 Linux
指南手册, 其它指南手册的位置
主机名配置, 网络配置
注册您的产品, 注册您的产品
自动分区, 磁盘分区设置, 自动分区
自动引导, 在基于 x86 的系统上不用软盘引导
ELILO, 自动引导红帽企业 Linux

A

ATAPI 光盘
未识别，问题, 如果没有发现 IDE 光盘怎么办？

B

BIOS，与 GRUB 相关的问题, 与 BIOS 相关的限制对 GRUB 和 LILO 的影响
BIOS，与 LILO 相关的问题, 与 BIOS 相关的限制对 GRUB 和 LILO 的影响
boot.img, 从 LS-120 磁盘来引导安装程序
boot.iso, 其它引导选项

D

DASD 安装, 从硬盘安装
dd
制作安装磁盘, 使用 dd 命令
Disk Druid
按钮, Disk Druid 的按钮
编辑分区, 编辑分区
分区, 为你的系统分区
删除分区, 删除一个分区
添加分区, 添加分区
文件系统类型, 文件系统类型

E

EFI
系统分区, Itanium 系统 &#8212; EFI Shell
EFI Shell, Itanium 系统 &#8212; EFI Shell
ELILO
安装后的引导设置, Itanium 系统 &#8212; 引导机器和安装后的设置
自动引导, 自动引导红帽企业 Linux

F

FTP
安装, 筹备网络安装, 通过 FTP 安装

G

GRUB, x86 和 AMD64 系统的引导装载程序配置, 升级引导装载程序配置
SMP 母板, SMP 母板，GRUB，和 LILO, SMP 母板，GRUB，和 LILO
创建一个新配置, 创建一个新的引导装载程序配置
配置, x86 和 AMD64 系统的引导装载程序配置, 升级引导装载程序配置
其它选项, 其它可选的引导装载程序, 其它可选的引导装载程序
LOADLIN, 其它可选的引导装载程序, 其它可选的引导装载程序
SYSLINUX, 其它可选的引导装载程序, 其它可选的引导装载程序
商用产品, 其它可选的引导装载程序, 其它可选的引导装载程序
删除, 删除红帽企业 Linux
与 BIOS 相关的问题, 与 BIOS 相关的限制对 GRUB 和 LILO 的影响
与分区相关的问题, 最后一个疑问：使用 GRUB 还是 LILO

H

HTTP
安装, 筹备网络安装, 通过 HTTP 安装

I

ia64
见 Itanium
IDE 光盘
未识别，问题, 如果没有发现 IDE 光盘怎么办？
isolinux, 在 x86 和 AMD64 系统上引导安装程序

L

LILO, x86 和 AMD64 系统的引导装载程序配置, 升级引导装载程序配置
SMP 母板, SMP 母板，GRUB，和 LILO, SMP 母板，GRUB，和 LILO
创建一个新配置, 创建一个新的引导装载程序配置
配置, x86 和 AMD64 系统的引导装载程序配置, 升级引导装载程序配置
其它选项, 其它可选的引导装载程序, 其它可选的引导装载程序
LOADLIN, 其它可选的引导装载程序, 其它可选的引导装载程序
SYSLINUX, 其它可选的引导装载程序, 其它可选的引导装载程序
商用产品, 其它可选的引导装载程序, 其它可选的引导装载程序
删除, 删除红帽企业 Linux
与 BIOS 相关的问题, 与 BIOS 相关的限制对 GRUB 和 LILO 的影响
与分区相关的问题, 最后一个疑问：使用 GRUB 还是 LILO
LOADLIN, 其它可选的引导装载程序, 其它可选的引导装载程序

M

MBR
在……上安装引导装载程序, 高级引导装载程序配置, 高级引导装载程序配置
MS-DOS
用……制作安装磁盘, 使用 rawrite 工具

N

NFS
安装, 筹备网络安装, 通过 NFS 安装

O

OS/2 引导管理器, 高级引导装载程序配置, 高级引导装载程序配置

P

parted 分区工具, 创建新分区
Partition Magic, 其它可选的引导装载程序, 其它可选的引导装载程序

R

rawrite
制作安装磁盘, 使用 rawrite 工具

S

SMP 母板
GRUB, SMP 母板，GRUB，和 LILO, SMP 母板，GRUB，和 LILO
LILO, SMP 母板，GRUB，和 LILO, SMP 母板，GRUB，和 LILO
startup.nsh, 使用启动脚本
SYSLINUX, 其它可选的引导装载程序, 其它可选的引导装载程序
System Commander, 其它可选的引导装载程序, 其它可选的引导装载程序

T

TCP/IP 配置, 执行网络安装

U

USB 磁盘驱动器
引导安装程序, 其它引导方法
后退 | 起点 | 前进
关于 Itanium 和 Linux 的额外资料 |  | 后记


Red Hat, Inc.

1801 Varsity Drive Raleigh NC 27606-2072 USA 电话：+1 919 754 3700 电话：888 733 4281 传真：+1 919 754 3701 PO Box 13588 Research Triangle Park NC 27709 USA

rhel-ig-x8664-multi(ZH-CN)-3-HTML-RHI (2003-07-25T17:10)

版权© 2003，Red Hat, Inc. 本资料只允许在开放出版许可（Open Publication License）V1.0 或更新版本的条款下发行。（最新版本目前位于http://www.opencontent.org/openpub/）。

没有版权所有者的明确许可，禁止发行该文档的独立修改的版本。

除非事前从版权所有者处获得许可，禁止使用任何标准（纸印）书籍格式为商业目的而发行该作品或从该作品推导出的作品。

红帽、Red Hat、红帽网络、Red Hat Network、红帽“Shadow Man”徽标、RPM、Maximum RPM、RPM 徽标、Linux Library、PowerTools、Linux Undercover、RHmember、RHmember More、Rough Cuts、Rawhide 以及所有基于红帽的商标和徽标是商标或 Red Hat, Inc. 在美国和其它国家的注册商标。

Linux 是 Linus Torvalds 的注册商标。

Motif 和 UNIX 是 The Open Group 的注册商标。

Intel 和 Pentium 是 Intel Corporation 的注册商标。Itanium 和 Celeron 是 Intel Corporation 的商标。

AMD、Opteron、Athlon、Duron、以及 K6 是 Advanced Micro Devices, Inc. 的注册商标。

Netscape 是 Netscape Communications Corporation 在美国和其它国家的注册商标。

Windows 是 Microsoft Corporation 的注册商标。

SSH 和 Secure Shell 是 SSH Communications Security, Inc. 的商标。

FireWire 是 Apple Computer Corporation 的商标。

IBM、AS/400、OS/400、RS/6000、S/390、和 zSeries 是 International Business Machines Corporation 的注册商标。eServer、iSeries、和 pSeries 是 International Business Machines Corporation 的商标。

本书中所引用的所有其它商标和版权均属其拥有者所有。

security@redhat.com 密钥的 GPG 指纹是：

CA 20 86 86 2B D6 9D FC 65 F6 EC C4 21 91 80 CD DB 42 A6 0E

起点


设置根口令

后退 第 4章 . 安装红帽企业 Linux 前进

4.23. 设置根口令

设置根帐号及其口令是安装过程中最重要的步骤之一。你的根帐号和 Windows NT 机器上的管理员帐号类似。根帐号被用来安装软件包，升级 RPM，以及执行多数系统维护工作。作为根用户登录可使你对系统有完全的控制权。

注记 | 注记
 | 根用户（又称超级用户）对整个系统有完全的存取权；正因如此，请最好只有在执行系统维护或管理时才登录为根用户。

图 4-22. 根口令

请只有在进行系统管理时才使用根帐号。创建一个非根帐号来做日常工作。若你需要快速修复某项事务时，用 su - 命令暂时登录为根用户。遵循这些最基本的原则将会减少你因键入错误或不正确的命令而损害系统的机会。

窍门 | 窍门
 | 要变成根用户，在终端机窗口的 shell 提示下键入 su - ，并按 [Enter] 键，然后，输入根口令并按 [Enter] 键。

安装程序会提示你为你的系统设置一个根口令[1]。如果根口令没有被输入，安装程序将不允许你继续。

根口令必须至少包括六个字符；你键入的口令不会在屏幕上显示。你必须把口令输入两次；如果两个口令不匹配，安装程序将会请你重新输入口令。

你应该把根口令设为你可以记住但又不容易被别人猜到的组合。你的名字、电话号码、 qwerty、 password、 root、 123456、以及 anteater 都是典型的坏口令。好口令混合使用数字、大小写字母，并且不包含任何词典中的现成词汇。例如：Aard387vark 或 420BMttNT。请记住，口令是区分大小写的。如果你笔录下你的口令，请将之保存在一个安全的地方。然而，我们建议你不要笔录任何你创建的口令。

注记 | 注记
 | 不要使用本指南中提供的任何示范口令。使用其中任何一个，都可以被视为安全风险。

窍门 | 窍门
 | 要在安装后改变你的根口令，使用根口令配置工具。 在 shell 提示下键入 redhat-config-rootpassword 命令来启动根口令配置工具。如果你不是根用户，它会提示你输入根口令后再继续。

注

[1]

根口令是用于你的红帽企业 Linux 系统的管理口令。你应该只在需要系统维护的时候才登录为根用户。根帐号没有任何加于普通用户上的限制，因此，作为根用户所做的任何改变会影响你的整个系统。

后退 | 起点 | 前进
时区配置 | 上级 | 软件包组的选择


从光盘中安装

后退 第 4章 . 安装红帽企业 Linux 前进

4.5. 从光盘中安装

要从光盘中安装红帽企业 Linux，在引导装载程序屏幕中选择「光盘」选项，然后选择「确定」按钮。当提示时，在光盘驱动器中插入红帽企业 Linux 光盘（如果你没有从光盘中引导的话）。一旦光盘已在驱动器中，选择「确定」按钮，然后按 [Enter]键。

安装程序将会探测你的系统，并试图识别你的光盘驱动器。它会开始寻找一个 IDE（又称 ATAPI）光盘驱动器。如果找到了，它会继续到安装进程的下一阶段（参阅第 4.12 节）。

注记 | 注记
 | 要在任何时候中止安装进程，请重新引导你的机器，然后弹出引导盘或引导光盘。你可以在看到「即将安装」屏幕前的任何时候安全地取消安装。详情请参阅第 4.25 节。

如果你的光盘驱动器没有被检测到，而且它是一个 SCSI 光盘，安装程序将会请你选择一个 SCSI 驱动程序。选择与你的适配器最接近的驱动程序。如果必要，你可以为驱动程序指定选项，然而，多数驱动程序会被你的 SCSI 适配器自动检测到。

窍门 | 窍门
 | 光盘驱动器的可选参数的部分列表可以在《红帽企业 Linux 参考指南》内的“常规参数和模块”这一附录中找到。

4.5.1. 如果没有发现 IDE 光盘怎么办？

如果你在 x86 或 AMD64 系统上有一个 IDE（ATAPI）光盘，但是安装程序没有成功地找到它，反而向你询问你的光盘驱动器的类型，请尝试下列引导命令。重新开始安装，然后在 boot: 提示后输入 linux hdX=cdrom。根据光盘连接的接口以及它是被配置为主还是次而定，把 X 替换成以下字母之一：

  • a — 第一个 IDE 控制器，主

  • b — 第一个 IDE 控制器，次

  • c — 第二个 IDE 控制器，主

  • d — 第二个 IDE 控制器，次

如果你有第三个及（或）第四个控制器，请按字母顺序，从主到次为控制器分派字母。

后退 | 起点 | 前进
选择一种安装方法 | 上级 | 从硬盘安装


通过 FTP 安装

后退 第 4章 . 安装红帽企业 Linux 前进

4.9. 通过 FTP 安装

FTP 对话框只有在你从 FTP 服务器中安装时才会出现（如果你在「安装方法」对话框中选择了「FTP」的话）。该对话框允许你指定要从中安装红帽企业 Linux 的 FTP 服务器。

图 4-5. FTP 设置对话框

输入你从中安装的 FTP 站点的名称或 IP 地址，以及包含用于你的体系的 RedHat/ 安装文件的目录。譬如，如果 FTP 站点包含目录 /mirrors/redhat/arch/RedHat/，请输入 /mirrors/redhat/arch/（这里的 arch 应使用你的系统体系类型来替换，如 i386、ia64、ppc、或 s390）。如果一切都被正确地指定了，一个通知你“base/hdlist 已被检索到”的消息箱就会出现。

接下来，你会看到「欢迎」对话框。

窍门 窍门

你可以通过使用已经复制到服务器上的 ISO 映像来节省磁盘空间。要达到这个目的，使用 ISO 映像来安装红帽企业 Linux，而不必通过环回挂载把它们复制到一个单一树中。对于每个 ISO 映像，执行：

mkdir disc1

mount -o loop example-1.iso disc1
后退 | 起点 | 前进
通过 NFS 安装 | 上级 | 通过 HTTP 安装


从硬盘安装

后退 第 4章 . 安装红帽企业 Linux 前进

4.6. 从硬盘安装

注记 | 注记
 | 硬盘安装只适用于 ext2、ext3、或 FAT 文件系统。如果你有其它的文件系统，如 reiserfs，你将无法执行硬盘安装。

硬盘安装需要使用 ISO（或光盘）映像。ISO 映像是光盘映像的精确复制件。由于红帽企业 Linux 的发行版本中包括了大量软件包，可用的 ISO 映像也有好几个。把所需的 ISO 映像（二进制的红帽企业 Linux 光盘）存放到某目录中后，选择从硬盘安装。这样，你就会把安装程序指向要执行安装的目录。

在试图安装前，请校验 ISO 映像的完整性。这会帮助你避免硬盘安装过程中经常会遇到的问题。要在执行安装前校验 ISO 映像的完整性，请使用 md5sum 程序（该程序有适用于各类操作系统的版本）。md5sum 程序应该可以在提供 ISO 映像的同一服务器上找到。

注记 注记

ISO 映像现在嵌入了 md5sum。要测试 ISO 映像校验和的完好性，在安装引导提示下键入：

linux mediacheck

Itanium 用户应该使用 elilo linux mediacheck 命令。

除此之外，如果你从中安装的目录中还有一个叫 RedHat/base/updates.img 的文件，你可以用它来更新安装程序。请参考 anaconda RPM 软件包中的 install-methods.txt 文件来获取关于各类安装红帽企业 Linux 的途径，以及应用安装程序更新的详情。

图 4-3. 硬盘驱动器安装的选择分区对话框

「选择分区」屏幕只在你从磁盘分区中安装时才会出现（这就是说，如果你在「安装方法」中选择了「硬盘驱动器」的话）。该对话框允许你指定你从中安装红帽企业 Linux 的磁盘分区和目录。

输入包含红帽企业 Linux ISO 映像的分区的设备名称。其中还有一个被标为「包含映像的目录」的字段。

如果 ISO 映像位于该分区的根（顶级）目录中，请输入到达该映像的路径（譬如，如果 ISO 映像所在的分区被正常挂载为 /home/，而映像位于 /home/new 中，你可以输入 new）。

如果 ISO 映像不在该分区的根（顶级）目录中，请输入到达该映像的全路径（譬如，如果 ISO 映像在 /test/new 中，你应该输入 /test/new）。

当你确认了磁盘分区后，接下来，你就会看到「欢迎」对话框。

后退 | 起点 | 前进
从光盘中安装 | 上级 | 执行网络安装


通过 HTTP 安装

后退 第 4章 . 安装红帽企业 Linux 前进

4.10. 通过 HTTP 安装

HTTP 对话框只有在你从 HTTP 服务器中安装时才会出现（如果你在「安装方法」中选择了「HTTP」的话）。该对话框提示你输入要从中安装红帽企业 Linux 的 HTTP 服务器的信息。

输入你要从中安装的 HTTP 站点的名称或 IP 地址，以及包含用于你的体系的 RedHat/ 安装文件的目录。譬如，如果 HTTP 站点包含目录 /mirrors/redhat/arch/RedHat/，则请输入 /mirrors/redhat/arch/（这里的 arch 应使用你的系统体系类型来替换，如 i386、ia64、ppc、或 s390）。如果一切都被正确地指定了，一个通知你“base/hdlist 已被检索到”的消息箱就会出现。

图 4-6. HTTP 设置对话框

接下来，你会看到「欢迎」对话框。

窍门 窍门

你可以通过使用已经复制到服务器上的 ISO 映像来节省磁盘空间。要达到这个目的，使用 ISO 映像来安装红帽企业 Linux，而不必通过环回挂载把它们复制到一个单一树中。对于每个 ISO 映像，执行：

mkdir disc1

mount -o loop example-1.iso disc1
后退 | 起点 | 前进
通过 FTP 安装 | 上级 | 欢迎使用红帽企业 Linux


通过 NFS 安装

后退 第 4章 . 安装红帽企业 Linux 前进

4.8. 通过 NFS 安装

NFS 对话框只在你从 NFS 服务器中安装时才会出现（如果你使用网络或 PCMCIA 驱动程序盘提供了驱动程序，并且在「安装方法」中选择了「NFS 映像」的话）。

输入你的 NFS 服务器的域名。譬如，如果你是从 example.com 域的 eastcoast 主机上安装的话，在「NFS 服务器」 字段中输入 eastcoast.example.com。

接下来，输入导出目录的名称。如果你遵循了第 2.6 节中描述的设置步骤，你将应该输入目录 /location/of/disk/space/，其中包含了 RedHat/ 目录。

如果 NFS 服务器导出的是红帽企业 Linux 安装树的镜像，输入包含 RedHat/ 目录的目录（如果你不知道该目录的路径，请向你的系统管理员咨询）。譬如，如果 NFS 站点包含目录 /mirrors/redhat/arch/RedHat/，则请输入 /mirrors/redhat/arch/（这里的 arch 应使用你的系统的体系类型来替换，如 i386、ia64、ppc、或 s390）。如果一切都被正确指定了，一则表明红帽企业 Linux 的安装程序正在运行的消息就会出现。

图 4-4. NFS 设置对话框

如果 NFS 服务器从红帽企业 Linux 光盘导出 ISO 映像的话，输入包含该 ISO 映像的目录。

接下来，你会看到「欢迎」对话框。

后退 | 起点 | 前进
执行网络安装 | 上级 | 通过 FTP 安装


执行网络安装

后退 第 4章 . 安装红帽企业 Linux 前进

4.7. 执行网络安装

如果你要执行的是网络安装，「配置 TCP/IP」对话框就会出现。该对话框向你询问 IP 和其它网络地址。你可以选择通过 DHCP 或手工地配置设备的 IP 地址和子网掩码。如果要手工配置，输入你在安装中使用的 IP 地址，然后按 [Enter] 键。安装程序会试图根据你的 IP 地址来猜测你的子网掩码；如果子网掩码不正确，你可以改变它。按 [Enter] 键。安装程序还会从你的 IP 地址和子网掩码来猜测默认的网关和主名称服务器的地址，如果它们不正确，你可以改变它们。

后退 | 起点 | 前进
从硬盘安装 | 上级 | 通过 NFS 安装


安装完成

后退 第 4章 . 安装红帽企业 Linux 前进

4.29. 安装完成

祝贺你！你的红帽企业 Linux 3 安装现已完成！

安装程序会提示你做好重新引导系统的准备。如果安装介质（磁盘驱动器内的磁盘或光盘驱动器内的光盘）在重新引导时没有被自动弹出，请记住取出它们。

计算机正常的通电序列完成后，你应该看到图形化的引导装载程序提示，在这里，你可以执行以下任何任务：

  • 按 [Enter] 键 — 导致默认的引导项目被引导。

  • 选择一个引导标签，接着按 [Enter] 键 — 导致引导装载程序引导与该引导标签相对应的操作系统。（在 LILO 的文本模式引导装载程序的提示下按 [?] 或 [Tab] 键可得到一个有效的引导标签的列表。）

  • 什么都不做 — 引导装载程序的超时时间过后（默认为五秒），引导装载程序将会自动引导默认的引导项目。

做引导红帽企业 Linux 的恰当选择。你应该看到一行一行的信息往上卷。最终，你应该看到一个 login: 提示或 GUI 登录屏幕（如果你安装了 X 窗口系统并选择要自动启动它的话）。

在你首次启动红帽企业 Linux 机器时，你会看到设置代理屏幕。它会帮助你进行红帽企业 Linux 配置。使用这个工具，你可以设置系统时间和日期；安装软件；在红帽网络上注册系统等等。设置代理让你能够一开始就配置环境，因此你可以马上就得心应手地使用红帽企业 Linux 系统。

如果你不能肯定下一步该做什么，我们建议你从其它红帽企业 Linux 指南手册着手。它们在网上或包括在你的红帽企业 Linux 产品中的红帽企业 Linux 文档光盘。

这些指南手册的 HTML、PDF、和 RPM 版本位于红帽企业 Linux 的文档光盘上。它们还可以在 http://www.redhat.com/docs/ 上找到。

注记 | 注记
 | 虽然本指南尽可能地反映了最当前的信息，但是要查看在文档定稿之前尚不及包括的信息，请参考“红帽企业 Linux 发行注记”。它可以在红帽企业 Linux 的第一张光盘上找到，也可以在 http://www.redhat.com/docs/ 上找到。

如果你是一个较有经验的用户，只想寻求些管理方面的信息，你可能会发现《红帽企业 Linux 参考指南》更有用。

关于系统管理的概况，请参考《红帽企业 Linux 系统管理介绍》。如果你需要关于系统配置的信息，你可能会发现《红帽企业 Linux 系统管理指南》对你比较有帮助。

如果你需要关于系统保安方面的信息，请参考《红帽企业 Linux 安全指南》。

不要忘记注册来获得您作为红帽顾客所应得的权益。注册使您能够得到您已购买的红帽服务，例如技术支持和红帽网络。

要注册产品，请到：

http://www.redhat.com/apps/activate/
后退 | 起点 | 前进
X 配置 — 显示器和定制 | 上级 | Itanium 系统 — 引导机器和安装后的设置


自动分区

后退 第 4章 . 安装红帽企业 Linux 前进

4.16. 自动分区

自动分区在有关哪些数据要从系统中删除（若适用）这一方面允许你有控制权。可供你选择的选项有：

  • 「删除系统内所有的 Linux 分区」 — 选择该选项来只删除 Linux 分区（在从前安装 Linux 时创建的分区）。这将不会影响你的硬盘驱动器上可能会有的其它分区（例如：VFAT 或 FAT32 分区）。

  • 「删除系统内的所有分区」 — 选择这一选项来删除你的硬盘驱动器上的所有分区（这包括由其它操作系统创建的分区如 Windows 所创建的分区或 NTFS 分区）。

    小心 小心

    如果你选择了这个选项，在选定的硬盘驱动器上的所有数据将会被安装程序删除。如果在你打算安装红帽企业 Linux 的硬盘驱动器上有你想保留的信息，请不要选此项。

  • 「保存所有的分区，使用现有的空闲空间」 — 选择这一选项来保留你当前的数据和分区，假设你的硬盘驱动器上有足够的可用空闲空间的话。

图 4-11. 自动分区

使用你的鼠标来选择你想安装红帽企业 Linux 的硬盘驱动器。如果你有两个或两个以上硬盘驱动器，你应该选择包含本次安装的硬盘驱动器。没有被选择的硬盘驱动器，及其中的数据，将不会受到影响。

注记 | 注记
 | 备份系统上的所有数据是明智之举。例如，如果你要升级或创建一个双引导系统，你应该备份这个硬盘驱动器上你想保存的数据。错误难免会发生，甚至会导致所有数据丢失。

小心 | 小心
 | 如果你有一个 RAID 卡，请留意，某些 BIOS 不支持从 RAID 卡中引导。在这类情况下，/boot/ 分区一定要在 RAID 阵列之外的分区上创建，比如在一个分开的硬盘驱动器上。用有问题的 RAID 卡来创建分区，有必要使用一个内部硬盘驱动器。 /boot/ 分区也是软件 RAID 设置所必需的。 如果你已选定要自动为你的系统分区，你应该选择「评审」，然后手工地编辑 /boot/ 分区。

要对自动创建的分区评审并做一些必要的改变，选择「评审」选项。选择「评审」并点击「下一步」来前进后，你将会看到在 Disk Druid 中为你创建的分区。如果它们没有满足你的需要，你还能够对这些分区进行修改。

当你选好之后，点击「下一步」来继续。

后退 | 起点 | 前进
磁盘分区设置 | 上级 | 为你的系统分区


为你的系统分区

后退 第 4章 . 安装红帽企业 Linux 前进

4.17. 为你的系统分区

如果你选择了自动分区，但没有选择「评审」，请向前跳到第 4.19 节。

如果你选择了自动分区并选择了「评审」，你可以接受目前的分区设置（点击「下一步」），或使用手工分区工具 Disk Druid 来修改设置。

到了这一步，你必须告诉安装程序要在哪里安装红帽企业 Linux。这是通过在将要安装红帽企业 Linux 的一个或多个磁盘分区上定义挂载点来做到的。这时，你可能还需要创建或（并）删除分区。

注记 | 注记
 | 如果你还没有计划好要如何设立分区，请参阅附录 D。你最起码需要一个大小合适的根分区，一个大小等于系统内存两倍的交换分区，Itanium 系统用户将需要一个大小约为100MB，类型为 FAT（VFAT）的 /boot/efi/ 分区，一个至少是512MB的交换分区，和一个大小合适的根（/）分区。

图 4-12. 在 x86 和 AMD64 系统上用 Disk Druid 来分区

图 4-13. 在 Itanium 系统上用 Disk Druid 来分区

安装程序使用的分区工具是 Disk Druid。除了某些较隐晦的情况外，Disk Druid 能够为典型的安装处理其分区要求。

4.17.1. 硬盘驱动器的图形化表示

Disk Druid 提供了对你的硬盘的图形化表示。

单击鼠标来突出显示图形化表示中的某一字段。双击来编辑某个现存的分区或从现存空闲空间中创建分区。

在显示之上，你会看到「Drive」名称（如 /dev/hda），「Geom」（显示了硬盘的几何属性，包括了三个数字分别代表硬盘汇报的柱面、磁头和扇区数量），以及被安装程序检测到的硬盘驱动器「Model」。

4.17.2. Disk Druid 的按钮

这些按钮控制着 Disk Druid 的行为。它们用来改变一个分区的属性（例如文件系统类型和挂载点），还可用来创建 RAID 设备。这个屏幕上的按钮可用来接受你所做的改变，或退出 Disk Druid。为更进一步解释，让我们依次来看一看这些按钮：

  • 「新建」：用来请求一个新分区。当选择后，一个对话框就会出现，其中包括的字段（如挂载点和大小）都必须被填充。

  • 「编辑」：用来修改目前在「分区」部分中选定分区的属性。选择「编辑」打开一个对话框。部分或全部字段可被编辑，这要依据分区信息是否已被写入磁盘而定。

    你还可以编辑图形化显示所表示的空闲空间，从而在那个空间内创建一个新分区。你既可以突出显示空闲空间，然后选择「编辑」按钮，也可以双击空闲空间来编辑它。

  • 要制作一个 RAID 设备，你必须首先创建（或重新利用现有的）软件 RAID 分区。一旦你已创建了两个或两个以上的软件 RAID 分区，选择「RAID」来把软件 RAID 分区连接为一个 RAID 设备。

  • 「删除」：用来删除目前在「当前磁盘分区」部分中突出显示的分区。你会被要求确认对任何分区的删除。

  • 「重设」：用来把 Disk Druid 恢复到它最初的状态。如果你「重设」分区，你所做的所有改变将会丢失。

  • 「RAID」：用来给部分或全部磁盘分区提供冗余性。它只有在你有使用 RAID 的经验时才应使用。关于 RAID 的详情，请参阅《红帽企业 Linux 系统管理指南》。

    要制作一个 RAID 设备，你必须首先创建软件 RAID 分区。一旦你已创建了两个或两个以上的软件 RAID 分区，选择「RAID」来把软件 RAID 分区连接为一个 RAID 设备。

  • 「LVM」：允许你创建一个 LVM 逻辑卷。LVM（逻辑卷管理器）的目的是用来表现基本物理贮存空间如硬盘的简单逻辑视图。LVM 管理单个物理磁盘 — 或者更确切地说，磁盘上的单个分区。它只有在你有使用 LVM 的经验时才应使用。关于 LVM 的详情，请参阅《红帽企业 Linux 系统管理指南》。注意：LVM 只在图形化安装程序中才被提供。

    要创建 LVM 逻辑卷，你必须首先创建类型为物理卷（LVM）的分区。一旦你已创建了一个或多个物理卷（LVM）分区，选择「LVM」来创建 LVM 逻辑卷。

4.17.3. 分区字段

在分区层次之上的信息是代表你正创建的分区的标签。这些标签定义如下：

  • 「设备」：该字段显示分区的设备名。

  • 「挂载点/RAID/Volume」：挂载点是文件卷在目录层次内存在的位置；文件卷在该位置上被“挂载”。该字段标明分区将被挂载的位置。如果某个分区存在，但还没有设立，那么你需要为其定义挂载点。双击分区或点击「编辑」按钮来为其定义挂载点。

  • 「类型」：该字段显示了分区的类型（例如，ext2、ext3、或 vfat）。

  • 「格式化」：该字段显示了正创建的分区是否会被格式化。

  • 「大小 (MB)」：该字段显示了分区的大小（MB）。

  • 「开始」：该字段显示了分区在你的硬盘上开始的柱面。

  • 「结束」：该字段显示了分区在你的硬盘上结束的柱面。

「隐藏 RAID 设备/LVM 卷组成员」：如果你不想看到创建的 RAID 设备或 LVM 卷组成员，选择该选项。

4.17.4. 推荐的分区方案

除非你另有原因，我们推荐你为 Itanuim 系统创建以下分区：

  • 一个 /boot/efi/ 分区（至少100MB）— 挂载在 /boot/efi/ 的分区包含所有安装了的内核、initrd 映像、以及 ELILO 配置文件。

    警告 警告

    你必须在第一个主分区上创建类型为 VFAT、大小至少为100MB的 /boot/efi/ 分区。

  • 一个交换分区（至少512MB） — 交换分区被用来支持虚拟内存。换一句话说，当系统没有足够的内存来贮存正在被处理的数据时，数据就会被写入交换分区。如果你不能肯定要创建多大的交换分区，将它定为系统内存的两倍，但是不要超过2048MB（或2GB）。它的类型必须是 swap。

    窍门 窍门

    如果你的分区方案需要一个大于2GB的交换分区，你应该创建附加的交换分区。例如，如果你的内存是4GB，你可能想创建两个2GB的交换分区。

  • 一个 / 分区（900MB - 5.0GB）— 这是根目录的位置。在这种设置中，所有文件（除了那些贮存在 /boot/efi/ 上的以外）都位于根分区中。它的类型必须是 ext3 或 ext2。

  • 一个 /var/ 分区（3.0GB或更大）— /var/ 分区是写入可变数据的地方。它包括假脱机目录和文件、管理性和记录性数据、中转和临时文件。应用到红帽企业 Linux 的更新被写入 /var/ 分区。

除非你另有原因，我们推荐你为基于 x86 和 AMD64 的系统创建以下分区：：

  • 一个交换分区（至少256MB） — 交换分区被用来支持虚拟内存。换一句话说，当系统没有足够的内存来贮存正在被处理的数据时，数据就会被写入交换分区。如果你不能肯定要创建多大的交换分区，将它定为系统内存的两倍，但是不要超过2048MB（或2GB）。它的类型必须是 swap。

    例如，如果你的内存是1GB或更少，你的交换分区就应该至少和系统内存相等，至多是内存的两倍。对于大于1GB的内存，推荐你使用2GB的交换分区。如果你要在将来升级系统内存，创建一个较大的交换分区就会特别有用。

    窍门 窍门

    如果你的分区方案需要一个大于2GB的交换分区，你应该创建附加的交换分区。例如，如果你的内存是4GB，你可能想创建两个2GB的交换分区。

  • 一个 /boot 分区（100MB）— 挂载在 /boot 中的分区，包含操作系统内核（它允许你的系统引导红帽企业 Linux）、以及在自展过程中使用的文件。鉴于多数 PC BIOS 的限制，创建一个较小的分区来容纳这些文件是一个好办法。对多数用户来说，大小为100MB的引导分区应该是足够了。

    小心 小心

    如果你的硬盘大于1024个柱面（而且你的系统至少是在两年前制造的），而且你想让 /（根）分区使用硬盘上的所有剩余空间，你可能需要创建一个 /boot 分区。

    小心 小心

    如果你有一张 RAID 卡，请注意某些 BIOS 不支持从 RAID 卡中引导。在这种情况下，/boot/ 分区必须在 RAID 阵列之外被创建，如在一个单独的硬盘驱动器上创建。

  • 一个 / 分区（350MB - 5.0GB）— 这是根目录的位置。在这种设置中，所有文件（除了那些贮存在 /boot/ 上的以外）都位于根分区中。

    350MB大的根分区仅允许你进行最小程度的安装，而5.0GB大的根分区允许你执行完整安装，包括所有软件包组。

  • 一个 /var/ 分区（3.0GB或更大）— /var/ 分区是写入可变数据的地方。它包括假脱机目录和文件、管理性和记录性数据、中转和临时文件。应用到红帽企业 Linux 的更新被写入 /var/ 分区。

4.17.5. 添加分区

要添加一个新分区，选择「新建」按钮。一个对话框就会出现（参见图 4-14）。

注记 | 注记
 | 你必须至少把一个分区定为本次安装专用。详情请参阅附录 D。

图 4-14. 创建一个新分区

  • 「挂载点」：输入分区的挂载点。譬如，如果这个分区是根分区，输入 /；如果是 /boot 分区，输入 /boot ，等等。你还可以使用拉下菜单来为你的系统选择正确的挂载点。

  • 「文件系统类型」：使用拉下菜单，选择用于该分区的合适的文件系统。关于文件系统类型的详情，请参阅第 4.17.5.1 节。

  • 「允许的驱动器」：这个字段包括在你的系统上安装的硬盘列表。如果一个硬盘的箱被突出显示，那么在该硬盘上可以创建想要的分区。如果那个箱内没有打勾，那么这个分区在该硬盘上将决不会被创建。靠使用默认的复选箱设置，你能够使用 Disk Druid 在你觉得合适的地方放置分区，或让 Disk Druid 来决定应该放置分区的地方。

  • 「大小（MB）」：输入分区的大小（MB）。注意，该字段从100MB开始；若不改变，创建的分区将只有100MB大。

  • 「其它大小选项」：选择是否要将分区保留为固定大小，允许它“扩大”（使用硬盘驱动器上的可用空间）到某一程度，或允许它“扩大”到使用全部硬盘驱动器上可用的剩余空间。

    如果你选择 「指定空间大小（MB）」，你必须在这个选项右侧的字段内给出大小限制。这会允许你在你的硬盘驱动器上保留一定的空间为将来使用。

  • 「强制为主分区」：选择你所创建的分区是否应为硬盘上的四个主分区之一。如果没有选择，所创建的分区将会是一个逻辑分区。详情请参阅第 D.1.3 节。

  • 「确定」：当你对设置满意并想创建分区的时候，选择「确定」按钮。

  • 「取消」：如果你不想创建这个分区，选择「取消」按钮。

4.17.5.1. 文件系统类型

红帽企业 Linux 允许你依据分区将使用的文件系统来创建不同的分区类型。下面是对不同文件系统以及它们的使用方法的简单描述。

  • 「ext2」 — ext2 文件系统支持标准 Unix 文件类型（常规文件，目录，符号链接等）。它还提供了分派长至 255 个字符文件名的能力。

  • 「ext3」 — ext3 文件系统是基于 ext2 文件系统之上的，它有一个主要优点 — 登记。使用登记的文件系统减少了崩溃后恢复文件系统所花费的时间，因为它没有必要运行 fsck [1]来检查文件系统。ext3 文件系统会被默认选定，且是我们极力推荐的。

  • 「物理卷（LVM）」 — 创建一个或多个物理卷（LVM）分区允许你创建一个 LVM 逻辑卷。LVM 可以在使用物理磁盘的时候提高性能。关于 LVM 的详细信息，请参阅《红帽企业 Linux 系统管理指南》。

  • 「软件 RAID」 — 创建两个或多个软件 RAID 分区允许你创建一个 RAID 设备。关于 RAID 的详情，请参阅《红帽企业 Linux 系统管理指南》中的“RAID（独立磁盘冗余阵列）”这一章。

  • 「交换空间」 — 交换分区被用于支持虚拟内存。换一句话说，如果存放你的系统正要处理的数据所需的内存不够时，这些数据就会被写到你的交换分区上。额外信息请参阅《红帽企业 Linux 系统管理指南》。

  • 「vfat」 — VFAT 文件系统是一个 Linux 文件系统，它与 Microsoft Windows 的 FAT 文件系统的长文件名兼容。这个文件必须被用在 Itanuim 系统的 /boot/efi 分区上。

4.17.6. 编辑分区

要编辑一个分区，选择「编辑」按钮或双击该分区。

注记 | 注记
 | 如果分区在你的硬盘中已经存在，你将只能改变分区的挂载点。如果你想做其它改变，你将需要删除该分区然后再重建它。

4.17.7. 删除一个分区

要删除分区，在「分区」部分将之突出显示，然后点击「删除」按钮。你需要在提示时确认此项删除。

关于基于 x86 和 AMD64 的系统的安装说明，请跳到第 4.18 节。

关于 Itanium 系统的安装说明，请跳到第 4.19 节。

注

[1]

fsck 程序被用来检查文件系统元数据统一性，还可以选用它维修一个或多个 Linux 文件系统。

后退 | 起点 | 前进
自动分区 | 上级 | x86 和 AMD64 系统的引导装载程序配置


磁盘分区设置

后退 第 4章 . 安装红帽企业 Linux 前进

4.15. 磁盘分区设置

分区允许你将硬盘驱动器分隔成独立的区域，每个区域都如同是一个单独的硬盘驱动器。如果你运行不止一个操作系统，分区就特别有用。如果你不能肯定想要如何给系统分区，请阅读附录 D。

在这个屏幕上，你可以选择自动分区，或者使用 Disk Druid 来手工分区。

自动分区允许你不必亲自为驱动器分区而执行安装。如果你对在系统上分区信心不足，建议你不要选择手工分区，而是让安装程序自动为你分区。

要手工分区，选择 Disk Druid 分区工具。

警告 | 警告
 | 红帽更新代理默认把更新的软件包下载到 /var/spool/up2date/ 中。如果你要手工给系统分区，并创建一个单独的 /var/ 分区，请确定给这个分区保留足够的空间（大于3.0GB）来容纳下载的软件包更新。

图 4-10. 磁盘分区设置

如果你选择使用 Disk Druid 来手工分区，请参阅第 4.17 节。

警告 | 警告
 | 如果你在安装过程的「磁盘分区设置」阶段看到一则和如下相似的消息： 「设备 hda 上的分区表无法被读取。创建新分区时必须对其执行初始化，从而会导致该驱动器中的所有数据丢失。」 你在那个驱动器上可能没有分区表，或者那个驱动器上的分区表无法被安装程序所用的分区软件识别。 使用过 EZ-BIOS 之类程序的用户可能遇到过相似的问题，从而导致了数据丢失（假定安装前没有进行备份）。 无论你执行的是哪一种安装类型，你都应该为系统上的现存数据进行备份。
后退 | 起点 | 前进
鼠标配置 | 上级 | 自动分区


防火墙配置

后退 第 4章 . 安装红帽企业 Linux 前进

4.20. 防火墙配置

红帽企业 Linux 为增加系统安全性提供了防火墙保护。防火墙存在于你的计算机和网络之间，用来判定网络中的远程用户有权访问你的计算机上的哪些资源。一个正确配置的防火墙可以极大地增加你的系统安全性。

图 4-19. 防火墙配置

为你的系统选择恰当的安全级别。

「无防火墙」

「无防火墙」给予完全访问权并不做任何安全检查。安全检查是对某些服务的禁用。建议你只有在一个可信任的网络（非互联网）中运行时，或者你想稍后再进行详细的防火墙配置时才选此项。

「启用防火墙」

如果你选择了「启用防火墙」，你的系统就不会接受那些没有被你具体指定的连接（除了默认设置外）。按照默认设置，只有答复输出请求如 DNS 答复或 DHCP 请求的连接是允许。如果需要访问在这个机器上运行的服务，你可以选择允许指定的服务穿过防火墙。

如果你要把系统连接到互联网上，但是并不打算运行服务器，这是最安全的选择。

下一步，选择应该被允许穿过防火墙的服务。

启用这些选项将允许具体指定的服务穿过防火墙。注意：这些服务在系统内可能没有被安装。请确定你选择启用了你可能需要的选项。

「WWW (HTTP)」

HTTP 协议被 Apache（以及其它万维网服务器）用来进行网页服务。如果你打算向公众开放你的万维网服务器，请启用该选项。你不必启用该选项来本地查看网页或开发网页。如果你打算提供网页服务的话，你需要安装 httpd 软件包。

启用「WWW (HTTP)」将不会为 HTTPS 打开一个端口。要启用 HTTPS，在「其它端口」字段内注明。

「FTP」

FTP 协议是用于在网络机器间传输文件的协议。如果你打算使你的 FTP 服务器可被公开利用，启用该选项。你需要安装 vsftpd 软件包才能利用该选项。

「SSH」

Secure（安全）SHell（SSH）是用来在远程机器上登录及执行命令的一组工具。如果你打算使用 SSH 工具通过防火墙来访问你的机器，启用该选项。你需要安装 openssh-server 软件包以便使用 SSH 工具来远程访问你的机器。

「Telnet」

Telnet 是用来在远程机器上登录的协议。Telnet 通信是不加密的，几乎没有提供任何防止网络刺探之类行为的安全措施。建议你不要允许进入的 Telnet 访问。如果你想允许进入的 Telnet 访问，你必须安装 telnet-server 软件包。

「邮件 (SMTP)」

如果你想允许进入的邮递服务穿过你的防火墙，因此远程主机可以直接连接到你的机器来发送邮件，启用该选项。如果你想从你的 ISP 服务器中收取 POP3 或 IMAP 邮件，或者你使用的是 fetchmail 之类的工具，不要启用该选项。请注意，不正确配置的 SMTP 服务器会允许远程机器使用你的服务器来发送垃圾邮件。

你可以允许到这里没有列出的其它端口的访问，方法是在「其它端口」字段内把它们列出。格式为：端口:协议。例如，如果你想允许 IMAP 通过你的防火墙，你可以指定 imap:tcp。你还可以具体指定端口号码，要允许 UDP 分组在端口 1234 通过防火墙，输入 1234:udp。要指定多个端口，用逗号将它们隔开。

最后，选择任何你认为应该允许来自它的所有交通到你的系统的设备。

选择信任的设备中的任何一个将会允许你的系统接受来自这一设备的全部交通；它不受防火墙规则的限制。例如，如果你在运行一个局域网，但是通过 PPP 拨号连接到了互联网上，你可以选择「eth0」，而后所有来自你的局域网的交通将会被允许。把「eth0」选为“信任的”意味着所有这个以太网内的交通都是被允许的，但是 ppp0 接口仍旧有防火墙限制。如果你想限制某一接口上的交通，不要选择它。

建议你不要将连接到互联网之类的公共网络上的设备定为信任的设备。

窍门 | 窍门
 | 要在安装完毕后改变你的安全级别配置，使用安全级别配置工具。 在 shell 提示下键入 redhat-config-securitylevel 命令来启动安全级别配置工具。如果你不是根用户，它会提示你输入根口令后再继续。
后退 | 起点 | 前进
网络配置 | 上级 | 语言支持的选择


文本模式安装程序用户界面

后退 第 4章 . 安装红帽企业 Linux 前进

4.2. 文本模式安装程序用户界面

红帽企业 Linux 文本模式安装程序使用一个基于屏幕的界面，它包括多数通常在图形化用户界面中能够看到的屏幕“构件”。图 4-1和图 4-2示范了你将会看到的屏幕。

注记 | 注记
 | 虽然有关文本模式安装的说明不是十分充分，使用文本模式安装的用户仍旧可以遵循图形化安装说明来获得所需信息。

图 4-1. 在「引导装载程序配置」中所见的安装程序构件

图 4-2. 在 Disk Druid 中所见的安装程序构件

下面是一列在图 4-1和图 4-2中显示的最重要的构件：

  • 窗口 — 在整个安装进程中，你会不时地在屏幕上看到窗口（本书中通常把它称为对话框，dialog）。有时，一个窗口会重叠在另一个窗口之上；在这种情况下，你只能与最上面的窗口交流。当该窗口使用完毕，它就会消失，允许你继续使用下面的窗口。

  • 复选箱 — 复选箱允许你选择或取消选择某项功能。箱内要么显示一个星号（已选），要么是一个空格（未选）。当光标位于复选箱内，按 [Space] 键来选择一个未选的功能或取消一个已选的功能。

  • 文本输入行 — 文本输入行是你可以输入安装程序所要求信息的区域。当光标停在文本输入行时，你可以在那一行中输入并（或）编辑信息。

  • 文本构件 — 文本构件是屏幕上用于显示文本的区域。有时，文本构件可能还会含有其它构件，如复选箱。如果文本构件所含的信息超出为它保留的空间所能显示的，一个滚动条就会出现；如果你将光标定位于文本构件之内，你可以使用[向上]和[向下] 箭头键来在所有信息中上下滚动。你在滚动条上的当前位置被显示为一个 # 字符，它会在你拖拉滚动条时移上移下。

  • 滚动条 — 滚动条出现在窗口的侧面或底部，它用来控制窗框内显示的文档或列表部分。滚动条使你能够轻而易举地查看文件的任意部分。

  • 按钮构件 — 按钮构件是与安装程序交流的主要方法。通过 [Tab] 键和 [Enter] 键使用这些按钮，你可在安装程序的屏幕中逐步推进。当按钮被突出显示时，它们可以被选择。

  • 光标 — 光标虽然不是一个构件，但它被用来选择（并联络）某个特定构件。当光标从一个构件移至另一个构件后，它可能会导致构件改变颜色，或者你可能只会看到光标本身定位在构件内或构件旁。在图 4-1中，光标定位在「确定」按钮上。图 4-2显示了光标定位在「编辑」按钮上。

4.2.1. 使用键盘来导航

在安装对话框之间的切换是通过一组简单的击键来达到的。要移动光标，使用 [向左]、[向右]、[向上]、和[向下]箭头键。使用 [Tab] 和 [Alt]-[Tab] 键来在屏幕上的每个构件间向前或向后循环。多数屏幕在底部显示了一个可用光标定位键的摘要。

要“按”一个按钮，将光标定位在按钮之上（例如，使用 [Tab] 键），然后按 [Space] 或 [Enter] 键。要从一列项目中选择一项，将光标移至你要选择的项目，然后按 [Enter] 键。要选择一个带复选箱的项目，将光标移至复选箱内，然后按 [Space] 键来选择这个项目。要取消选择，再按一次 [Space] 键。

按 [F12] 来接受当前值，并继续到下一个对话框；这相当于按「确定」按钮。

小心 | 小心
 | 除非一个对话框在等待你的输入，在安装进程中不要随意按键（这么做可能会导致无法预料的行为）。
后退 | 起点 | 前进
安装红帽企业 Linux | 上级 | 启动安装程序


Itanium 系统 — EFI Shell

后退 第 1章 . Itanium 系统特有信息 前进

1.2. Itanium 系统 — EFI Shell

在 Itanium 系统上开始安装红帽企业 Linux 之前，你必须对 EFI Shell、它的作用、它所能提供的信息有个基本的了解。

EFI Shell 是一个用来启动应用程序（如红帽企业 Linux 安装程序）、载入 EFI 协议和设备驱动程序、和执行简单脚本的控制台界面。它和 DOS 控制台相仿，只能够进入 FAT16 (VFAT) 格式化的介质。

EFI Shell 还包含能够在 EFI 系统分区上使用的常用工具。这些工具有：edit、type、cp、rm、和 mkdir。要获得工具列表和其它命令，在 EFI Shell 提示下键入 help。

EFI Shell 中包含一个叫做 ELILO 的引导装载程序。关于 EFI 的额外信息可以在以下 URL 中找到：

http://developer.intel.com/technology/efi/index.htm

1.2.1. Itanium 系统 — EFI 设备名称

map 命令可以被用来列举所有 EFI 能够识别的设备和文件系统。当你的 Itanium 系统引导入 EFI shell，它会按以下顺序探测你的系统：

  1. LS-120 驱动器（如果它包含介质）

  2. 在主 IDE 接口上的 IDE 硬盘驱动器

  3. 在次 IDE 接口的 IDE 硬盘驱动器

  4. 在 SCSI 接口上的 SCSI 硬盘驱动器

  5. 在 IDE 接口上的光盘驱动器

  6. 在 SCSI 接口上的光盘驱动器

要查看系统轮询的结果，在 EFI Shell 提示下键入以下命令：

map

其输出会按照系统探测的顺序被列出。因此，所有 FAT16 文件系统被首先列出，然后是 IDE 硬盘驱动器，然后是 SCSI 硬盘驱动器，然后是 IDE 光盘驱动器，最后是 SCSI 光盘驱动器。

例如，map 命令的输出会和以下类似：

Device mapping table
  fs0  : VenHw(Unknown Device:00)/HD(Part1,Sig00000000)
  fs1  : VenHw(Unknown Device:80)/HD(Part1,Sig00000000)
  fs2  : VenHw(Unknown Device:FF)/CDROM(Entry1)/HD(Part1,Sig00000000)
  blk0 : VenHw(Unknown Device:00)
  blk1 : VenHw(Unknown Device:00)/HD(Part1,Sig00000000)
  blk2 : VenHw(Unknown Device:80)
  blk3 : VenHw(Unknown Device:80)/HD(Part1,Sig00000000)
  blk4 : VenHw(Unknown Device:80)/HD(Part2,Sig00000000)
  blk5 : VenHw(Unknown Device:80)/HD(Part3,Sig00000000)
  blk6 : VenHw(Unknown Device:80)/HD(Part3,Sig00000000)/HD(Part1,Sig725F7772)
  blk7 : VenHw(Unknown Device:FF)
  blk8 : VenHw(Unknown Device:FF)/CDROM(Entry1)
  blk9 : VenHw(Unknown Device:FF)/CDROM(Entry1)/HD(Part1,Sig00000000)

在这个例子中，LS-120 驱动器中有一个 LS-120 磁盘，光盘驱动器中也有一个光盘。所有列举项目中以 fs 开头的是 EFI 能够读取的 FAT16 文件系统。所有列举项目中以 blk 开头的是 EFI 能够识别的块设备。文件系统和块设备都是按照它们被探测到的顺序被列出的。因此，fs0 是 LS-120 上的系统分区，fs1 是硬盘驱动器上的系统分区，fs2 是光盘上的系统分区。

1.2.2. Itanium 系统 — EFI 系统分区

当为 Linux 来给硬盘驱动器分区时，你必须创建一个 FAT16 (VFAT) 格式的系统分区，并有一个 /boot/efi/ 挂载点。该分区包含安装了的 Linux 内核以及 ELILO 配置文件（elilo.conf）。elilo.conf 文件包含你可以引导系统的内核列表。

后退 | 起点 | 前进
Itanium 系统特有信息 | 上级 | 安装前的准备工作


Itanium 系统 — 引导机器和安装后的设置

后退 第 4章 . 安装红帽企业 Linux 前进

4.30. Itanium 系统 — 引导机器和安装后的设置

本节描述了如何在 Itanium 系统上引导红帽企业 Linux，如何设置 EFI 控制台变量，因此当机器的上电序列完成后会自动引导红帽企业 Linux。

当安装程序结束后你重新引导了系统之后，键入以下命令来引导红帽企业 Linux：

elilo

键入了 elilo 后，在 /boot/efi/elilo.conf 配置文件中列举的默认内核就会被载入。（文件中列举的第一个内核是默认内核。）

如果你想载入一个不同的内核，在 elilo 命令之后键入 /boot/efi/elilo.conf 中的内核的标签。例如，要载入叫做 linux 的内核，键入：

elilo linux

如果你不知道安装了的内核的名称，你可以使用以下说明来在 EFI 中查看 /boot/efi/elilo.conf 文件：

  1. 在 Shell> 提示下，把设备改到系统分区（Linux 中被挂载为 /boot/efi）。例如，如果 fs0 是系统引导分区，在 EFI Shell 提示下键入 fs0:。

  2. 在 fs0:\> 提示下键入 ls 会确定你所在的分区是否正确。

  3. 然后键入：

    Shell>type elilo.conf

    该命令显示配置文件的内容。每个实例都包含一行，开头为 label，其后跟随那个内核的标签。标签名称是你在 elilo 之后要键入来引导不同内核的名称。

4.30.1. 安装后引导装载程序选项

除了指定要载入的内核外，你还可以输入其它引导选项，如 single 会引导单用户模式，或 mem=1024M 来强制红帽企业 Linux 使用 1024MB 内存。要给引导装载程序传递选项，在 EFI Shell 提示下输入以下内容（把 linux 替换成你想引导的内核名称，把 option 替换成你想传递给内核的选项）：

elilo linux option

4.30.2. 自动引导红帽企业 Linux

安装了红帽企业 Linux 之后，每次想引导 Itanium 系统时，你都可以在 EFI Shell 提示下键入 elilo 和任何引导选项。然而，如果你想配置你的系统自动引导红帽企业 Linux，你需要配置 EFI Boot Manager。

要配置 EFI Boot Manager（可能会根据硬件而有所不同）：

  1. 引导 Itanium 系统，然后从 EFI Boot Manager 菜单中选择 Boot option maintenance menu。

  2. 从主菜单中选择 Add a Boot Option。

  3. 选择在 Linux 中被挂载为 /boot/efi/ 的系统分区。

  4. 选择 elilo.efi 文件。

  5. 在 Enter New Description: 提示下，键入 Red Hat Enterprise Linux 3，或你想在 EFI Boot Manager 菜单中显示的名称。

  6. 在 Enter Boot Option Data Type 提示下，如果你不想给 ELILO 引导装载程序传递选项，输入 N 代表 No Boot Option。这个选项在多数情况下都能奏效。如果你想给引导装载程序传递选项，你可以在 /boot/efi/elilo.conf 配置文件中配置。

  7. 对 Save changes to NVRAM 提示回答 Yes。这会把你返回到 EFI Boot Maintenance Manager 菜单中。

  8. 下一步，让 Red Hat Enterprise Linux 3 这个菜单项目成为默认引导项目。一个引导选项列表会出现。把 Red Hat Enterprise Linux 3 菜单项目移到列表顶端，方法是使用箭头键来选择它，然后按 [u] 键来把它向上移动。你还可以按 [d] 键把项目向下移动。改变了引导顺序后，选择 Save changes to NVRAM。选择 Exit 来返回到主菜单。

  9. 另外，你还可以从主菜单上选择 Set Auto Boot TimeOut => Set Timeout Value 来改变引导超时值。

  10. 选择 Exit 来返回到 EFI Boot Manager。

4.30.2.1. 使用启动脚本

推荐你配置 ELILO Boot Manager 来自动引导红帽企业 Linux 。然而，如果你在启动 ELILO 引导装载程序之前需要执行额外的命令，你可以创建一个叫做 startup.nsh 的启动脚本。最后一个命令应该是引导 Linux 的 elilo 命令。

startup.nsh 脚本应该位于 /boot/efi 分区（/boot/efi/startup.nsh），并包含以下内容：

echo -off
your set of commands
elilo

如果你想给引导装载程序传递选项（参阅第 4.30.1 节），请在 elilo 之后添加它们。

你可以引导红帽企业 Linux 后创建这个文件，也可以使用 EFI shell 内建的编辑器来创建它。要使用 EFI shell，在 Shell> 提示下，把设备改到系统分区（在 Linux 中被挂载为 /boot/efi）。例如，如果 fs0 是系统引导分区，在 EFI Shell 提示下键入 fs0:。键入 ls 来确定你位于正确的分区。然后键入 edit startup.nsh。键入文件的内容然后保存它。

在系统下次引导时，EFI 就会检测到 startup.nsh 文件，并使用它来引导系统。要停止 EFI 载入文件，键入 [Ctrl]-[c]。这会中止进程，并把你返回到 EFI shell 提示下。

后退 | 起点 | 前进
安装完成 | 上级 | 给你目前的系统升级


选择一种安装方法

后退 第 4章 . 安装红帽企业 Linux 前进

4.4. 选择一种安装方法

你想使用哪一种安装方法？可用的安装方法如下所列：

光盘

如果你有一个光盘驱动器和红帽企业 Linux 光盘，你可以使用这种方法。你将需要一个引导盘或红帽企业 Linux 的第一张光盘。PCMCIA 驱动程序盘也可能被使用。有关光盘安装的说明，请参阅第 4.5 节。

硬盘驱动器

如果你已将红帽企业 Linux ISO 映像复制到本地硬盘驱动器中，你可以使用这种方法。你将需要一个引导盘或一个可引导的光盘（使用 linux askmethod 引导选项）。PCMCIA 驱动程序盘也可能被使用。有关硬盘驱动器安装的说明，请参阅第 4.6 节。

NFS

如果是从一个 NFS 服务器中使用 ISO 映像或红帽企业 Linux 的镜像映像来安装，你可以使用这种方法。你将需要一个引导盘或一个引导光盘（使用 linux askmethod 引导选项）。你可能还需要一个网络驱动程序盘。PCMCIA 驱动程序盘也可能被使用。有关网络安装的说明，请参阅第 4.8 节。还请注意，NFS 安装也可以在图形化模式中执行。

FTP

如果你是从一个 FTP 服务器中直接安装，使用这种方法。你将需要一个引导盘或一个引导光盘（使用 linux askmethod 引导选项）。你可能还需要一个网络驱动程序盘。PCMCIA 驱动程序盘也可能被使用。有关 FTP 安装的说明，请参阅第 4.9 节。

HTTP

如果你是从一个 HTTP（万维网）服务器中直接安装，使用这种办法。你将需要一个引导盘或一个引导光盘（使用 linux askmethod 引导选项）。你可能还需要一个网络驱动程序盘。PCMCIA 驱动程序盘也可能被使用。有关 HTTP 安装的说明，请参阅第 4.10 节。

后退 | 起点 | 前进
启动安装程序 | 上级 | 从光盘中安装


安装软件包

后退 第 4章 . 安装红帽企业 Linux 前进

4.26. 安装软件包

到了这一步，在所有软件包被安装之前你将不必进行任何操作。安装的快慢要依据你所选择的软件包数量和你的计算机的速度而定。

后退 | 起点 | 前进
准备安装 | 上级 | 视频卡配置


辅助功能的解决办法

后退 介绍 前进

3. 辅助功能的解决办法

尽管图形化用户界面（GUI）对视觉无碍的用户来说极为方便，对于视觉有缺陷的用户来说，由于语音合成器难以解释图形，GUI 的方便性通常大受制约。红帽企业 Linux 是适用于视觉有缺陷的用户的理想操作系统，因为内核并不需要图形化界面。多数现代工具，包括电子邮件、新闻、万维网浏览器、日历、计算器等等，都可以在 Linux 上不使用图形化环境而运行。这个工作环境还可以被定制以满足用户的硬件或软件需求。

因为无论您购买的是哪一种盒装产品，其中都提供了卓越的支持，所以 Red Hat, Inc. 是有特殊需要的用户的理想选择。许多 Linux 发行版本给顾客所提供的支持要么是非常有限的，要么根本不存在。Red Hat 的支持是通过电子邮件或电话来提供的。我们还考虑特殊情况，并对身体有残疾的用户会提供特殊待遇。如果您需要特别支持，请通知我们的支持技术员。

详情请参考：

  • http://www.tldp.org/HOWTO/Accessibility-HOWTO/

  • http://www.tldp.org/HOWTO/Keyboard-and-Console-HOWTO.html

  • README-Accessibility 文件提供了关于如何使用为有特殊需要的用户所提供的工具的详细信息和说明。该文件可在 /usr/share/doc/redhat-release-X/ 目录下找到。这里的 X 是你所安装的产品的发行版本号码。

后退 | 起点 | 前进
如何使用本书 | 上级 | Itanium 系统特有信息


如何使用本书

后退 介绍 前进

2. 如何使用本书

本书着重于基于光盘的安装，因此它是寻求简便快捷安装方法的新老用户们的理想选择。它将会帮助你做好安装前的系统准备，并指导你完成红帽企业 Linux 的整个安装过程。

注记 注记

如果你当前在一个 x86 系统上使用红帽企业 Linux 2.1（或更高），你可以执行升级。

虽然用于 x86 处理器上的红帽企业 Linux 产品族支持升级，如果你备份数据后再在从前的红帽企业 Linux 安装上安装本版红帽企业 Linux，你可能会有一个更连贯的系统。所推荐的这种方法会帮助你确保系统的稳定性。

要执行升级，在引导提示下键入以下命令：

linux upgrade

大致浏览第2章 来重温基本知识，然后仔细阅读第4章 。读时遵循指点。一旦你已决定要在安装中升级，请参阅附录 A。

如果你是一位有经验的用户，不需要温习基本知识，你可以跳到第4章 来开始安装进程。

2.1. 我们需要用户的反馈！

如果你在《红帽企业 Linux 安装指南》中发现错别字，或者有改进本书的建议，我们很希望能收到您的来函！请向以下的 Bugzilla 网站提交一份关于 rhel-ig-x8664-multi 的报告：

http://bugzilla.redhat.com/bugzilla/

在提交报告的时候，请明确指定本书的标记：

rhel-ig-x8664-multi(ZH-CN)-3-HTML-RHI (2003-07-25T17:10)

如果你有改进本书的建议，请尽可能详细地阐明。如果你发现了错误，请包括所在章节及段落，因此我们可以轻易地查找到。

如果你有支持方面的疑问（譬如：如果你需要有关配置 X 的帮助，或者你不能肯定应如何给硬盘驱动器分区），请在下面的网页中注册你的产品以获得在线支持：

http://www.redhat.com/apps/activate/
后退 | 起点 | 前进
介绍 | 上级 | 辅助功能的解决办法


键盘配置

后退 第 4章 . 安装红帽企业 Linux 前进

4.13. 键盘配置

使用鼠标来选择你要在本次安装中和今后使用的系统默认键盘布局类型（例如，美国英语式），参见图 4-8。

选定后，点击「下一步」来继续。

图 4-8. 键盘配置

窍门 | 窍门
 | 要在你安装结束后改变键盘类型，使用键盘配置工具。 在 shell 提示下键入 redhat-config-keyboard 命令来启动键盘配置工具。如果你不是根用户，它会提示你输入根口令再继续。
后退 | 起点 | 前进
语言选择 | 上级 | 鼠标配置


语言选择

后退 第 4章 . 安装红帽企业 Linux 前进

4.12. 语言选择

使用鼠标来选择你想在安装中使用的语言（参见图 4-7）。

选择恰当的语言会在稍后的安装中帮助你定位时区。安装程序将会试图根据你在这个屏幕上所指定的信息来选择恰当的时区。

图 4-7. 语言选择

当你选定了恰当的语言后，点击「下一步」 来继续。

后退 | 起点 | 前进
欢迎使用红帽企业 Linux | 上级 | 键盘配置


语言支持的选择

后退 第 4章 . 安装红帽企业 Linux 前进

4.21. 语言支持的选择

你的系统上可以安装并支持多种语言。

你必须选择一种语言作为你的默认语言。当安装结束后，你的系统中将会使用默认语言。如果你在安装中还选择安装了其它语言，你可以在安装后改变你的默认语言。

如果你只打算在系统上使用一种语言，只选择那种语言将会节省大量磁盘空间。默认语言是你在安装中选择要使用的语言。

小心 | 小心
 | 如果你只选择了一种语言，当安装完成后，你将只能使用该种语言。

图 4-20. 语言支持的选择

要在你的系统上使用多种语言，具体指定要安装的语言，或者选择在你的红帽企业 Linux 系统上安装所有可用语言。

使用「重设」按钮来取消你的选择。重设会还原到默认设置；只有你选定在安装中使用的语言会被安装。

窍门 | 窍门
 | 要在安装结束后改变语言配置，使用语言配置工具。 在 shell 提示下键入 redhat-config-language 命令来启动语言配置工具。如果你不是根用户，它会提示你输入根口令后再继续。
后退 | 起点 | 前进
防火墙配置 | 上级 | 时区配置


鼠标配置

后退 第 4章 . 安装红帽企业 Linux 前进

4.14. 鼠标配置

为你的系统选择正确的鼠标类型。如果你找不到确切的匹配，选择你确定会与你的系统兼容的鼠标类型，（参见图 4-9）。

要判定你的鼠标接口，沿着鼠标线缆追踪到与你的系统相接的地方，然后参考以下图表。

如果你的鼠标是串口鼠标，它的端口看起来类似： 。

如果你的鼠标是 PS/2 鼠标，它的端口看起来类似： 。

如果你的鼠标是 USB 鼠标，它的端口看起来类似： 。

如果你找不到一个你能确定与你的系统兼容的鼠标，根据你的鼠标的键数和它的接口，选择「通用」项目中的一个。

窍门 | 窍门
 | 如果你有一个带滑轮的鼠标，选择「通用 - 带滑轮鼠标」项目（带有正确鼠标端口的）作为兼容的鼠标类型。

如果你有一个 PS/2、USB、或总线鼠标，你不必挑选端口或设备。如果你有一个串口鼠标，你应该选择该鼠标所在的正确端口和设备。

「模拟 3 键」 复选箱允许你象使用三键鼠标一样使用双键鼠标。一般来说，三键鼠标在图形化界面（X 窗口系统）中使用起来比较方便。如果你选择了这个复选箱，你可以同时按鼠标的两键来模拟第三个“中间”键。

图 4-9. 鼠标配置

窍门 | 窍门
 | 要在安装结束后改变鼠标配置，使用鼠标配置工具。 在 shell 提示下键入 redhat-config-mouse 命令来启动鼠标配置工具。如果你不是根用户，它会提示你输入根口令后再继续。 要把鼠标配置成左手用鼠标，请重设鼠标按钮的顺序。方法是：重新引导系统后，点击面板上的「主菜单」 => 「首选项」 => 「鼠标」。
后退 | 起点 | 前进
键盘配置 | 上级 | 磁盘分区设置


网络配置

后退 第 4章 . 安装红帽企业 Linux 前进

4.19. 网络配置

如果你没有网络设备，你将看不到这个屏幕。请向前跳到第 4.20 节。

图 4-17. 网络配置

安装程序会自动检测到你拥有的任何网络设备，并把它们显示在「网络设备」列表中。

选定网络设备后，点击「编辑」。从弹出的「编辑接口」屏幕上，你可以选择通过 DHCP 来配置网络设备的 IP 地址和子网掩码（若没有选择 DHCP 则手工配置），你还可以选择在引导时激活该设备。如果你选择了「引导时激活」，你的网络接口就会在引导时被启动。如果你没有 DHCP 客户的访问权，或者你不能肯定这里该提供什么信息，请和你的网络管理员联系。

图 4-18. 编辑网络设备

注记 | 注记
 | 不要使用在配置例子中见到的数字。这些数字将在你自己的网络配置中行不通。如果你不能肯定应该输入什么数值，请联系你的网络管理员来得到协助。

如果你的网络设备有一个主机名（全限定域名），你可以选择要 DHCP（动态主机配置协议）自动检测它，或者在提供的字段中手工输入主机名。

最后，如果你手工地输入了 IP 和子网掩码信息，你可能还得输入网关、主要、次要、和第三 DNS 地址。

窍门 | 窍门
 | 即便你的计算机不属于任何网络，你也可以为你的系统输入一个主机名。如果你不借助这个机会输入一个名称，你的系统将会被称为 localhost。

窍门 | 窍门
 | 要在安装结束后改变你的网络配置，使用网络管理工具。 在 shell 提示下键入 redhat-config-network 命令来启动 网络管理工具。如果你不是根用户，它会提示你输入根口令后再继续。
后退 | 起点 | 前进
x86 和 AMD64 系统的引导装载程序配置 | 上级 | 防火墙配置


软件包组的选择

后退 第 4章 . 安装红帽企业 Linux 前进

4.24. 软件包组的选择

当分区被选定并按配置格式化后，你便可以选择要安装的软件包了。

首先，一个详细列举你的红帽企业 Linux 安装的默认软件包集合的屏幕会出现。该屏幕会根据你要安装的红帽企业 Linux 版本的不同而有所不同。

图 4-23. 默认软件包列表确认

要进一步定制你的软件包，选择屏幕上的「定制要安装的软件包集合」选项。点击「下一步」会把你带到「选择软件包组」屏幕。

如果你选择要接受当前的软件包列表，向前跳到第 4.25 节。

你可以选择根据功能归类的软件包组（譬如，「X 窗口系统」、「编辑器」）；单个软件包；或者两者的组合。

注记 | 注记
 | 我们鼓励想得到开发或运行 32 位应用程序支持的 AMD64 和 Itanium 系统用户选择「兼容性体系支持」和「兼容性体系开发支持」软件包来为系统安装体系特有的支持。

要选择一个组件，点击它旁边的复选箱（参见图 4-24）。

图 4-24. 软件包组的选择

选择你想要安装的每个组件。在定制安装中选择「全部」（在组件列表的结尾处）会安装包括在红帽企业 Linux 中的所有软件包。

选定了软件包组后，点击「细节」来查看哪些软件包会被默认安装，还可以在该组中添加或删除可选软件包。

图 4-25. 软件包组细节

后退 | 起点 | 前进
设置根口令 | 上级 | 准备安装


准备安装

后退 第 4章 . 安装红帽企业 Linux 前进

4.25. 准备安装

你应该看到一个为你安装红帽企业 Linux 做准备的屏幕。

当你重新引导系统后，一份完整的安装日志可在 /root/install.log 中找到，以备今后参考。

警告 | 警告
 | 如果由于某种原因，你宁愿不继续安装进程， 这是你可以安全取消并重新引导系统的最后机会。一旦你按下了「下一步」按钮，分区将会被写入，软件包将会被安装。如果你想中止安装，你现在就应该在任何信息被重新写入任何硬盘驱动器之前重新引导。

要取消安装进程，按你的计算机的重设按钮，或者使用 [Control]-[Alt]-[Delete] 组合键来重启你的机器。

后退 | 起点 | 前进
软件包组的选择 | 上级 | 安装软件包


你的硬件兼容吗？

后退 第 2章 . 安装前的准备工作 前进

2.3. 你的硬件兼容吗？

如果你有一个老式的系统，或者你的系统是自装的，硬件兼容性在这些情况下就显得特别重要。红帽企业 Linux 3 应该与在最近两年内厂家制作的系统内的多数硬件兼容。然而，硬件的技术规范几乎每天都在改变，因此我们很难保证你的硬件会百分之百地兼容。

最新的硬件支持列表可在以下网址中查到：

http://hardware.redhat.com/hcl/
后退 | 起点 | 前进
注册您的产品 | 上级 | 你有足够的磁盘空间吗？


筹备硬盘驱动器安装

后退 第 2章 . 安装前的准备工作 前进

2.7. 筹备硬盘驱动器安装

硬盘驱动器安装要求你具备一个已安装的可用 Linux 系统和 ISO 映像，而不是整个安装树。

硬盘驱动器安装只能从 ext2 或 ext3 文件系统中进行。

  • 光盘集合 — 从每个安装光盘中创建光盘 ISO 映像文件。对于每个光盘，在 Linux 系统上执行以下命令：
      dd if=/dev/cdrom of=/tmp/file-name.iso

  • ISO 映像 — 把这些映像传输到要安装的系统上。

    在试图安装前，请校验 ISO 映像的完整性。这会帮助你避免硬盘安装过程中经常会遇到的问题。要在执行安装前校验 ISO 映像的完整性，请使用 md5sum 程序（该程序有适用于各类操作系统的版本）。md5sum 程序应该可以在提供 ISO 映像的同一服务器上找到。

后退 | 起点 | 前进
筹备网络安装 | 上级 | 系统需求表


你能用光盘安装吗？

后退 第 2章 . 安装前的准备工作 前进

2.5. 你能用光盘安装吗？

可以用来安装红帽企业 Linux 的方法有好几种。

从光盘中安装要求你已购买了红帽企业 Linux 3 产品，或者你拥有红帽企业 Linux 光盘，以及光盘驱动器。多数新计算机会允许你从光盘引导。如果你的系统支持从光盘引导，这种启动本地光盘安装方法将非常简便。

你可能需要改变你的 BIOS 来允许从光盘驱动器引导。关于改变 BIOS 的详情，请参阅第 4.3.1 节。

2.5.1. 其它引导方法

引导光盘

如果你可以使用光盘驱动器来引导，你便能够创建你自己的光盘来引导安装程序。这在你执行网络或硬盘安装时会非常有用。详细说明请参见第 2.5.2 节。

如果你选择要创建一个引导光盘，你就没必要创建驱动程序盘。

如果你无法从光盘驱动器引导，你可以使用以下的引导方法：

引导盘

如果你需要一个引导盘（boot diskette） [1]，你必须制作它。如果你无法从光盘中引导，你就需要一个引导盘。它可以用来从网络、块设备或 PCMCIA 设备中引导（你将还需要相应的驱动程序盘）。

引导盘的映像文件 bootdisk.img 位于第一张红帽企业 Linux 光盘的 images/ 目录中。关于制作引导盘的信息，请参阅第 2.5.3 节。

如果你选择要创建引导盘，并且要通过网络或硬盘驱动器安装，你必须还得创建合适的驱动程序盘。

驱动程序盘

如果你执行的安装不是 IDE 光盘或硬盘安装，而且你在使用引导盘，你将至少需要一个事先制作的驱动程序盘。安装程序会在适当的时候提示你插入驱动程序盘。

关于驱动程序盘的详细信息，请参阅附录 E。

在红帽企业 Linux 的安装期间，你可能需要以下驱动程序盘：

网络设备驱动程序盘

如果你需要一个网络设备驱动程序盘（network device drivers diskette）来从网络中引导，你必须创建它。网络驱动程序盘的映像文件 drvnet.img 位于第一张红帽企业 Linux 光盘中的 images/ 目录下。有关制作磁盘的详情，请参阅第 2.5.3 节或附录 E。

块设备驱动程序盘

如果你需要一个块设备驱动程序盘（block device driver diskette）来从块设备中引导（如 SCSI 光盘驱动器），你必须创建它。块设备驱动程序盘的映像文件 drvblock.img 位于第一张红帽企业 Linux 光盘中的 images/ 目录下。有关制作磁盘的详细信息，请阅读第 2.5.3 节或附录 E。

PCMCIA 设备驱动程序盘

如果你要使用 PCMCIA 设备来安装红帽企业 Linux，你就需要一个 PCMCIA 设备驱动程序盘（PCMCIA device driver diskettes）。如果你需要 PCMCIA 设备驱动程序盘，你必须创建它。

下面的检查表能够帮助你决定你是否需要制作 PCMCIA 驱动程序盘：

  • 你要从光盘中安装红帽企业 Linux，而且你的光盘驱动器是通过 PCMCIA 卡与你的计算机相连的。

  • 你在安装中将会使用一个 PCMCIA 网络适配器。

PCMCIA 驱动程序盘的映像文件 pcmciadd.img 位于第一张红帽企业 Linux 光盘中的 images/ 目录下。关于制作磁盘的信息，请参阅第 2.5.3 节或附录 E。

注记 | 注记
 | 「USB 磁盘驱动器」 — 你还可以使用 USB 磁盘驱动器中的引导盘来引导安装程序（如果你的系统支持从 USB 磁盘驱动器中引导的话）。

2.5.2. 制作安装引导光盘

isolinux（在 Itanium 系统中不可用）现在被用来引导红帽企业 Linux 安装光盘。要创建你自己的光盘来引导安装程序，使用以下步骤：

使用以下命令把第一张红帽企业 Linux 光盘上的 isolinux/ 目录复制到临时目录（此处指代为 <path-to-workspace>）中：

cp -r <path-to-cd>/isolinux/ <path-to-workspace>

改换到你刚创建的 <path-to-workspace> 目录中：

cd <path-to-workspace>

请确定你复制的文件具备正确的权限：

chmod u+w isolinux/*

最后，使用以下命令来创建 ISO 映像文件：

mkisofs -o file.iso -b isolinux.bin -c boot.cat -no-emul-boot \
-boot-load-size 4 -boot-info-table -R -J -v -T isolinux/

注记 | 注记
 | 以上命令被分成两行只是为了印刷方便。当你执行这个命令时，请确定在单行上作为单个命令使用。

按照你的例行方式，把 ISO 映像（文件名为 file.iso，位于 <path-to-workspace>）刻录到光盘上。

2.5.3. 制作安装引导盘

isolinux（在 Itanium 系统中不可用）现在被用来引导红帽企业 Linux 安装光盘。如果你在从红帽企业 Linux 光盘中引导时遇到问题，你可以把 images/bootdisk.img 映像写到磁盘上。

如果你需要从映像文件（image file）中制作一张磁盘，你可能需要使用从下列红帽企业 Linux 勘误网页中获取的更新了的磁盘映像：

http://www.redhat.com/apps/support/errata/

映像文件含有对磁盘内容的精确复制（或映像）。由于磁盘包括了文件数据之外的文件系统信息，映像文件的内容在写入磁盘之前不能被使用。

对于 x86 和 AMD64 系统：你需要一个空白的、格式化的、高密度的（1.44MB）3.5英寸软盘，并且能够使用一个带有3.5英寸软盘驱动器的计算机。

对于 Itanium 系统：你需要一个 LS-120 磁盘和 LS-120 磁盘驱动器。

计算机必须能够运行 MS-DOS 程序或在多数类似 Linux 的操作系统上可以找到的 dd 工具。

第一张红帽企业 Linux 光盘中的 images/ 目录包含引导映像。一旦你已选择了正确的映像（bootdisk.img），把这个映像文件传输到磁盘上。

2.5.3.1. 使用 rawrite 工具

要在 MS-DOS 里制作磁盘，使用包括在第一张红帽企业 Linux 光盘里 dosutils 目录下的 rawrite 工具。首先，给一个空白的、格式化的、3.5英寸的磁盘注以恰当的标签（如“引导盘”或“更新盘”）；将它插入到磁盘驱动器中；然后，使用下列命令（假定你的光盘驱动器的盘符是 D:）：

C:\> d:
D:\> cd \dosutils
D:\dosutils> rawrite
Enter disk image source file name: ..\images\bootdisk.img
Enter target diskette drive: a:
Please insert a formatted diskette into drive A: and
press --ENTER-- : [Enter]
D:\dosutils>

首先，rawrite 会向你询问磁盘映像的文件名；输入你要写入的映像目录和名称（例如，..\images\bootdisk.img）。然后，rawrite 会向你询问要写入映像的磁盘驱动器的盘符，输入a:。最后，rawrite 会请你确认在你选定的驱动器内已插入格式化的磁盘。在按 [Enter] 键确认后，rawrite 就会把映像文件复制到磁盘中去。如果你要制作另一个磁盘，给磁盘标签，然后运行 rawrite，指定恰当的映像文件。

注记 | 注记
 | rawrite 工具只接受 8.3 类型的文件名，如 filename.img [2]。如果你从 http://www.redhat.com/ 下载的映像文件，其名称类似于 update-anaconda-03292002.img，你必须在运行 rawrite 之前把它重命名为 updates.img。

2.5.3.2. 使用 dd 命令

要在 Linux（或任何其它与 Linux 相仿的操作系统）下制作磁盘，你必须有到磁盘驱动器设备（在 Linux 中是 /dev/fd0 ）的写权限。

首先，给一张空白的、格式化的磁盘恰当地注以标签（如引导盘或更新盘）。把它插入到磁盘驱动器中（但是不要使用 mount [3] 命令）。在挂载红帽企业 Linux 光盘之后，转到含有所需映像文件的目录，然后使用下列命令（请适当地改变映像文件和磁盘设备的名称）：

dd if=bootdisk.img of=/dev/fd0 bs=1440k

要制作另一张磁盘，给那个磁盘注以标签，然后再运行 dd ，指定恰当的映像文件。

注

[1] | 引导盘是你创建的用来引导（或启动）安装程序的磁盘，它还可以是你在安装过程中创建的可用在今后引导操作系统的磁盘。你的计算机通常从硬盘中引导，但是如果硬盘被损坏，你可以从一个可引导的磁盘中引导计算机。
[2] | 8.3 格式文件名的命名约定是：八个字符，加一点，再加三个字符的文件扩展名。这种命名约定支持一到八个字符长的文件名，其中不能包括空格，文件名不能 以 「?」 或 「_」 字符开头。
[3] | 当你挂载一个软盘或光盘时，这些设备上的内容就可被你利用。
后退 | 起点 | 前进
你有足够的磁盘空间吗？ | 上级 | 筹备网络安装


筹备网络安装

后退 第 2章 . 安装前的准备工作 前进

2.6. 筹备网络安装

注记 | 注记
 | 如果你执行的是基于网络的安装，请确定安装光盘（或其它类型的光盘）不在提供服务的系统的驱动器内。否则可能会导致不期而至的错误。

不管是网络安装（NFS、FTP、HTTP）还是通过本地贮存区的安装，你都必须要有红帽企业 Linux 安装介质。如果你执行的是 NFS、FTP、或 HTTP 安装，请使用以下步骤。

通过网络安装所要使用的 NFS、FTP、HTTP 服务器必须是能够提供完整 RedHat/ 目录的单独机器。RedHat/base/ 和 RedHat/RPMS/ 目录都必须存在并能够被利用，而且包含所有安装光盘中的所有文件。

注记 | 注记
 | 下面指定的目录是指 /location/of/disk/space/。这意味着它是上一级目录，但是不包括 RedHat/ 发行目录。例如，如果安装服务器上的 /export/redhat/ 目录中有红帽企业 Linux 3 安装文件，/location/of/disk/space/ 就会是 /export/redhat/。

要从安装光盘中把 RedHat/ 目录复制到充当安装服务器的 Linux 机器上，执行以下步骤：

  • 对每个二进制光盘，执行以下命令：

    • mount /mnt/cdrom

    • cp -var /mnt/cdrom/RedHat /location/of/disk/space

      这里的 /location/of/disk/space/ 是你创建的目录，如 /export/redhat/。

    • umount /mnt/cdrom/

  • 请注意，发行注记没有包括在 RedHat 目录中。除非它们被特意复制了，你在安装红帽企业 Linux 时将不会看到发行注记。发行注记的格式是 HTML，位于光盘的根目录。你可以把它们复制到你的安装目录中。例如：

    cp /mnt/cdrom/RELEASE-NOTES*.html /location/of/disk/space/

    发行注记可从在以下网址上查看：http://www.redhat.com/docs/。

  • 接下来，使安装程序能够通过 NFS、FTP、或 HTTP 进入 /location/of/disk/space/，然后从客户校验一下。

  • 对于 NFS，通过在 /etc/exports 中添加项目来导出指定的系统：

    /location/of/disk/space client.ip.address(ro,no_root_squash)

    要导出到所有机器（不适用于所有 NFS 系统），添加：

    /location/of/disk/space *(ro,no_root_squash)

    启动 NFS 守护进程（在红帽企业 Linux 机器上，使用 /sbin/service nfs start）。如果 NFS 已在运行，则重新载入配置文件（在红帽企业 Linux 系统上，使用 /usr/bin/service nfs reload）。

    请确定使用《红帽企业 Linux 系统管理指南》中的说明来测试 NFS 共享。

    如果 RedHat/ 目录没有在 NFS 共享目录中出现，你挂载或导出的路径可能不正确。

  • FTP 和 HTTP 安装还支持第二类树形结构。要使它更容易地存取安装光盘的内容，在 FTP 或 HTTP 服务器上使用以下挂载点挂载每个光盘或 ISO 映像（这里的 X 是光盘或 ISO 映像的号码）：

    /location/of/disk/space/discX/

    例如：

    mount -o loop CD1.iso /location/of/disk/space/disc1/

2.6.1. 使用 ISO 映像进行 NFS 安装

NFS 安装可以使用 ISO（或光盘）映像，而不必使用整个安装树。把所需要的 ISO 映像（二进制红帽企业 Linux 光盘）存放到某目录中后，选择通过 NFS 来安装。这样，你就会把安装程序指向要执行安装的目录。

在试图安装前，请校验 ISO 映像的完整性。这会帮助你避免硬盘安装过程中经常会遇到的问题。要在执行安装前校验 ISO 映像的完整性，请使用 md5sum 程序（该程序有适用于各类操作系统的版本）。md5sum 程序应该可以在提供 ISO 映像的同一服务器上找到。

注记 注记

ISO 映像中嵌入了 md5sum。要测试 ISO 映像校验和的完好性，在安装引导提示下键入（Itanium 系统后面加上 elilo）：

linux mediacheck

除此之外，如果你的安装目录中还有一个叫 updates.img 的文件，那么它就可以用于安装程序更新。请参考 anaconda RPM 软件包中的 install-methods.txt 文件来获取关于各类安装红帽企业 Linux 的途径，以及应用安装程序更新的详情。

注记 | 注记
 | 你在该目录中只能有一类红帽企业 Linux 发行版本的 ISO 映像。
后退 | 起点 | 前进
你能用光盘安装吗？ | 上级 | 筹备硬盘驱动器安装


你有足够的磁盘空间吗？

后退 第 2章 . 安装前的准备工作 前进

2.4. 你有足够的磁盘空间吗？

几乎每一个现代操作系统（OS）都使用磁盘分区（disk partitions），红帽企业 Linux 也不例外。当你安装红帽企业 Linux 时，你可能也得使用磁盘分区。如果你从前没有接触过磁盘分区（或者需要温习一下基本概念），在继续前请阅读附录 D。

红帽企业 Linux 使用的磁盘空间必须和在你的系统上可能安装的其它 OS 所用的磁盘空间分离，如 Windows、OS/2、甚至于不同版本的 Linux。对于基于 x86 和 AMD64 的系统，至少两个分区（/ 和 swap）必须要专用于红帽企业 Linux。 对于 Itanium 系统，至少三个分区（/、/boot/efi 和 swap）必须专用于红帽企业 Linux。

在你开始安装进程之前，必须要满足以下条件之一：

  • 你的计算机必须有足够的未分区[1]的磁盘空间来安装红帽企业 Linux。

  • 你必须有一个或多个可以删除的分区，因此能够空出足够的空间来安装红帽企业 Linux。

要更清除地了解你真正需要多少空间，请参阅第 4.17.4 节中所讨论的推荐分区大小。

如果不能肯定你是否满足了这些条件，或者想了解该如何为你的红帽企业 Linux 安装创建空闲空间，请参阅附录 D。

注

[1]

未分区的磁盘空间意味着在你要安装的硬盘驱动器上的可用磁盘空间还没有为数据而划分成块。当你为一个磁盘分区时，每个分区都如同一个独立的磁盘驱动器。

后退 | 起点 | 前进
你的硬件兼容吗？ | 上级 | 你能用光盘安装吗？


注册您的产品

后退 第 2章 . 安装前的准备工作 前进

2.2. 注册您的产品

注册会使您能够使用您购买的红帽服务，例如技术支持和红帽网络。要注册您的产品，请访问：

http://www.redhat.com/apps/activate/

注记 | 注记
 | 在试图连接红帽网络之前，您必须激活产品。如果产品没有激活，红帽网络会拒绝系统在无资格获得的频道中注册。
后退 | 起点 | 前进
安装前的准备工作 | 上级 | 你的硬件兼容吗？


时区配置

后退 第 4章 . 安装红帽企业 Linux 前进

4.22. 时区配置

你可以通过选择你的计算机的物理位置，或者指定你的时区和通用协调时间（UTC）间的偏移来设置你的时区。

请注意屏幕上端的两个标签（参见图 4-21）。第一个标签允许你按位置来配置时区。

在互动地图上，你还可以点击一个用黄点标记的指定城市，一个红色的 X 会出现来标明你的选择。你还可以在一个列表中滚动选择一个时区。

第二个标签允许你指定 UTC 偏移。这个标签显示了一个可从中选择的偏移列表，以及设立夏时制的选项。

图 4-21. 配置时区

在两个标签上，你都可以选择「系统时钟使用 UTC」。如果你知道你的系统是设置到 UTC 的话，选择此项。

窍门 | 窍门
 | 要在安装完成后改变你的时区配置，请使用时间和日期属性工具。 在 shell 提示下键入 redhat-config-date 命令来启动时间和日期属性工具。如果你不是根用户，它会提示你输入根口令后再继续。 要作为基于文本的程序来运行时间和日期属性工具，使用 timeconfig 命令。
后退 | 起点 | 前进
语言支持的选择 | 上级 | 设置根口令


安装后的问题

后退 附录 C. 安装红帽企业 Linux 中的故障排除 前进

C.4. 安装后的问题

C.4.1. 在基于 x86 系统的 GRUB 图形化屏幕中遇到问题

如果由于某种原因，你需要禁用图形化引导屏幕，你可以用根用户身份编辑 /boot/grub/grub.conf 文件，然后重新引导系统来达到这一目的。

编辑方法是，把 grub.conf 文件中开头为 splashimage 的行变为注释。要将某一行变为注释，在这一行的起首插入 # 字符。

当你重新引导后，grub.conf 文件将会被重读，你所做的改变就会生效。

你可以重新启用图形化引导屏幕，方法是在 grub.conf 文件中不注释掉（或添加）以上提到的那一行。

C.4.2. 在基于 x86 系统的 LILO 图形化屏幕中遇到问题

如果由于某种原因，你需要禁用图形化引导屏幕，你可以用根用户身份编辑 /etc/lilo.conf 文件，然后重新运行 LILO 来达到这一目的。

首先，作为根用户把 /etc/lilo.conf 文件中 message=/boot/message 这一行变为注释（或删除）。要将某一行变为注释，在这一行的起首插入 ; 字符。其次，键入 /sbin/lilo -v 来重新运行 LILO。下一次引导时，你将会见到提示 LILO:，如同从前的红帽企业 Linux 发行版本中一样。

你可以重新启用图形化引导屏幕，方法是在 lilo.conf 文件中添加（或不注释掉）以上提到的句行，然后重新运行 LILO。

C.4.3. 引导入图形环境

如果你安装了 X 窗口系统，但是在登录了红帽企业 Linux 系统后却看不到图形化桌面环境，你可以使用 startx 命令来启动 X 窗口系统图形化界面。

输入了该命令后，按 [Enter] 键，图形化界面就会被显示。

不过请注意，这只在这一次中有效，并不会改变未来的登录进程。

要设置你的系统从而使你能够使用图形化屏幕登录，你必须编辑 /etc/inittab 这个文件，只需改变运行级别部分中的一个数字即可。编辑完毕后，重新引导计算机，你下次登录时就会看到图形化登录提示。

打开 shell 提示。如果你登录的是你的用户账号，键入 su 命令来变成根用户身份。

现在，键入 gedit /etc/inittab 来使用 gedit 编辑这个文件。/etc/inittab 文件就会打开。在第一个屏幕上，你会看到类似以下的部分：

# Default runlevel. The runlevels used by RHS are:
#   0 - halt (Do NOT set initdefault to this)
#   1 - Single user mode
#   2 - Multiuser, without NFS (The same as 3, if you do not have networking)
#   3 - Full multiuser mode
#   4 - unused
#   5 - X11
#   6 - reboot (Do NOT set initdefault to this)
#
id:3:initdefault:

要把登录从控制台改为图形化，你需要把 id:3:initdefault: 这一行中的数字从 3 改为 5。

警告 | 警告
 | 请只把默认的运行级别数字从 3 改为 5。

你改后的那一行应该类似：

          id:5:initdefault:

当你对所做改变满意后，使用[Ctrl]-[x]键组合来保存并退出该文件。你会看到一条消息通知你这个文件已被修改，并请你确认所做改变。键入 [Y] 来表示肯定。

现在，你重新引导后的登录屏幕就会是图形化的了。

C.4.4. 引导入 X 窗口系统（GUI）的问题

如果你在启动 X（X 窗口系统）时遇到问题，你可能在安装过程中没有安装它。

如果你想要使用 X 窗口系统，你可以从红帽企业 Linux 光盘中安装相应软件包或执行升级。

如果你选择了升级，选择 X 窗口系统软件包组，然后在升级软件包选择过程中选择 GNOME、KDE、或两者皆选。

C.4.5. 登录时的问题

如果你在设置代理中没有创建一个用户帐号，你就必须登录为根用户，然后使用你给根用户设立的口令。

如果你没有记住根口令，你需要把系统引导为 linux single。

Itanium 用户必须使用 elilo 来输入引导命令。

如果你使用的是基于 x86 的系统，GRUB 是你所安装的引导装载程序，载入了 GRUB 引导屏幕后，键入 e 来编辑。你会看到你所选定的引导标签的配置文件中的项目列表。

选择以 kernel 开头的那一行，然后键入 e来编辑该项引导项目。

在 kernel 行的结尾处，添加：

single

按 [Enter] 键来退出编辑模式。

回到 GRUB 屏幕后，键入 b 来引导单用户模式。

如果你使用的是基于 x86 的系统，LILO 是你所安装的引导装载程序，按 [Ctrl]-[x] 来退出图形化 LILO 屏幕，回到 LILO boot: 提示下。

下一步，在 LILO boot: 提示下输入 linux single。

一旦你引导入了单用户模式，你就会看到 # 提示符，你必须键入 passwd root，它将会允许你为根用户输入一个新口令。这时候，你可以键入 shutdown -r now 来使用新的根口令重新引导系统。

如果你忘记了你的用户帐号口令，你必须变成根用户。要变成根用户，键入 su - ，在提示后输入根口令，然后键入 passwd <username>。这将会允许你为某一指定的用户帐号输入一个新口令。

如果你看不到图形化登录屏幕，请检查一下你的硬件是否兼容。“硬件兼容性列表”可在以下网页上找到：

http://hardware.redhat.com/hcl/

C.4.6. 你的内存不能够被识别吗？

有时，内核不能识别你的全部内存（RAM）。你可以用 cat /proc/meminfo 命令来校验。

查看一下所显示的数量是否与你所知的系统内存相同。如果不同，在 /boot/grub/grub.conf 文件中添加以下一行：

mem=xxM

把 xx 替换成你拥有的内存数量（以 MB 为单位）。

在 /boot/grub/grub.conf 文件中，以上的例子与下面相似：,

#NOTICE: You have a /boot partition. This means that
#        all kernel paths are relative to /boot/
default=0
timeout=30
splashimage=(hd0,0)/grub/splash.xpm.gz
title 红帽企业 Linux (2.4.21-1.1931.2.399.ent)
        root (hd0,0)
        kernel /vmlinuz-2.4.21-1.1931.2.399.ent ro root=/dev/hda3 mem=128M

当你重新引导后，grub.conf 文件中的改变将会反映在你的系统中。

或者，你可以在 /etc/lilo.conf 文件中添加以下一行：

append="mem=xxM"

注意，append 命令在 GRUB 和 LILO 中都可用。

把 xx 替换成你拥有的内存数量（以 MB 为单位）。 切记，每映像后补的行会完全覆写全局后补的行。把这行添加到每映像描述中可能值得一试。

在 /etc/lilo.conf 文件中，以上的例子与下面相似：

boot=/dev/sda
      map=/boot/map
      install=/boot/boot.b
      prompt
      timeout=50

      image=/boot/vmlinuz-2.4.21-1.1931.2.399.ent
              label=linux
              root=/dev/sda1
              initrd=/boot/initrd-2.4.21-1.1931.2.399.ent.img
              read-only
              append="mem=128M"

记住在改变了 /etc/lilo.conf 文件后运行 /sbin/lilo -v 命令。

请注意，在 GRUB 或 LILO 中指定所用标签（映像）时传递这一选项可以获得同样的效果。

当你已载入 GRUB 引导屏幕后，键入 e 来编辑。 你所选定的引导标签的配置文件中的项目列表就会在你面前出现。

选择开头为 kernel 的行，然后键入 e 来编辑这一引导项目。

在 kernel 行的末尾，添加：

mem=xxM

或

append=xxM

这里的 xx 与你系统的内存数量相同。

按 [Enter] 键来退出编辑模式。

回到 GRUB 屏幕后，键入 b 来用你的新内存指数引导。

在图形化的 LILO 屏幕上，按 [Ctrl]-[x] 退回到 boot: 提示。接下来，在 boot: 提示下输入：

linux mem=xxM

Itanium 用户必须使用 elilo 来输入引导命令。

请记住将 xx 替换成你系统的内存数量。按 [Enter] 键来引导。

C.4.7. 你的打印机无法运行

如果你不能肯定该如何设置打印机，或者你在设置过程中遇到问题，请使用打印机配置工具。

在 shell 提示下键入 redhat-config-printer 命令来启动打印机配置工具。如果你不是根用户，它会提示你输入根口令后再继续。

C.4.8. 配置声卡遇到问题

如果由于某种原因，你听不到声音，但是你知道自己安装了一个声卡，你可以运行声卡配置工具（redhat-config-soundcard）。

要使用声卡配置工具，选择「主菜单」 => 「系统设置」 => 「声卡检测」，一个小型的文本箱就会弹出，提示你输入根口令。

你还可以在 shell 提示下键入 redhat-config-soundcard 命令来启动声卡配置工具。如果你不是根用户，它会提示你输入根口令后再继续。

要运行基于文本的配置工具，在终端窗口中以根用户身份键入 sndconfig。注意，sndconfig 程序没有被默认安装，但是你可以在红帽企业 Linux 的光盘上找到它。

如果声卡配置工具不起作用（如果声音示例播放不出，你仍听不到音频输出），你还可以使用其它几种方法，不过这些方法没有运行声卡配置工具那么简单。你可以编辑 modules.conf 文件（对多数新用户来说，不提倡使用这个办法），或者参考你的声卡附带的文档。

C.4.9. 基于 Apache 的 httpd 服务或 Sendmail 在启动时被挂起

如果你在启动基于 Apache 的 httpd 服务或 Sendmail 时遇到问题，请确定 /etc/hosts 文件中包括下面这行：

127.0.0.1  localhost.localdomain  localhost

C.4.10. NVIDIA 芯片集的问题

如果你有一个 NVIDIA 芯片集，并且刚刚更新了你的内核，你可能会遇到视频卡中的问题，例如没有视频输出。

如果你遇到了类似的问题，你应该下载用于你的 NVIDIA 芯片集的最新内核驱动程序。详情请参见：

http://www.nvidia.com/view.asp?IO=linux_display_1.0-3123
后退 | 起点 | 前进
安装过程中的问题 | 上级 | 磁盘分区简介


安装起始部分的问题

后退 附录 C. 安装红帽企业 Linux 中的故障排除 前进

C.2. 安装起始部分的问题

C.2.1. 没有检测到你的鼠标

如果「没有检测到鼠标」屏幕（参见图 C-1）出现了，这说明安装程序无法正确地识别你的鼠标。

你可以继续 GUI 安装，或者使用不需鼠标的文本模式安装。如果你选择要继续 GUI 安装，你必须向安装程序提供你的鼠标配置信息（参阅第 4.14 节）。

图 C-1. 没有检测到鼠标

C.2.2. 引导入图形化安装遇到问题

某些视频卡无法在安装程序中正确工作。其结果为引导入图形化安装程序时出现问题。

如果安装程序无法使用视频卡的默认设置来运行，它将会在较低分辨率模式中运行。如果这还不行，安装程序将会试图在文本模式中运行。

一种可行的解决方法是使用 resolution= 引导选项。该选项对便携电脑用户最有帮助。详情请参阅附录 F。

注记 | 注记
 | 要禁用帧缓冲支持，允许安装程序在文本模式中运行，请试用 nofb 引导选项。该命令对于某些带有屏幕阅读硬件的辅助功能而言可能是必不可少的。
后退 | 起点 | 前进
安装红帽企业 Linux 中的故障排除 | 上级 | 安装过程中的问题


安装过程中的问题

后退 附录 C. 安装红帽企业 Linux 中的故障排除 前进

C.3. 安装过程中的问题

C.3.1. “No devices found to install Red Hat Enterprise Linux”错误消息

如果你收到“No devices found to install Red Hat Enterprise Linux”错误消息，这可能表明某个 SCSI 控制器没有被安装程序识别。

首先，查看一下你的硬件厂商的网站来确定是否有可用的能够修正这个问题的驱动程序映像。关于驱动程序盘的常规信息，请参阅附录 E。

你还可以参考Red Hat 硬件兼容列表，位于：

http://hardware.redhat.com/hcl/

C.3.2. 没有软驱却要保存回溯追踪消息

如果你在安装中收到回溯追踪错误消息，通常你可以把它保存到软盘中。

如果你的系统中没有软驱，你可以使用 scp 命令把错误消息复制到另一个远程系统中。

当回溯追踪对话框出现时，回溯追踪消息会被自动写入一个叫做 /tmp/anacdump.txt 的文件。一旦这个对话框出现，键入[Ctrl]-[Alt]-[F2] 来切换到一个新的 tty（虚拟控制台），然后使用 scp 命令把消息写入一个已知运行的远程系统上的 /tmp/anacdump.txt 文件中。

C.3.3. 分区表问题

如果你在安装程序的「磁盘分区设置」（第 4.15 节）之后看到和以下类似的错误消息：

「设备 hda 上的分区表无法被读取。创建新分区时必须对其执行初始化，从而会导致该驱动器中的所有数据丢失。」

你在该驱动器上可能没有分区表，或者该驱动器上的分区表可能无法被安装程序中使用的分区软件识别。

使用过 EZ-BIOS 之类程序的用户遇到过类似的问题，这个问题导致了无法被恢复的数据丢失（假定安装前没有进行备份）。

无论你执行的是哪一种安装类型，你都应该为系统上的现存数据进行备份。

C.3.4. 使用剩余空间

你创建了一个 swap 和一个 /（根）分区，而且选择了要让根分区使用剩余空间，但是它并不一定会填满整个硬盘驱动器。

如果你的硬盘大于 1024 个柱面，你必须创建一个 /boot 分区才能使 /（根）分区使用你的硬盘上的所有剩余空间。

C.3.5. x86 系统用户会遇到的其它分区问题

如果你使用 Disk Druid 来创建分区，却无法前进到下一屏幕，你可能没有创建所有满足 Disk Druid 的依赖关系所必需的分区。

你至少需要有以下分区：

  • 一个 /（根）分区

  • 一个类型为 swap 的交换分区

窍门 | 窍门
 | 当把分区类型定义为 swap 时，你不必给它分派挂载点。Disk Druid 为你自动分派挂载点。

C.3.6. Itanium 系统用户会遇到的其它分区问题

如果你使用 Disk Druid 来创建分区，却无法前进到下一屏幕，你可能没有创建所有满足 Disk Druid 的依赖关系所必需的分区。

你至少需要有以下分区：

  • 一个类型为 VFAT 的 /boot/efi/ 分区

  • 一个 /（根）分区

  • 一个类型为 swap 的交换分区

窍门 | 窍门
 | 当把分区类型定义为 swap 时，你不必给它分派挂载点。Disk Druid 为你自动分派挂载点。

C.3.7. 看到 Python 错误

在某些红帽企业 Linux 的升级或安装中，安装程序（又称 Anaconda）可能会由于 Python 或 traceback 错误而失败。这个错误可能会在选择了单个软件包后发生，也可能会在试图把升级日志保存到 /tmp/ 中时发生。它看起来类似：

Traceback (innermost last):
   File "/var/tmp/anaconda-7.1//usr/lib/anaconda/iw/progress_gui.py",
line 20, in run
     rc = self.todo.doInstall ()
   File "/var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 1468, in
doInstall
     self.fstab.savePartitions ()
   File "fstab.py", line 221, in savePartitions
     sys.exit(0)
 SystemExit: 0

 Local variables in innermost frame:
 self: <fstab.GuiFstab instance at 8446fe0>
 sys: <module 'sys' (built-in)>
 ToDo object:
 (itodo
 ToDo
 p1
 (dp2
 S'method'
 p3
 (iimage
 CdromInstallMethod
 p4
 (dp5
 S'progressWindow'
 p6

 <failed>

在会发生这个错误的系统中，到 /tmp/ 的链接可能是与其它位置的符号链接，或者 /tmp/ 自从创建以来已被改变。这些符号链接或被改变的连接在安装进程中无效，因此安装程序无法在其中写入信息而失败。

如果你遇到了这样的错误，首先请下载任何用于 Anaconda 的勘误。勘误可在以下网址中找到：

http://www.redhat.com/support/errata/

anaconda 的网站也是一个有用的参考，它位于：

http://rhlinux.redhat.com/anaconda/

你还可以搜寻与这一问题有关的错误报告。要搜寻 Red Hat 的错误跟踪系统，请访问：

http://bugzilla.redhat.com/bugzilla/

最后，如果你仍面对与这个错误有关的问题，请注册你的产品， 然后联系我们的技术支持组。要注册你的产品，请访问：

http://www.redhat.com/apps/activate/
后退 | 起点 | 前进
安装起始部分的问题 | 上级 | 安装后的问题


给你的系统升级

后退 附录 A. 给你目前的系统升级 前进

A.2. 给你的系统升级

如果你在引导提示下键入 linux upgrade 来指示安装程序执行升级，「升级检查」屏幕就会出现。

注记 注记

如果 /etc/redhat-release 文件已从默认内容被改变了，在试图升级红帽企业 Linux 3 时就可能会找不到你的红帽企业 Linux 安装。

你可以使用下面的引导命令来在引导时放松对这个文件的检查：

linux upgradeany

如果你的红帽企业 Linux 安装没有作为升级选项被给出，则使用 linux upgradeany 命令。

要执行升级，选择「执行现有安装的升级」。当你做好升级准备后，点击「下一步」。

要在你的系统上执行红帽企业 Linux 的新安装，选择「执行 Red Hat Enterprise Linux 的新安装」。进一步说明请参阅第4章 。

图 A-1. 选择升级还是安装

后退 | 起点 | 前进
给你目前的系统升级 | 上级 | 升级引导装载程序配置


升级完成

后退 附录 A. 给你目前的系统升级 前进

A.5. 升级完成

祝贺你！你的红帽企业 Linux 3 升级现已完成！

你现在将会被提示做好重新启动系统的准备。如果重新引导前，介质没有被自动弹出，请不要忘记从软盘驱动器中取出磁盘，或从光盘驱动器中取出光盘。

如果你不能肯定下一步该做什么，我们建议你从其它红帽企业 Linux 指南手册着手。它们在网上或包括在你的红帽企业 Linux 产品中的红帽企业 Linux 文档光盘。

这些指南手册的 HTML、PDF、和 RPM 版本位于红帽企业 Linux 的文档光盘上。它们还可以在 http://www.redhat.com/docs/ 上找到。

注记 | 注记
 | 虽然本指南尽可能地反映了最当前的信息，但是要查看在文档定稿之前尚不及包括的信息，请参考“红帽企业 Linux 发行注记”。它可以在红帽企业 Linux 的第一张光盘上找到，也可以在 http://www.redhat.com/docs/ 上找到。

如果你是一个较有经验的用户，只想寻求些管理方面的信息，你可能会发现《红帽企业 Linux 参考指南》更有用。

关于系统管理的概况，请参考《红帽企业 Linux 系统管理介绍》。如果你需要关于系统配置的信息，你可能会发现《红帽企业 Linux 系统管理指南》对你比较有帮助。

如果你需要关于系统保安方面的信息，请参考《红帽企业 Linux 安全指南》。

不要忘记注册来获得您作为红帽顾客所应得的权益。注册使您能够得到您已购买的红帽服务，例如技术支持和红帽网络。

要注册产品，请到：

http://www.redhat.com/apps/activate/
后退 | 起点 | 前进
升级软件包 | 上级 | 删除红帽企业 Linux


升级引导装载程序配置

后退 附录 A. 给你目前的系统升级 前进

A.3. 升级引导装载程序配置

引导装载程序软件被用来在你的计算机上启动红帽企业 Linux。它还能启动其它操作系统，如 Windows。如果你使用的是红帽企业 Linux 引导装载程序软件（GRUB 或 LILO），它会被自动检测到。

图 A-2. 升级引导装载程序配置

在「引导装载程序配置屏幕」上，你的选项有：

「更新引导装载程序配置」 — 选择这个选项来保留你目前的引导装载程序配置（GRUB 或 LILO，依你目前安装的而定）然后应用更新。

「跳过引导装载程序更新」 — 如果你不想改变你目前使用的引导装载程序配置，选择这个选项。如果你使用的是第三方引导装载程序，你不应该更新引导装载程序。

「创建新的引导装载程序配置」 — 如果你想为你的系统创建一个新的引导装载程序，选择这个选项。如果你目前装有 LILO 并想转换成 GRUB，或者如果你一直在使用引导盘来引导你的红帽企业 Linux 系统，但想使用一个引导装载程序软件如 GRUB 或 LILO，你将需要创建一个新的引导装载程序配置（详情请参阅 第 A.3.1 节）。

选定后，点击「下一步」来继续。

A.3.1. 创建一个新的引导装载程序配置

为了要不使用引导盘来引导你的系统，你通常需要安装一个引导装载程序。引导装载程序是计算机启动时所运行的第一个软件，它的责任是载入操作系统内核软件并把控制转交给它，然后，内核软件再来初始化剩余的操作系统。

安装程序为你提供了两个引导装载程序：GRUB 和 LILO。

GRUB（GRand Unified Bootloader）是一个默认安装的功能强大的引导装载程序。GRUB 能够通过连锁载入另一个引导装载程序来载入多种免费和专有操作系统（连锁载入是通过载入另一个引导装载程序来载入 DOS 或 Windows 之类不被支持的操作系统的机制）。

LILO (LInux LOader) 是用于 Linux 的灵活多用的引导装载程序。它并不依赖于某一特定文件系统，能够从软盘和硬盘引导 Linux 内核映像，甚至还能够引导其它操作系统。

如果你不想把 GRUB 安装为引导装载程序，点击「改变引导装载程序」。然后，你便可以选择安装 LILO 或干脆不安装引导装载程序。

如果你目前已有一个能够引导 Linux 的引导装载程序，并且不打算覆盖当前使用的引导装载程序，点击「改变引导装载程序」按钮来选择「不安装引导装载程序」。

小心 | 小心
 | 如果你由于某种原因要不安装 GRUB 或 LILO，你将无法直接引导系统，你得使用另一种引导方法（如引导盘）。只有当你确定另有引导系统的方法时才使用该选项！

图 A-3. 引导装载程序配置

每个可引导分区都被列出，包括被其它操作系统使用的分区。包含你的系统根文件系统的分区将有一个 Red Hat Enterprise Linux（GRUB）或 linux（LILO）「标签」。其它分区也可以有引导标签。如果你想添加或改变其它被安装程序检测到的分区的标签，单击该分区来选择它，选定后，你可以点击「编辑」按钮来改变引导标签。

在你想要的引导分区旁边选择「默认」来选择你默认的可引导操作系统。你选定了默认引导映像后，安装才会继续。

注记 | 注记
 | 「标签」列中列出的信息是你在引导所需操作系统时必须在非图形化引导装载程序的引导提示下输入的信息。 一旦你已载入 GRUB 引导屏幕，使用箭头键来选择引导标签，键入 [e] 来编辑。你将会面对你所选择的引导标签的配置文件中的项目列表。 在图形化的 LILO 屏幕中，按 [Ctrl]-[x] 来退回到 boot: 提示。如果你忘记了系统中定义的引导标签，你可以随时在提示下按 [Tab] 键来显示定义引导标签的列表。

在你的服务器能够被别人亲身访问的环境中，引导装载程序口令为你提供了一种安全机制。

如果你打算安装引导装载程序，你应该创建一个口令来保护你的系统。若没有引导装载程序口令，能够访问你的系统的用户将可以向内核传递选项，从而损害你的系统安全性；若使用了引导装载程序口令，用户必须先输入口令才能选择非标准的引导选项。

如果你选择要使用引导装载程序口令来增进你的系统安全性，请确定选择标为「使用引导装载程序口令」的复选箱。

一旦选毕，输入口令并确认。

要配置更高级的引导装载程序选项，如改变驱动器顺序或向内核传递选项，请在点击「下一步」前确定选择「配置高级引导选项」。

A.3.2. 高级引导装载程序配置

现在，你已选定了要安装的引导装载程序，你还可以决定要在哪里安装引导装载程序。你可以在下面两个位置之一安装引导装载程序：

主引导记录（MBR）

这是我们推荐安装引导装载程序的地方，除非 MBR 已经在启动另一个操作系统的引导装载程序，如 System Commander。MBR 是你的硬盘驱动器上的一个特殊区域，它会被你的计算机的 BIOS 自动载入，并且是引导装载程序控制引导进程的最早地点。如果你在 MBR 上安装引导装载程序，当你的机器引导时，GRUB（或 LILO）会呈现一个引导提示。然后你便可以引导红帽企业 Linux 或其它任何你配置引导装载程序来引导的操作系统。

你的引导分区的第一个扇区

如果你已在你的系统上使用另一个引导装载系统的话，我们推荐这个位置。在这种情况下，你的另外的引导装载系统会首先取得控制权。然后你可以配置它来启动 GRUB（或 LILO），继而引导红帽企业 Linux。

小心 | 小心
 | 如果你有一个 RAID 卡，请留意某些 BIOS 不支持从 RAID 卡引导。在这类情况下， 引导装载程序不应该被安装在 RAID 阵列的 MBR 上。引导装载程序应该被安装在创建 /boot 分区所在的同一驱动器上的 MBR 。

图 A-4. 引导装载程序安装

如果你的系统只将使用红帽企业 Linux，你应该选择 MBR。

如果你想重新排列驱动器顺序，或者你的 BIOS 所返回的驱动器顺序不正确，点击「改变驱动器顺序」按钮。如果你有多个 SCSI 适配器或者兼有 SCSI 和 IDE 适配器，并想从 SCSI 设备中引导，改变驱动器顺序可能会发挥作用。

「强制使用 LBA32 (通常不需要)」选项允许你的 /boot 分区超过 1024 柱面限制。如果你的系统支持使用 LBA32 扩展来引导超过 1024 柱面限制的操作系统，并且你想把 /boot 分区放置在 1024 柱面之外，你应该选择该选项。

窍门 窍门

在为你的硬盘驱动器分区时，请注意某些较老的系统 BIOS 无法进入硬盘上前1024柱面以外的区域。如果情况如此，在你的硬盘的前1024柱面上为 /boot Linux 保留足够空间以便引导 Linux。其它 Linux 分区可以在柱面1024之后。

在 parted 中，1024柱面相当于528MB。详情请参阅：

http://www.pcguide.com/ref/hdd/bios/sizeMB504-c.html

如果你想给引导命令添加默认选项，请把它们输入到「内核参数」字段中。你输入的任何选项将会在每次引导时被传递给 Linux 内核。

A.3.3. 救援模式

如果你需要使用救援模式，有几个选项可供你选择。

  • 使用光盘来引导，在 boot: 提示下键入 linux rescue。

  • 通过根据 boot.img 映像制作的安装引导盘来引导你的系统。这种方法要求你插入红帽企业 Linux 的第一张光盘或使用硬盘上的 ISO 映像作为救援映像。一旦你用这个磁盘引导了，在 boot: 提示下键入 linux rescue。

    如果你执行的安装不是 IDE 光盘或硬盘安装，而且你在使用引导盘，你将至少需要一个事先制作的驱动程序盘。安装程序会在适当的时候提示你插入驱动程序盘。详情请参阅第 2.5.3 节或附录 E。

A.3.4. 其它可选的引导装载程序

如果你不想使用引导装载程序，你还有其它几种选择：

LOADLIN

你可以从 MS-DOS 中载入 Linux。不幸的是，这需要在 MS-DOS 分区上有一份 Linux 内核（以及一个初始内存磁盘，如果你有一个 SCSI 适配器的话）。达到这一目的的唯一方法是使用其它方法（譬如引导盘）来引导你的红帽企业 Linux 系统，然后将内核复制到 MS-DOS 分区。LOADLIN 在以下网页以及相关的镜像网站中可以找到：

ftp://metalab.unc.edu/pub/Linux/system/boot/dualboot/

和相关镜像站点。

SYSLINUX

SYSLINUX 是一个和 LOADLIN 很相似的 MS-DOS 程序。它也在以下网页以及相关网站中可以找到：

ftp://metalab.unc.edu/pub/Linux/system/boot/loaders/

和相关镜像站点。

商用引导装载程序

你可以使用商用引导装载程序来载入 Linux。例如，System Commander 和 Partition Magic 能够引导 Linux （但仍需要在你的 Linux 根分区安装 GRUB 或 LILO）。

LOADLIN 和 System Commander 之类的引导装载程序被当作第三方引导装载程序对待，它们不被红帽支持。

A.3.5. SMP 母板，GRUB，和 LILO

这个部分只与 SMP 母板有关。SMP 是对称多重处理（Symmetric Multiprocessing）的简写，它是一个通过多个 CPU 同时完成单独进程（多重处理）来提供快速性能的计算机体系。

如果安装程序检测到你的系统上有 SMP 母板，它会自动创建两个引导装载程序项目（根据你安装的引导装载程序而定），而不是通常的一个项目。

注记 | 注记
 | 带有超线程的 Intel® Pentium® 4 系统将会默认安装 SMP 内核。

在 grub.conf 中的两个 GRUB 项目将会是 Red Hat Enterprise Linux (kernel version) 和 Red Hat Enterprise Linux (kernel version-smp)。Red Hat Enterprise Linux (kernel version-smp) 将会被默认引导。然而，如果你在使用 SMP 内核时遇到困难，你可以选择引导 Red Hat Enterprise Linux (kernel version) 项目。你会保留所有像从前一样的功能，但是你将只能使用单个处理器来操作。

在 lilo.conf 中的两个 LILO 项目将会是 linux 和 linux-up。linux 项目将会被默认引导。然而，如果你在 SMP 内核中遇到困难，你可以选择引导 linux-up 项目。你保留所有会像从前一样的功能，但是你将只能使用单个处理器来操作。

后退 | 起点 | 前进
给你的系统升级 | 上级 | 升级软件包


升级软件包

后退 附录 A. 给你目前的系统升级 前进

A.4. 升级软件包

到了这一步，在所有的软件包都被升级或安装前，你不必进行任何操作。

后退 | 起点 | 前进
升级引导装载程序配置 | 上级 | 升级完成


视频卡配置

后退 第 4章 . 安装红帽企业 Linux 前进

4.27. 视频卡配置

安装程序现在将会给你一个视频卡列表，以供你选择。

如果你决定要安装 X 窗口系统软件包，你现在就有机会为你的系统配置一个 X 服务器。如果你没有选择要安装 X 窗口系统软件包，请跳到第 4.25 节。

如果你的视频卡没有出现在列表中（参见图 4-26），这说明 X 可能不支持它。不过，如果你对你的视频卡有技术上的了解，你可以选择「没列出的卡」，然后试图通过匹配视频卡的视频芯片与 X 服务器来配置它。

图 4-26. 视频卡设置

下一步，输入在你的视频卡上安装的视频内存数量。如果你不能肯定，请阅读你的视频卡文档。选择多于可用的内存不会损坏你的视频卡，但是 X 服务器可能不会正确启动。

如果你断定你选择的数值是不正确的，你可以点击「恢复原值」按钮来返回到建议的设置。

如果你宁愿安装后再配置 X 或干脆不安装， 你还可以选择「跳过 X 配置」 。

窍门 | 窍门
 | 要在安装结束后改变你的 X 配置，使用 X 配置工具。 在 shell 提示下键入 redhat-config-xfree86 命令来启动X 配置工具。如果你不是根用户，它会提示你输入根口令后再继续。
后退 | 起点 | 前进
安装软件包 | 上级 | X 配置 — 显示器和定制


欢迎使用红帽企业 Linux

后退 第 4章 . 安装红帽企业 Linux 前进

4.11. 欢迎使用红帽企业 Linux

「欢迎」屏幕不提示你做任何输入。请阅读左侧面板内的帮助文字来获得附加说明，以及关于如何注册你的红帽企业 Linux 产品的信息。

请注意屏幕左下角的「隐藏帮助」按钮。帮助屏幕是默认打开的。如果你不想查看帮助信息，点击「隐藏帮助」来把屏幕上的帮助部分最小化。

点击「下一步」按钮来继续。

后退 | 起点 | 前进
通过 HTTP 安装 | 上级 | 语言选择


x86 和 AMD64 系统的引导装载程序配置

后退 第 4章 . 安装红帽企业 Linux 前进

4.18. x86 和 AMD64 系统的引导装载程序配置

要不使用引导盘来引导你的系统，你通常需要安装一个引导装载程序。引导装载程序是计算机启动时所运行的第一个软件，它的责任是载入操作系统内核软件并把控制转交给它，然后，内核软件再初始化剩余的操作系统。

基于 x86 的安装程序为你提供了两个引导装载程序：GRUB 和 LILO。AMD64 安装程序只提供了 GRUB 引导装载程序。

GRUB（GRand Unified Bootloader）是一个默认安装的功能强大的引导装载程序。GRUB 能够通过连锁载入另一个引导装载程序来载入多种免费和专有操作系统（连锁载入是通过载入另一个引导装载程序来载入 DOS 或 Windows 之类不被支持的操作系统的机制）。

LILO (LInux LOader) 是用于 Linux 的灵活多用的引导装载程序。它并不依赖于某一特定文件系统，能够从软盘和硬盘引导 Linux 内核映像，甚至还能够引导其它操作系统。

注记 | 注记
 | LILO 作为引导装载程序选项不适用于 AMD64 系统的用户。

图 4-15. 引导装载程序配置

如果你不想把 GRUB 安装为引导装载程序，点击「改变引导装载程序」。然后，你便可以选择安装 LILO 或干脆不安装引导装载程序。

如果你目前已有一个能够引导红帽企业 Linux 的引导装载程序，并且不打算覆盖当前使用的引导装载程序，点击「改变引导装载程序」按钮来选择「不要安装引导装载程序」。

小心 | 小心
 | 如果你由于某种原因要不安装 GRUB 或 LILO，你将无法直接引导系统，你必须得使用另一种引导方法（如商用引导装载程序）。只有当你确定另有引导系统的方法时才使用该选项！

每个可引导分区都被列出，包括被其它操作系统使用的分区。包含你的系统根文件系统的分区将有一个Red Hat Enterprise Linux（GRUB）或 linux（LILO）「标签」。其它分区也可以有引导标签。如果你想添加或改变其它被安装程序检测到的分区的标签，单击该分区来选择它，选定后，你可以点击 「编辑」按钮来改变引导标签。

在你想要的引导分区旁边选择「默认」来选择你默认的可引导操作系统。你选定了默认引导映像后，安装才会继续。

注记 | 注记
 | 「标签」列中列出的信息是你在引导所需操作系统时必须在非图形化引导装载程序的引导提示下输入的信息。 一旦你已载入 GRUB 引导屏幕，使用箭头键来选择引导标签，键入 [e] 来编辑。你将会看到所选引导标签配置文件中的项目列表。 在图形化的 LILO 屏幕中，按 [Ctrl]-[x] 来退回到 boot: 提示。如果你忘记了系统中定义的引导标签，你可以随时在提示下按 [Tab] 键来显示定义引导标签的列表。

在你的服务器能够被别人亲身访问的环境中，引导装载程序口令为你提供了一种安全机制。

如果你打算安装引导装载程序，你应该创建一个口令来保护你的系统。若没有引导装载程序口令，能够进入你的系统的用户将可以向内核传递选项，从而减弱你的系统安全性；若使用了引导装载程序口令，用户必须先输入口令才能选择非标准的引导选项。

如果你选择要使用引导装载程序口令来增进你的系统安全性，请确定选择标为「使用引导装载程序口令」的复选箱。

一旦选毕，输入口令并确认。

要配置更高级的引导装载程序选项，如改变驱动器顺序或向内核传递选项，请在点击「下一步」前确定选择「配置高级引导选项」。

4.18.1. 高级引导装载程序配置

现在，你已选定了要安装的引导装载程序，你还可以决定要在哪里安装引导装载程序。你可以在下面两个位置之一安装引导装载程序：

  • 主引导记录（MBR）— 这是我们推荐安装引导装载程序的地方，除非 MBR 已经在启动另一个操作系统的引导装载程序，如 System Commander。MBR 是你的硬盘驱动器上的一个特殊区域，它会被你的计算机的 BIOS 自动载入，并且是引导装载程序控制引导进程的最早地点。如果你在 MBR 上安装引导装载程序，当你的机器引导时，GRUB（或 LILO）会呈现一个引导提示。然后你便可以引导红帽企业 Linux 或其它任何你配置要引导的操作系统。

  • 引导分区的第一个扇区 — 如果你已在系统上使用另一个引导装载系统的话，我们推荐这个位置。在这种情况下，你的另外的引导装载系统会首先取得控制权。然后你可以配置它来启动 GRUB（或 LILO），继而引导红帽企业 Linux.

图 4-16. 引导装载程序安装

小心 | 小心
 | 如果你有一个 RAID 卡，请留意某些 BIOS 不支持从 RAID 卡引导。在这类情况下，引导装载程序不应该被安装在 RAID 阵列的 MBR 上。引导装载程序应该被安装在创建 /boot 分区所在的同一驱动器上的 MBR。

如果你的系统只将使用红帽企业 Linux，你应该选择 MBR。

如果你想重新排列驱动器顺序，或者你的 BIOS 所返回的驱动器顺序不正确，点击「改变驱动器顺序」按钮。如果你有多个 SCSI 适配器或者兼有 SCSI 和 IDE 适配器，并想从 SCSI 设备中引导，改变驱动器顺序可能会发挥作用。

「强制使用 LBA32 (通常不需要)」选项允许你的 /boot 分区超过 1024 柱面限制。如果你的系统支持使用 LBA32 扩展来引导超过 1024 柱面限制的操作系统，并且你想把 /boot 分区放置在 1024 柱面之外，你应该选择该选项。

窍门 窍门

在为你的硬盘驱动器分区时，请注意某些较老的系统 BIOS 无法进入硬盘上前1024柱面以外的区域。如果情况如此，在你的硬盘的前1024柱面上为 /boot Linux 保留足够空间以便引导 Linux。其它 Linux 分区可以在柱面1024之后。

在 parted 中，1024柱面相当于528MB。详情请参阅：

http://www.pcguide.com/ref/hdd/bios/sizeMB504-c.html

如果你想给引导命令添加默认选项，请把它们输入到「内核参数」字段中。你输入的任何选项将会在每次引导时被传递给 Linux 内核。

4.18.2. 救援模式

救援模式提供完全从软盘、光盘、及其它系统硬盘以外的引导方法来引导入红帽企业 Linux 环境的能力。有时候，你可能无法使红帽企业 Linux 完全运行，以至于你无法存取系统硬盘上的文件。使用救援模式，即便你无法真正从硬盘上运行红帽企业 Linux，你也可以存取贮存在系统硬盘上的文件。如果你需要救援模式，可用的选项有：

  • 使用光盘来引导 x86 或 AMD64 系统，在安装引导提示下键入 linux rescue。Itanium 用户应该键入 elilo linux rescue 来进入救援模式。

  • 通过根据 bootdisk.img 映像制作的安装引导盘来引导你的系统。这种方法要求你插入红帽企业 Linux 的第一张光盘或硬盘上的 ISO 映像作为救援映像。一旦你用该磁盘引导了，在 boot: 提示下键入 linux rescue。Itanium 用户应该键入 elilo linux rescue 来进入救援模式。

关于救援模式的详情，请参阅《红帽企业 Linux 系统管理指南》。

4.18.3. 其它可选的引导装载程序

如果你不想使用引导装载程序，你还有其它几种选择：

LOADLIN

你可以从 MS-DOS 中载入 Linux。不幸的是，这需要在 MS-DOS 分区上有一份 Linux 内核（以及一个初始内存磁盘，如果你有一个 SCSI 适配器的话）。达到这一目的的唯一方法是使用其它方法（譬如引导盘）来引导你的红帽企业 Linux 系统，然后将内核复制到 MS-DOS 分区。LOADLIN 在以下网页以及相关的镜像网站中可以找到：

ftp://metalab.unc.edu/pub/Linux/system/boot/dualboot/

和相关镜像站点。

SYSLINUX

SYSLINUX 是一个和 LOADLIN 很相似的 MS-DOS 程序。它也在以下网页以及相关网站中可以找到：

ftp://metalab.unc.edu/pub/Linux/system/boot/loaders/

和相关镜像站点。

商用引导装载程序

你可以使用商用引导装载程序来载入 Linux。例如，System Commander 和 Partition Magic 能够引导 Linux （但仍需要在你的 Linux 根分区安装 GRUB 或 LILO）。

注记 | 注记
 | LOADLIN 和 System Commander 之类的引导装载程序被当作第三方引导装载程序对待，它们不被红帽支持。

4.18.4. SMP 母板，GRUB，和 LILO

这个部分只与 SMP 母板有关。SMP 是对称多重处理（Symmetric Multiprocessing）的简写，它是一个通过多个 CPU 同时完成单独进程（多重处理）来提供快速性能的计算机体系。

如果安装程序检测到你的系统上有 SMP 母板，它会自动创建两个引导装载程序项目。

注记 | 注记
 | 带有超线程的 Intel® Pentium® 4 系统将会默认安装 SMP 内核。

在 grub.conf 中的两个 GRUB 项目将会是 Red Hat Enterprise Linux (kernel version) 和 Red Hat Enterprise Linux (kernel version-smp)。Red Hat Enterprise Linux (kernel version-smp) 将会被默认引导。然而，如果你在使用 SMP 内核时遇到困难，你可以选择引导 Red Hat Enterprise Linux (kernel version) 项目。你会保留所有和从前一样的功能，但是你将只能使用单个处理器来操作。

在 lilo.conf 中的两个 LILO 项目将会是 linux 和 linux-up。 linux 项目将会被默认引导。然而，如果你在 SMP 内核中遇到困难，你可以选择引导 linux-up 项目。你会保留所有和从前一样的功能，但是你将只会使用单个处理器来操作。

后退 | 起点 | 前进
为你的系统分区 | 上级 | 网络配置


启动安装程序

后退 第 4章 . 安装红帽企业 Linux 前进

4.3. 启动安装程序

要开始安装，你必须首先引导安装程序。请确定你已具备安装中将会用到的所有资料。如果你已经通读了一遍第2章 ，而且遵循了其中的说明，你应该已经一切就绪。

注记 | 注记
 | 偶尔，某些硬件在安装中需要一个驱动程序盘（driver disk）。驱动程序盘为安装程序不支持的硬件添加支持。详情请参阅附录 E。

4.3.1. 在 x86 和 AMD64 系统上引导安装程序

你可以使用下列任何介质来引导安装程序（这要根据你的系统所能支持的而定）：

  • 红帽企业 Linux 光盘 — 你的机器支持可引导的光盘驱动器，并且你有一组红帽企业 Linux 光盘。

  • 可引导的光盘 — 你的机器支持可引导的光盘驱动器，并且你想执行网络或硬盘驱动器安装。

  • 引导盘 — 你的机器不支持可引导光盘，并且你想从本地光盘、网络或硬盘驱动器[1]中安装。

要创建一个引导光盘，请参阅第 2.5.2 节。

要创建引导盘，请参阅 第 2.5.3 节。

将引导盘插入到你的计算机的第一个软盘驱动器内，然后重新引导（或使用光盘来引导，如果你的计算机支持的话）。你可能需要改变你的 BIOS 设置来允许你从软盘或光盘中引导。

窍门 | 窍门
 | 要改变你在 x86 或 AMD64 系统上的 BIOS 设置，请阅读计算机刚开始引导时所显示的说明。你会看到一行文字，告诉你按 [Del] 或 [F1] 键来进入 BIOS 设置。 当你进入了 BIOS 设置程序之后，查找能够改变你的引导顺序的部分。默认值通常是 C、A 或 A、 C（根据你是从硬盘 [C] 还是软盘驱动器 [A] 中引导而定）。请改变该顺序，使光盘位于该引导顺序的最前面，接下来是 C 或 A（你的典型默认引导的那一个）。这会指示计算机首先在光盘驱动器内寻找可引导的介质；如果它在光盘驱动器中没有发现可引导的介质，它才会在你的硬盘或软盘驱动器中查找。 退出 BIOS 前把你做的改变存盘。要了解详细情况，请阅读你的系统附带的文档。

片刻之后，一个包含 boot: 提示的屏幕就会出现。这个屏幕包括了许多不同的引导选项。每个引导选项还有一个或多个与之关联的帮助屏幕。要访问帮助屏幕，按在屏幕底部列出的恰当的功能键。

在你引导安装程序的时候，请留意两个问题：

  • 当你看到了 boot: 提示后，如果在一分钟内不采取任何行动，安装程序会自动开始。要禁用这项功能，按帮助屏幕上的功能键之一。

  • 如果你按了帮助屏幕上的功能键，在帮助屏幕从引导介质中被读取时会出现稍微的延迟。

正常情况下，你只需按 [Enter] 键来引导。请留意引导消息以便查看 Linux 内核是否检测到了你的硬件。如果你的硬件被正确地检测到，请继续到下一个部分。如果它没有正确地检测到你的硬件，你可能会需要重新开始安装，并使用附录 F中提供的引导选项之一。

4.3.2. 在 Itanium 系统上引导安装程序

你的 Itanium 系统可能会直接从红帽企业 Linux 的第一张光盘中引导红帽企业 Linux 安装程序。如果它不能从光盘中引导安装程序（或者你想执行硬盘驱动器、NFS、FTP、或 HTTP 安装），你必须从磁盘引导。关于从磁盘引导的详情，请参阅第 4.3.2.2 节。

4.3.2.1. 从光盘中引导安装程序

要从红帽企业 Linux 的第一张光盘中引导，遵循这些步骤：

  1. 取出红帽企业 Linux 第一张光盘以外的所有介质。

  2. 从「引导选项」菜单中选择「EFI Shell」。

  3. 在 Shell> 提示下，改换到光盘中的文件系统。例如，在前面的 map 输出范例中，光盘上的系统分区是 fs1。要改换到 fs1 文件系统中，在提示下键入 fs1:。

  4. 键入 elilo linux 来引导入安装程序。

  5. 转到第4章 来开始安装。

4.3.2.2. 从 LS-120 磁盘来引导安装程序

如果你的 Itanium 无法从红帽企业 Linux 的第一张光盘引导，你必须从 LS-120 磁盘引导。如果你想执行硬盘驱动器、NFS、FTP、或 HTTP 安装，你必须从 LS-120 磁盘引导。

你必须根据第一张光盘上的引导映像文件 images/boot.img 来创建一个 LS-120 引导映像文件磁盘。要在 Linux 中创建这个磁盘，插入一张空白的 LS-120 磁盘，在 shell 提示下键入以下命令：

dd if=boot.img of=/dev/hda bs=180k

把 boot.img 替换成到引导映像文件的完整路径，把 /dev/hda 替换成用于 LS-120 磁盘驱动器的正确设备名称。

如果你不使用红帽企业 Linux 光盘，安装程序就会在文本模式中启动，你必须为你的系统选择几个基本选项。

如果你使用光盘来载入安装程序，请遵循第4章 中的说明。

要从 LS-120 磁盘中引导，请遵循这些步骤：

  1. 插入你根据 boot.img 引导映像文件来创建的 LS-120 磁盘。如果你执行的是本地光盘安装，但是要从 LS-120 磁盘引导，还需插入红帽企业 Linux 的第一张光盘。如果你执行的是硬盘驱动器、NFS、FTP、或 HTTP 安装，你就不需要光盘。

  2. 从「引导选项」菜单中选择「EFI Shell」。

  3. 在 Shell> 提示下，键入 fs0: 来把设备改成 LS-120 驱动器，使用以上的 map 输出范例。

  4. 键入 elilo linux 来引导入安装程序。

  5. 转到第4章 来开始安装。

4.3.3. 其它引导选项

对用户来说，从光盘中引导并执行图形化安装是最简便的方法，但是有些时候，在不同情况下，你可能需要用一种不同的方法来引导。本章节讨论其它可用的红帽企业 Linux 引导选项。

对于 Itanium 用户：

要给 Itanium 系统上的引导装载程序传递选项，在 EFI Shell 提示下输入以下内容：

elilo linux option

对于 x86 和 AMD64 用户：

要给 x86 或 AMD64 系统的引导装载程序传递选项，使用以下引导装载程序选项范例中的说明。

注记 | 注记
 | 请参阅附录 F来了解本章没有涉及的其它引导选项。

  • 要执行文本模式安装，在安装引导提示处键入：

    linux text

  • ISO 映像现在嵌入了 md5sum。要测试 ISO 映像校验和的完好性，在安装引导提示下键入：

    linux mediacheck

    安装程序将会提示你插入一个光盘或选择一个要测试的 ISO 映像，然后选择「确定」来执行校验和的操作。这种校验和的操作可以在任何红帽企业 Linux 光盘上执行，而且不必按指定顺序执行（例如：第一张光盘不必是第一个需要校验的光盘）。我们强烈建议你在所有从下载的 ISO 映像中创建的红帽企业 Linux 光盘上执行这一操作。该命令可用于 CD、DVD、硬盘 ISO、和 NFS ISO 安装。

  • images/ 目录中还有一个 boot.iso 文件。该文件是可用来引导安装程序的 ISO 映像。这种方法非常方便，它不必使用多个软盘来启动基于网络的安装。要使用 boot.iso，你的计算机必须能够从它的光盘驱动器引导，而且它的BIOS 设置也必须如此设置了。然后，你必须把boot.iso 文件烧录到可刻录或可写入的光盘。

  • 如果你需要在串行模式（serial mode）中执行安装，键入以下命令：

    linux console=<device>

    文本模式安装，使用：

    linux text console=<device>

    在上面的命令中，<device> 应该是你正在使用的设备（如 ttyS0 或 ttyS1）。例如：linux text console=ttyS0。

    当终端支持 UTF-8 时，使用串口终端的文本模式安装效果最好。在 UNIX 和 Linux 下，Kermit 支持 UTF-8。在 Windows 下，Kermit '95 也不错。只要安装中只使用英语，无 UTF-8 能力的终端也可以被使用。通过在安装程序引导时使用 utf8 选项，你可以使用增进的串行显示。例如：

     linux console=ttyS0 utf8

4.3.3.1. 内核选项

选项还可以被传递给内核。例如：要指示内核在一个有 128MB 内存的系统上使用全部内存，在安装引导提示下输入：

linux mem=128M

文本模式安装，使用：

linux text mem=128M

在输入了选项之后，按 [Enter] 键来使用这些选项引导。

如果你需要指定引导选项来识别你的硬件，请将它们笔录下来。安装中的配置引导装载程序部分将需要这些引导选项（详情请参阅第 4.18 节）。

4.3.3.2. 在基于 x86 的系统上不用软盘引导

红帽企业 Linux 光盘能够被支持可引导光盘的计算机引导。不是所有的计算机都支持这一功能，因此如果你的系统无法从光盘中引导，你可以使用另一种不用引导盘来启动安装的方法。下面的方法仅针对基于 x86 的计算机。

如果你的系统上装有 MS-DOS，你可以不用引导盘直接从光盘驱动器内引导。要达到这一目的（假定你的光盘驱动器是 d:），使用下列命令：

C:\> d:
D:\> cd \dosutils
D:\dosutils> autoboot.bat

这种方法如果运行在 DOS 窗口下则行不通 — autoboot.bat 文件必须在 DOS 是唯一操作系统的情况下执行。换一句话说，执行这些命令时你不能运行 Windows。

如果你的计算机无法从光盘中直接引导（并且你无法使用基于 DOS 的autoboot.bat），那么请使用引导盘来开始安装。

注

[1]

isolinux（在 Itanium 系统中不可用）被用来引导红帽企业 Linux 安装光盘。如果你从光盘引导时遇到困难，把 images/bootdisk.img 映像写入软盘。关于创建引导盘的说明，请参阅第 2.5.3 节。

后退 | 起点 | 前进
文本模式安装程序用户界面 | 上级 | 选择一种安装方法


X 配置 — 显示器和定制

后退 第 4章 . 安装红帽企业 Linux 前进

4.28. X 配置 — 显示器和定制

要完成 X 配置，你必须配置你的显示器并定制你的 X 设置。

要跳过 X 配置，请跳到第 4.29 节。

4.28.1. 配置你的显示器

安装程序会给你提供一个显示器列表。你既可以使用自动为你检测到的显示器，也可以在这个列表中另选一个。

注记 | 注记
 | 如果你在一个带有 LCD 屏幕的便携电脑上安装红帽企业 Linux，你应该选择最恰当的「通用 LCD」型号。

如果你的显示器没有在列表中出现，选择最恰当的「通用 CRT」或「通用 LCD」型号。若选择「通用 CRT」或「通用 LCD」显示器，安装程序会建议一个水平和垂直频率范围。这些数值通常在你的显示器文档中可以找到，也可从你的显示器的销售商或制造商处得到。请核对你的文档以确保这些数值被正确设置了。

小心 | 小心
 | 除非你肯定你所选显示器不超过你所用显示器的能力，不要选择与你的显示器相似的显示器。这么做可能会使你的显示器超频从而损坏它。

图 4-27. 显示器选择

安装程序为你的系统建议的水平和垂直频率范围也显示在显示器列表之下。

如果你断定你所选的显示器或频率数值不正确，你可以点击「恢复原值」按钮来返回到建议的设置中。

当显示器配置完毕后，点击「下一步」。

4.28.2. 定制配置

为你的 X 配置选择正确的色彩深度和分辨率。

你可以选择在安装结束后，你要将系统引导入文本还是图形化环境。除非你有特殊需要，推荐你引导入图形化环境（与 Windows 环境相似）。如果你选择要引导入文本环境，你将会看到一个命令提示（与 DOS 环境相似）。

图 4-28. X 定制

窍门 | 窍门
 | 要在安装结束后改变你的 X 配置，使用 X 配置工具。 在 shell 提示下键入 redhat-config-xfree86 命令来启动X 配置工具。如果你不是根用户，它会提示你输入根口令后再继续。
后退 | 起点 | 前进
视频卡配置 | 上级 | 安装完成